%global _empty_manifest_terminate_build 0 Name: python-flake8-nb Version: 0.5.3 Release: 1 Summary: Flake8 based checking for jupyter notebooks License: Apache-2.0 URL: https://github.com/s-weigand/flake8-nb Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b1/e8/660afa7a10f8211145d82a9b74affd9407b1c9f06459bfe92320f7ada850/flake8_nb-0.5.3.tar.gz BuildArch: noarch Requires: python3-flake8 Requires: python3-ipython Requires: python3-nbconvert %description # flake8-nb [![PyPi Version](https://img.shields.io/pypi/v/flake8_nb.svg)](https://pypi.org/project/flake8-nb/) [![Conda Version](https://img.shields.io/conda/vn/conda-forge/flake8-nb.svg)](https://anaconda.org/conda-forge/flake8-nb) [![Supported Python Versions](https://img.shields.io/pypi/pyversions/flake8_nb.svg)](https://pypi.org/project/flake8-nb/) [![Pre-commit](https://img.shields.io/badge/pre--commit-enabled-brightgreen?logo=pre-commit&logoColor=white)](https://github.com/pre-commit/pre-commit) [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0) [![Actions Status](https://github.com/s-weigand/flake8-nb/workflows/Tests/badge.svg)](https://github.com/s-weigand/flake8-nb/actions) [![Documentation Status](https://readthedocs.org/projects/flake8-nb/badge/?version=latest)](https://flake8-nb.readthedocs.io/en/latest/?badge=latest) [![Testing Coverage](https://codecov.io/gh/s-weigand/flake8-nb/branch/main/graph/badge.svg)](https://codecov.io/gh/s-weigand/flake8-nb) [![Documentation Coverage](https://flake8-nb.readthedocs.io/en/latest/_static/interrogate_badge.svg)](https://github.com/s-weigand/flake8-nb) [![Codacy Badge](https://app.codacy.com/project/badge/Grade/d02b436a637243a1b626b74d018c3bbe)](https://www.codacy.com/gh/s-weigand/flake8-nb/dashboard?utm_source=github.com&utm_medium=referral&utm_content=s-weigand/flake8-nb&utm_campaign=Badge_Grade) [![All Contributors](https://img.shields.io/github/all-contributors/s-weigand/flake8-nb)](#contributors) [![Code style Python: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [![Binder](https://static.mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/s-weigand/flake8-nb.git/main?urlpath=lab%2Ftree%2Ftests%2Fdata%2Fnotebooks) [`flake8`](https://github.com/pycqa/flake8) checking for jupyter notebooks. This tool is mainly aimed towards writing tutorials/lecture material, where one might also want to show off bad practices and/or errors, while still keeping the rest of the code clean and without adding the complexity of tooling to the readers (see [docs on cell tags](https://flake8-nb.readthedocs.io/en/latest/usage.html#cell-tags)). Basically this is a hack on the `flake8`'s `Application` class, which adds parsing and a cell based formatter for `*.ipynb` files. This is **NOT A PLUGIN** but a stand alone CLI tool/[pre-commit](https://pre-commit.com/) hook to be used instead of the `flake8` command/hook. ## Features - flake8 CLI tests for jupyter notebooks - Full base functionality of `flake8` and its plugins - Input cell based error formatting (Execution count/code cell count/total cellcount) - Report fine tuning with cell-tags (`flake8-noqa-tags` see [usage](https://flake8-nb.readthedocs.io/en/latest/usage.html#cell-tags)) - [pre-commit](https://pre-commit.com/) hook ## Examples ## Default reporting If you had a notebook with name `example_notebook.ipynb`, where the code cell which was executed as 34th cell (`In[34]`) had the following code: ```python bad_formatted_dict = {"missing":"space"} ``` running `flake8_nb` would result in the following output. ### Execution count ```bash $ flake8_nb example_notebook.ipynb example_notebook.ipynb#In[34]:1:31: E231 missing whitespace after ':' ``` ## Custom reporting If you prefer the reports to show the cell number rather then the execution count you can use the `--notebook-cell-format` option, given that the cell is the 5th `code` cell and 10th total cell (taking `raw` and `markdown` cells into account), you will get the following output. ### Code cell count ```bash $ flake8_nb --notebook-cell-format '{nb_path}:code_cell#{code_cell_count}' example_notebook.ipynb example_notebook.ipynb:code_cell#5:1:31: E231 missing whitespace after ':' ``` ### Total cell count ```bash $ flake8_nb --notebook-cell-format '{nb_path}:cell#{total_cell_count}' example_notebook.ipynb example_notebook.ipynb:cell#10:1:31: E231 missing whitespace after ':' ``` ## Similar projects - [nbQA](https://github.com/nbQA-dev/nbQA): Run isort, pyupgrade, mypy, pylint, flake8, mdformat, black, blacken-docs, and more on Jupyter Notebooks ## Contributors ✨ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Sebastian Weigand
Sebastian Weigand

πŸ’» πŸ€” 🚧 πŸ“† πŸš‡ ⚠️ πŸ“–
Jt Miclat
Jt Miclat

πŸ›
Philipp Eisenhauer
Philipp Eisenhauer

πŸ›
Shoma Okamoto
Shoma Okamoto

⚠️
Marco Gorelli
Marco Gorelli

πŸ”§ πŸ“–
Tony Hirst
Tony Hirst

πŸ€”
Dobatymo
Dobatymo

πŸ›
Alp ArΔ±bal
Alp ArΔ±bal

πŸ›
1kastner
1kastner

πŸ›
Dominique Sydow
Dominique Sydow

πŸ›
Liam Keegan
Liam Keegan

πŸ› πŸ’»
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package -n python3-flake8-nb Summary: Flake8 based checking for jupyter notebooks Provides: python-flake8-nb BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-flake8-nb # flake8-nb [![PyPi Version](https://img.shields.io/pypi/v/flake8_nb.svg)](https://pypi.org/project/flake8-nb/) [![Conda Version](https://img.shields.io/conda/vn/conda-forge/flake8-nb.svg)](https://anaconda.org/conda-forge/flake8-nb) [![Supported Python Versions](https://img.shields.io/pypi/pyversions/flake8_nb.svg)](https://pypi.org/project/flake8-nb/) [![Pre-commit](https://img.shields.io/badge/pre--commit-enabled-brightgreen?logo=pre-commit&logoColor=white)](https://github.com/pre-commit/pre-commit) [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0) [![Actions Status](https://github.com/s-weigand/flake8-nb/workflows/Tests/badge.svg)](https://github.com/s-weigand/flake8-nb/actions) [![Documentation Status](https://readthedocs.org/projects/flake8-nb/badge/?version=latest)](https://flake8-nb.readthedocs.io/en/latest/?badge=latest) [![Testing Coverage](https://codecov.io/gh/s-weigand/flake8-nb/branch/main/graph/badge.svg)](https://codecov.io/gh/s-weigand/flake8-nb) [![Documentation Coverage](https://flake8-nb.readthedocs.io/en/latest/_static/interrogate_badge.svg)](https://github.com/s-weigand/flake8-nb) [![Codacy Badge](https://app.codacy.com/project/badge/Grade/d02b436a637243a1b626b74d018c3bbe)](https://www.codacy.com/gh/s-weigand/flake8-nb/dashboard?utm_source=github.com&utm_medium=referral&utm_content=s-weigand/flake8-nb&utm_campaign=Badge_Grade) [![All Contributors](https://img.shields.io/github/all-contributors/s-weigand/flake8-nb)](#contributors) [![Code style Python: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [![Binder](https://static.mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/s-weigand/flake8-nb.git/main?urlpath=lab%2Ftree%2Ftests%2Fdata%2Fnotebooks) [`flake8`](https://github.com/pycqa/flake8) checking for jupyter notebooks. This tool is mainly aimed towards writing tutorials/lecture material, where one might also want to show off bad practices and/or errors, while still keeping the rest of the code clean and without adding the complexity of tooling to the readers (see [docs on cell tags](https://flake8-nb.readthedocs.io/en/latest/usage.html#cell-tags)). Basically this is a hack on the `flake8`'s `Application` class, which adds parsing and a cell based formatter for `*.ipynb` files. This is **NOT A PLUGIN** but a stand alone CLI tool/[pre-commit](https://pre-commit.com/) hook to be used instead of the `flake8` command/hook. ## Features - flake8 CLI tests for jupyter notebooks - Full base functionality of `flake8` and its plugins - Input cell based error formatting (Execution count/code cell count/total cellcount) - Report fine tuning with cell-tags (`flake8-noqa-tags` see [usage](https://flake8-nb.readthedocs.io/en/latest/usage.html#cell-tags)) - [pre-commit](https://pre-commit.com/) hook ## Examples ## Default reporting If you had a notebook with name `example_notebook.ipynb`, where the code cell which was executed as 34th cell (`In[34]`) had the following code: ```python bad_formatted_dict = {"missing":"space"} ``` running `flake8_nb` would result in the following output. ### Execution count ```bash $ flake8_nb example_notebook.ipynb example_notebook.ipynb#In[34]:1:31: E231 missing whitespace after ':' ``` ## Custom reporting If you prefer the reports to show the cell number rather then the execution count you can use the `--notebook-cell-format` option, given that the cell is the 5th `code` cell and 10th total cell (taking `raw` and `markdown` cells into account), you will get the following output. ### Code cell count ```bash $ flake8_nb --notebook-cell-format '{nb_path}:code_cell#{code_cell_count}' example_notebook.ipynb example_notebook.ipynb:code_cell#5:1:31: E231 missing whitespace after ':' ``` ### Total cell count ```bash $ flake8_nb --notebook-cell-format '{nb_path}:cell#{total_cell_count}' example_notebook.ipynb example_notebook.ipynb:cell#10:1:31: E231 missing whitespace after ':' ``` ## Similar projects - [nbQA](https://github.com/nbQA-dev/nbQA): Run isort, pyupgrade, mypy, pylint, flake8, mdformat, black, blacken-docs, and more on Jupyter Notebooks ## Contributors ✨ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Sebastian Weigand
Sebastian Weigand

πŸ’» πŸ€” 🚧 πŸ“† πŸš‡ ⚠️ πŸ“–
Jt Miclat
Jt Miclat

πŸ›
Philipp Eisenhauer
Philipp Eisenhauer

πŸ›
Shoma Okamoto
Shoma Okamoto

⚠️
Marco Gorelli
Marco Gorelli

πŸ”§ πŸ“–
Tony Hirst
Tony Hirst

πŸ€”
Dobatymo
Dobatymo

πŸ›
Alp ArΔ±bal
Alp ArΔ±bal

πŸ›
1kastner
1kastner

πŸ›
Dominique Sydow
Dominique Sydow

πŸ›
Liam Keegan
Liam Keegan

πŸ› πŸ’»
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package help Summary: Development documents and examples for flake8-nb Provides: python3-flake8-nb-doc %description help # flake8-nb [![PyPi Version](https://img.shields.io/pypi/v/flake8_nb.svg)](https://pypi.org/project/flake8-nb/) [![Conda Version](https://img.shields.io/conda/vn/conda-forge/flake8-nb.svg)](https://anaconda.org/conda-forge/flake8-nb) [![Supported Python Versions](https://img.shields.io/pypi/pyversions/flake8_nb.svg)](https://pypi.org/project/flake8-nb/) [![Pre-commit](https://img.shields.io/badge/pre--commit-enabled-brightgreen?logo=pre-commit&logoColor=white)](https://github.com/pre-commit/pre-commit) [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0) [![Actions Status](https://github.com/s-weigand/flake8-nb/workflows/Tests/badge.svg)](https://github.com/s-weigand/flake8-nb/actions) [![Documentation Status](https://readthedocs.org/projects/flake8-nb/badge/?version=latest)](https://flake8-nb.readthedocs.io/en/latest/?badge=latest) [![Testing Coverage](https://codecov.io/gh/s-weigand/flake8-nb/branch/main/graph/badge.svg)](https://codecov.io/gh/s-weigand/flake8-nb) [![Documentation Coverage](https://flake8-nb.readthedocs.io/en/latest/_static/interrogate_badge.svg)](https://github.com/s-weigand/flake8-nb) [![Codacy Badge](https://app.codacy.com/project/badge/Grade/d02b436a637243a1b626b74d018c3bbe)](https://www.codacy.com/gh/s-weigand/flake8-nb/dashboard?utm_source=github.com&utm_medium=referral&utm_content=s-weigand/flake8-nb&utm_campaign=Badge_Grade) [![All Contributors](https://img.shields.io/github/all-contributors/s-weigand/flake8-nb)](#contributors) [![Code style Python: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [![Binder](https://static.mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/s-weigand/flake8-nb.git/main?urlpath=lab%2Ftree%2Ftests%2Fdata%2Fnotebooks) [`flake8`](https://github.com/pycqa/flake8) checking for jupyter notebooks. This tool is mainly aimed towards writing tutorials/lecture material, where one might also want to show off bad practices and/or errors, while still keeping the rest of the code clean and without adding the complexity of tooling to the readers (see [docs on cell tags](https://flake8-nb.readthedocs.io/en/latest/usage.html#cell-tags)). Basically this is a hack on the `flake8`'s `Application` class, which adds parsing and a cell based formatter for `*.ipynb` files. This is **NOT A PLUGIN** but a stand alone CLI tool/[pre-commit](https://pre-commit.com/) hook to be used instead of the `flake8` command/hook. ## Features - flake8 CLI tests for jupyter notebooks - Full base functionality of `flake8` and its plugins - Input cell based error formatting (Execution count/code cell count/total cellcount) - Report fine tuning with cell-tags (`flake8-noqa-tags` see [usage](https://flake8-nb.readthedocs.io/en/latest/usage.html#cell-tags)) - [pre-commit](https://pre-commit.com/) hook ## Examples ## Default reporting If you had a notebook with name `example_notebook.ipynb`, where the code cell which was executed as 34th cell (`In[34]`) had the following code: ```python bad_formatted_dict = {"missing":"space"} ``` running `flake8_nb` would result in the following output. ### Execution count ```bash $ flake8_nb example_notebook.ipynb example_notebook.ipynb#In[34]:1:31: E231 missing whitespace after ':' ``` ## Custom reporting If you prefer the reports to show the cell number rather then the execution count you can use the `--notebook-cell-format` option, given that the cell is the 5th `code` cell and 10th total cell (taking `raw` and `markdown` cells into account), you will get the following output. ### Code cell count ```bash $ flake8_nb --notebook-cell-format '{nb_path}:code_cell#{code_cell_count}' example_notebook.ipynb example_notebook.ipynb:code_cell#5:1:31: E231 missing whitespace after ':' ``` ### Total cell count ```bash $ flake8_nb --notebook-cell-format '{nb_path}:cell#{total_cell_count}' example_notebook.ipynb example_notebook.ipynb:cell#10:1:31: E231 missing whitespace after ':' ``` ## Similar projects - [nbQA](https://github.com/nbQA-dev/nbQA): Run isort, pyupgrade, mypy, pylint, flake8, mdformat, black, blacken-docs, and more on Jupyter Notebooks ## Contributors ✨ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Sebastian Weigand
Sebastian Weigand

πŸ’» πŸ€” 🚧 πŸ“† πŸš‡ ⚠️ πŸ“–
Jt Miclat
Jt Miclat

πŸ›
Philipp Eisenhauer
Philipp Eisenhauer

πŸ›
Shoma Okamoto
Shoma Okamoto

⚠️
Marco Gorelli
Marco Gorelli

πŸ”§ πŸ“–
Tony Hirst
Tony Hirst

πŸ€”
Dobatymo
Dobatymo

πŸ›
Alp ArΔ±bal
Alp ArΔ±bal

πŸ›
1kastner
1kastner

πŸ›
Dominique Sydow
Dominique Sydow

πŸ›
Liam Keegan
Liam Keegan

πŸ› πŸ’»
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %prep %autosetup -n flake8-nb-0.5.3 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-flake8-nb -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Wed May 10 2023 Python_Bot - 0.5.3-1 - Package Spec generated