## Supervised Workflow
Classification | Regression
:-------------------------:|:-------------------------:
![](docs/images/pycaret_classification.png) | ![](docs/images/pycaret_regression.png)
## Unsupervised Workflow
Clustering | Anomaly Detection
:-------------------------:|:-------------------------:
![](docs/images/pycaret_clustering.png) | ![](docs/images/pycaret_anomaly.png)
## ⚡ PyCaret Time Series Module (beta)
PyCaret new time series module is now available in beta. Staying true to simplicity of PyCaret, it is consistent with our existing API and fully loaded with functionalities. Statistical testing, model training and selection (30+ algorithms), model analysis, automated hyperparameter tuning, experiment logging, deployment on cloud, and more. All of this with only few lines of code (just like the other modules of pycaret). If you would like to give it a try, checkout our official [quick start](https://nbviewer.org/github/pycaret/pycaret/blob/time_series_beta/time_series_101.ipynb) notebook.
:books: [Time Series Docs](https://pycaret.readthedocs.io/en/time_series/api/time_series.html)
:question: [Time Series FAQs](https://github.com/pycaret/pycaret/discussions/categories/faqs?discussions_q=category%3AFAQs+label%3Atime_series)
:rocket: [Features and Roadmap](https://github.com/pycaret/pycaret/issues/1648)
The module is still in beta. We are adding new functionalities every day and doing weekly pip releases. Please ensure to create a separate python environment to avoid dependency conflicts with main pycaret. The final release of this module will be merged with the main pycaret in next major release.
```
pip install pycaret-ts-alpha
```
![alt text](docs/images/pycaret_ts_quickdemo.gif)
## Who should use PyCaret?
PyCaret is an open source library that anybody can use. In our view the ideal target audience of PyCaret is:
- Experienced Data Scientists who want to increase productivity.
- Citizen Data Scientists who prefer a low code machine learning solution.
- Data Science Professionals who want to build rapid prototypes.
- Data Science and Machine Learning students and enthusiasts.
## PyCaret GPU support
With PyCaret >= 2.2, you can train models on GPU and speed up your workflow by 10x. To train models on GPU simply pass `use_gpu = True` in the setup function. There is no change in the use of the API, however, in some cases, additional libraries have to be installed as they are not installed with the default version or the full version. As of the latest release, the following models can be trained on GPU:
- Extreme Gradient Boosting (requires no further installation)
- CatBoost (requires no further installation)
- Light Gradient Boosting Machine requires [GPU installation](https://lightgbm.readthedocs.io/en/latest/GPU-Tutorial.html)
- Logistic Regression, Ridge Classifier, Random Forest, K Neighbors Classifier, K Neighbors Regressor, Support Vector Machine, Linear Regression, Ridge Regression, Lasso Regression requires [cuML >= 0.15](https://github.com/rapidsai/cuml)
## License
PyCaret is completely free and open-source and licensed under the [MIT](https://github.com/pycaret/pycaret/blob/master/LICENSE) license.
## Contributors
%package -n python3-pycaret-ts-alpha
Summary: PyCaret - An open source, low-code machine learning library in Python.
Provides: python-pycaret-ts-alpha
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pycaret-ts-alpha
**An open-source, low-code machine learning library in Python**
:rocket: **Version 2.3.6 out now!** [Check out the release notes here](https://github.com/pycaret/pycaret/releases).
Official •
Docs •
Install •
Tutorials •
FAQs •
Cheat sheet •
Discussions •
Contribute •
Resources •
Blog •
LinkedIn •
YouTube •
Slack
[![Python](https://img.shields.io/badge/Python-3.6%20%7C%203.7%20%7C%203.8-blue)](https://badge.fury.io/py/pycaret)
![pytest on push](https://github.com/pycaret/pycaret/workflows/pytest%20on%20push/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/pip/badge/?version=stable)](http://pip.pypa.io/en/stable/?badge=stable)
[![PyPI version](https://badge.fury.io/py/pycaret.svg)](https://badge.fury.io/py/pycaret)
[![License](https://img.shields.io/pypi/l/ansicolortags.svg)](https://img.shields.io/pypi/l/ansicolortags.svg)
[![Slack](https://img.shields.io/badge/slack-chat-green.svg?logo=slack)](https://join.slack.com/t/pycaret/shared_invite/zt-row9phbm-BoJdEVPYnGf7_NxNBP307w)
![alt text](docs/images/quick_start.gif)
## Welcome to PyCaret
PyCaret is an open-source, low-code machine learning library in Python that automates machine learning workflows. It is an end-to-end machine learning and model management tool that speeds up the experiment cycle exponentially and makes you more productive.
In comparison with the other open-source machine learning libraries, PyCaret is an alternate low-code library that can be used to replace hundreds of lines of code with few lines only. This makes experiments exponentially fast and efficient. PyCaret is essentially a Python wrapper around several machine learning libraries and frameworks such as scikit-learn, XGBoost, LightGBM, CatBoost, spaCy, Optuna, Hyperopt, Ray, and few more.
The design and simplicity of PyCaret are inspired by the emerging role of citizen data scientists, a term first used by Gartner. Citizen Data Scientists are power users who can perform both simple and moderately sophisticated analytical tasks that would previously have required more technical expertise.
| Important Links | |
| -------------------------- | -------------------------------------------------------------- |
| :star: **[Tutorials]** | New to PyCaret? Checkout our official notebooks! |
| :clipboard: **[Example Notebooks]** | Example notebooks created by community. |
| :orange_book: **[Official Blog]** | Tutorials and articles by contributors. |
| :books: **[Documentation]** | The detailed API docs of PyCaret |
| :tv: **[Video Tutorials]** | Our video tutorial from various events. |
| ✈️ **[Cheat sheet]** | Cheat sheet for all functions across modules. |
| :loudspeaker: **[Discussions]** | Have questions? Engage with community and contributors.|
| :hammer_and_wrench: **[Changelog]** | Changes and version history. |
| :deciduous_tree: **[Roadmap]** | PyCaret's software and community development plan.|
[tutorials]: https://pycaret.gitbook.io/docs/get-started/tutorials
[Example notebooks]: https://github.com/pycaret/pycaret/tree/master/examples
[Official Blog]: https://pycaret.gitbook.io/docs/learn-pycaret/official-blog
[Documentation]: https://pycaret.gitbook.io
[video tutorials]: https://pycaret.gitbook.io/docs/learn-pycaret/videos
[Cheat sheet]: https://pycaret.gitbook.io/docs/learn-pycaret/cheat-sheet
[Discussions]: https://github.com/pycaret/pycaret/discussions
[changelog]: https://pycaret.gitbook.io/docs/get-started/release-notes
[roadmap]: https://github.com/pycaret/pycaret/issues/1756
## Installation
PyCaret's default installation only installs hard dependencies as listed in the [requirements.txt](requirements.txt) file.
```python
pip install pycaret
```
To install the full version:
```python
pip install pycaret[full]
```
## Supervised Workflow
Classification | Regression
:-------------------------:|:-------------------------:
![](docs/images/pycaret_classification.png) | ![](docs/images/pycaret_regression.png)
## Unsupervised Workflow
Clustering | Anomaly Detection
:-------------------------:|:-------------------------:
![](docs/images/pycaret_clustering.png) | ![](docs/images/pycaret_anomaly.png)
## ⚡ PyCaret Time Series Module (beta)
PyCaret new time series module is now available in beta. Staying true to simplicity of PyCaret, it is consistent with our existing API and fully loaded with functionalities. Statistical testing, model training and selection (30+ algorithms), model analysis, automated hyperparameter tuning, experiment logging, deployment on cloud, and more. All of this with only few lines of code (just like the other modules of pycaret). If you would like to give it a try, checkout our official [quick start](https://nbviewer.org/github/pycaret/pycaret/blob/time_series_beta/time_series_101.ipynb) notebook.
:books: [Time Series Docs](https://pycaret.readthedocs.io/en/time_series/api/time_series.html)
:question: [Time Series FAQs](https://github.com/pycaret/pycaret/discussions/categories/faqs?discussions_q=category%3AFAQs+label%3Atime_series)
:rocket: [Features and Roadmap](https://github.com/pycaret/pycaret/issues/1648)
The module is still in beta. We are adding new functionalities every day and doing weekly pip releases. Please ensure to create a separate python environment to avoid dependency conflicts with main pycaret. The final release of this module will be merged with the main pycaret in next major release.
```
pip install pycaret-ts-alpha
```
![alt text](docs/images/pycaret_ts_quickdemo.gif)
## Who should use PyCaret?
PyCaret is an open source library that anybody can use. In our view the ideal target audience of PyCaret is:
- Experienced Data Scientists who want to increase productivity.
- Citizen Data Scientists who prefer a low code machine learning solution.
- Data Science Professionals who want to build rapid prototypes.
- Data Science and Machine Learning students and enthusiasts.
## PyCaret GPU support
With PyCaret >= 2.2, you can train models on GPU and speed up your workflow by 10x. To train models on GPU simply pass `use_gpu = True` in the setup function. There is no change in the use of the API, however, in some cases, additional libraries have to be installed as they are not installed with the default version or the full version. As of the latest release, the following models can be trained on GPU:
- Extreme Gradient Boosting (requires no further installation)
- CatBoost (requires no further installation)
- Light Gradient Boosting Machine requires [GPU installation](https://lightgbm.readthedocs.io/en/latest/GPU-Tutorial.html)
- Logistic Regression, Ridge Classifier, Random Forest, K Neighbors Classifier, K Neighbors Regressor, Support Vector Machine, Linear Regression, Ridge Regression, Lasso Regression requires [cuML >= 0.15](https://github.com/rapidsai/cuml)
## License
PyCaret is completely free and open-source and licensed under the [MIT](https://github.com/pycaret/pycaret/blob/master/LICENSE) license.
## Contributors
%package help
Summary: Development documents and examples for pycaret-ts-alpha
Provides: python3-pycaret-ts-alpha-doc
%description help
**An open-source, low-code machine learning library in Python**
:rocket: **Version 2.3.6 out now!** [Check out the release notes here](https://github.com/pycaret/pycaret/releases).
Official •
Docs •
Install •
Tutorials •
FAQs •
Cheat sheet •
Discussions •
Contribute •
Resources •
Blog •
LinkedIn •
YouTube •
Slack
[![Python](https://img.shields.io/badge/Python-3.6%20%7C%203.7%20%7C%203.8-blue)](https://badge.fury.io/py/pycaret)
![pytest on push](https://github.com/pycaret/pycaret/workflows/pytest%20on%20push/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/pip/badge/?version=stable)](http://pip.pypa.io/en/stable/?badge=stable)
[![PyPI version](https://badge.fury.io/py/pycaret.svg)](https://badge.fury.io/py/pycaret)
[![License](https://img.shields.io/pypi/l/ansicolortags.svg)](https://img.shields.io/pypi/l/ansicolortags.svg)
[![Slack](https://img.shields.io/badge/slack-chat-green.svg?logo=slack)](https://join.slack.com/t/pycaret/shared_invite/zt-row9phbm-BoJdEVPYnGf7_NxNBP307w)
![alt text](docs/images/quick_start.gif)
## Welcome to PyCaret
PyCaret is an open-source, low-code machine learning library in Python that automates machine learning workflows. It is an end-to-end machine learning and model management tool that speeds up the experiment cycle exponentially and makes you more productive.
In comparison with the other open-source machine learning libraries, PyCaret is an alternate low-code library that can be used to replace hundreds of lines of code with few lines only. This makes experiments exponentially fast and efficient. PyCaret is essentially a Python wrapper around several machine learning libraries and frameworks such as scikit-learn, XGBoost, LightGBM, CatBoost, spaCy, Optuna, Hyperopt, Ray, and few more.
The design and simplicity of PyCaret are inspired by the emerging role of citizen data scientists, a term first used by Gartner. Citizen Data Scientists are power users who can perform both simple and moderately sophisticated analytical tasks that would previously have required more technical expertise.
| Important Links | |
| -------------------------- | -------------------------------------------------------------- |
| :star: **[Tutorials]** | New to PyCaret? Checkout our official notebooks! |
| :clipboard: **[Example Notebooks]** | Example notebooks created by community. |
| :orange_book: **[Official Blog]** | Tutorials and articles by contributors. |
| :books: **[Documentation]** | The detailed API docs of PyCaret |
| :tv: **[Video Tutorials]** | Our video tutorial from various events. |
| ✈️ **[Cheat sheet]** | Cheat sheet for all functions across modules. |
| :loudspeaker: **[Discussions]** | Have questions? Engage with community and contributors.|
| :hammer_and_wrench: **[Changelog]** | Changes and version history. |
| :deciduous_tree: **[Roadmap]** | PyCaret's software and community development plan.|
[tutorials]: https://pycaret.gitbook.io/docs/get-started/tutorials
[Example notebooks]: https://github.com/pycaret/pycaret/tree/master/examples
[Official Blog]: https://pycaret.gitbook.io/docs/learn-pycaret/official-blog
[Documentation]: https://pycaret.gitbook.io
[video tutorials]: https://pycaret.gitbook.io/docs/learn-pycaret/videos
[Cheat sheet]: https://pycaret.gitbook.io/docs/learn-pycaret/cheat-sheet
[Discussions]: https://github.com/pycaret/pycaret/discussions
[changelog]: https://pycaret.gitbook.io/docs/get-started/release-notes
[roadmap]: https://github.com/pycaret/pycaret/issues/1756
## Installation
PyCaret's default installation only installs hard dependencies as listed in the [requirements.txt](requirements.txt) file.
```python
pip install pycaret
```
To install the full version:
```python
pip install pycaret[full]
```
## Supervised Workflow
Classification | Regression
:-------------------------:|:-------------------------:
![](docs/images/pycaret_classification.png) | ![](docs/images/pycaret_regression.png)
## Unsupervised Workflow
Clustering | Anomaly Detection
:-------------------------:|:-------------------------:
![](docs/images/pycaret_clustering.png) | ![](docs/images/pycaret_anomaly.png)
## ⚡ PyCaret Time Series Module (beta)
PyCaret new time series module is now available in beta. Staying true to simplicity of PyCaret, it is consistent with our existing API and fully loaded with functionalities. Statistical testing, model training and selection (30+ algorithms), model analysis, automated hyperparameter tuning, experiment logging, deployment on cloud, and more. All of this with only few lines of code (just like the other modules of pycaret). If you would like to give it a try, checkout our official [quick start](https://nbviewer.org/github/pycaret/pycaret/blob/time_series_beta/time_series_101.ipynb) notebook.
:books: [Time Series Docs](https://pycaret.readthedocs.io/en/time_series/api/time_series.html)
:question: [Time Series FAQs](https://github.com/pycaret/pycaret/discussions/categories/faqs?discussions_q=category%3AFAQs+label%3Atime_series)
:rocket: [Features and Roadmap](https://github.com/pycaret/pycaret/issues/1648)
The module is still in beta. We are adding new functionalities every day and doing weekly pip releases. Please ensure to create a separate python environment to avoid dependency conflicts with main pycaret. The final release of this module will be merged with the main pycaret in next major release.
```
pip install pycaret-ts-alpha
```
![alt text](docs/images/pycaret_ts_quickdemo.gif)
## Who should use PyCaret?
PyCaret is an open source library that anybody can use. In our view the ideal target audience of PyCaret is:
- Experienced Data Scientists who want to increase productivity.
- Citizen Data Scientists who prefer a low code machine learning solution.
- Data Science Professionals who want to build rapid prototypes.
- Data Science and Machine Learning students and enthusiasts.
## PyCaret GPU support
With PyCaret >= 2.2, you can train models on GPU and speed up your workflow by 10x. To train models on GPU simply pass `use_gpu = True` in the setup function. There is no change in the use of the API, however, in some cases, additional libraries have to be installed as they are not installed with the default version or the full version. As of the latest release, the following models can be trained on GPU:
- Extreme Gradient Boosting (requires no further installation)
- CatBoost (requires no further installation)
- Light Gradient Boosting Machine requires [GPU installation](https://lightgbm.readthedocs.io/en/latest/GPU-Tutorial.html)
- Logistic Regression, Ridge Classifier, Random Forest, K Neighbors Classifier, K Neighbors Regressor, Support Vector Machine, Linear Regression, Ridge Regression, Lasso Regression requires [cuML >= 0.15](https://github.com/rapidsai/cuml)
## License
PyCaret is completely free and open-source and licensed under the [MIT](https://github.com/pycaret/pycaret/blob/master/LICENSE) license.
## Contributors
%prep
%autosetup -n pycaret-ts-alpha-3.0.0.dev1649017462
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pycaret-ts-alpha -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot
- 3.0.0.dev1649017462-1
- Package Spec generated