%global _empty_manifest_terminate_build 0
Name: python-pylttb
Version: 0.1.9
Release: 1
Summary: pylttb - downsampling of given series using Largest Triangle Three Buckets method.
License: MIT
URL: https://pypi.org/project/pylttb/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/3c/caea9db5d685a4a6820bf74ab89f6a2a8b0b4ed978359021a54a020561c7/pylttb-0.1.9.tar.gz
BuildArch: noarch
%description
|License: MIT|
**pylttb** is an efficient implementation of Largest Triangle Threebuckets algorithm.
The algorithm was described by Sveinn Steinarsson in his master thesis. More info and original
implementation can be found at this `page `_. The code in **pylttb** is based on this implementation
but structures computations a bit differently to leverage ``numpy`` 's array arithmetics.
%package -n python3-pylttb
Summary: pylttb - downsampling of given series using Largest Triangle Three Buckets method.
Provides: python-pylttb
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pylttb
|License: MIT|
**pylttb** is an efficient implementation of Largest Triangle Threebuckets algorithm.
The algorithm was described by Sveinn Steinarsson in his master thesis. More info and original
implementation can be found at this `page `_. The code in **pylttb** is based on this implementation
but structures computations a bit differently to leverage ``numpy`` 's array arithmetics.
%package help
Summary: Development documents and examples for pylttb
Provides: python3-pylttb-doc
%description help
|License: MIT|
**pylttb** is an efficient implementation of Largest Triangle Threebuckets algorithm.
The algorithm was described by Sveinn Steinarsson in his master thesis. More info and original
implementation can be found at this `page `_. The code in **pylttb** is based on this implementation
but structures computations a bit differently to leverage ``numpy`` 's array arithmetics.
%prep
%autosetup -n pylttb-0.1.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pylttb -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.1.9-1
- Package Spec generated