%global _empty_manifest_terminate_build 0
Name: python-EventGeometry
Version: 1.0.1
Release: 1
Summary: FastJet Contrib for computing the Energy Mover's Distance and related geometric quantities
License: GPLv2
URL: https://github.com/pkomiske/EventGeometry
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/44/ee/f6fe8f7cd638d8a42dcd0170bc51fcd9fbcfd1833b053e58d61545f2543d/EventGeometry-1.0.1.tar.gz
%description
# EventGeometry
[![build-wheels](https://github.com/pkomiske/EventGeometry/actions/workflows/build-wheels.yml/badge.svg)](https://github.com/pkomiske/EventGeometry/actions)
[![PyPI version](https://badge.fury.io/py/EventGeometry.svg)](https://pypi.org/project/EventGeometry/)
[![python versions](https://img.shields.io/pypi/pyversions/EventGeometry)](https://pypi.org/project/EventGeometry/)
EventGeometry is a Python package as well as [FastJet contrib](https://fastjet.hepforge.org/contrib/) written primarily in C++. It incorporates the [Wasserstein](https://pkomiske.github.io/Wasserstein/) package for computing Wasserstein distances (known in particle physics as the Energy Mover's Distance) into the [FastJet](http://fastjet.fr) ecosystem.
## Documentation
The Wasserstein package has good Python and C++ [documentation](https://pkomiske.github.io/Wasserstein/docs/emd/). The main additions of the EventGeometry package are a [`FastJetEvent`](https://github.com/pkomiske/EventGeometry/blob/main/EventGeometry.hh#L123-L183) class that enables events composed either of a `PseudoJet` with constituents, or a vector of PseudoJets that can represent any particles.
### Particle Weights
The EMD requires a notion of "weight" to use for each particle. EventGeometry is quite flexible in this regard, and allows for the following options:
For use primarily with hadronic/pp events:
For use primarily with e+e- events:
For more details, see the [source code](https://github.com/pkomiske/EventGeometry/blob/main/EventGeometry.hh#L186-L237).
### Pairwise Distances
The EMD also requires a notion of distance between particles. EventGeometry supports several options:
For use primarily with hadronic/pp events:
For use primarily with e+e- events:
### Preprocessors
The `EMD` and `PairwiseEMD` classes can preprocess events before computing the Energy Mover's Distance. Available preprocessors include:
- `CenterEScheme`: Computes the E-scheme axis (by adding Cartesian four-momenta) and centers the particles such that the axis is at the origin.
- `CenterPtCentroid`: Computes the pT-weighted centroid of the particles in the rapidity-azimuth plane and centers the particles such that the axis is at the origin.
- `CenterWeightedCentroid`: Computes the weighted centroid axis (according to whatever particle weight is being used) and centers the particles that the axis is at the origin.
- `MaskCircle(Rmax)`: Removes particles from the event that are farther than `Rmax` away from the axis of the event. Note that this generally only makes sense after using one of the previous Preprocessors to center the event so that the axis is defined.
## C++ Usage
The EventGeometry library can be used in header-only mode by including the file `EventGeometry.hh` (note that the path to the `wasserstein` folder should be known to the compiler). If compiling an EventGeometry library is desired, one can run `make shared` (this should work on Linux and MacOS) in order to compile a shared library with appropriate multi-threading capabilities (fully thread-safe even though FastJet may not be). In this case, one should include the line `#define DECLARE_EVENTGEOMETRY_TEMPLATES` prior to including `EventGeometry.hh` and one should also link appropriately with the EventGeometry library.
%package -n python3-EventGeometry
Summary: FastJet Contrib for computing the Energy Mover's Distance and related geometric quantities
Provides: python-EventGeometry
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-EventGeometry
# EventGeometry
[![build-wheels](https://github.com/pkomiske/EventGeometry/actions/workflows/build-wheels.yml/badge.svg)](https://github.com/pkomiske/EventGeometry/actions)
[![PyPI version](https://badge.fury.io/py/EventGeometry.svg)](https://pypi.org/project/EventGeometry/)
[![python versions](https://img.shields.io/pypi/pyversions/EventGeometry)](https://pypi.org/project/EventGeometry/)
EventGeometry is a Python package as well as [FastJet contrib](https://fastjet.hepforge.org/contrib/) written primarily in C++. It incorporates the [Wasserstein](https://pkomiske.github.io/Wasserstein/) package for computing Wasserstein distances (known in particle physics as the Energy Mover's Distance) into the [FastJet](http://fastjet.fr) ecosystem.
## Documentation
The Wasserstein package has good Python and C++ [documentation](https://pkomiske.github.io/Wasserstein/docs/emd/). The main additions of the EventGeometry package are a [`FastJetEvent`](https://github.com/pkomiske/EventGeometry/blob/main/EventGeometry.hh#L123-L183) class that enables events composed either of a `PseudoJet` with constituents, or a vector of PseudoJets that can represent any particles.
### Particle Weights
The EMD requires a notion of "weight" to use for each particle. EventGeometry is quite flexible in this regard, and allows for the following options:
For use primarily with hadronic/pp events:
For use primarily with e+e- events:
For more details, see the [source code](https://github.com/pkomiske/EventGeometry/blob/main/EventGeometry.hh#L186-L237).
### Pairwise Distances
The EMD also requires a notion of distance between particles. EventGeometry supports several options:
For use primarily with hadronic/pp events:
For use primarily with e+e- events:
### Preprocessors
The `EMD` and `PairwiseEMD` classes can preprocess events before computing the Energy Mover's Distance. Available preprocessors include:
- `CenterEScheme`: Computes the E-scheme axis (by adding Cartesian four-momenta) and centers the particles such that the axis is at the origin.
- `CenterPtCentroid`: Computes the pT-weighted centroid of the particles in the rapidity-azimuth plane and centers the particles such that the axis is at the origin.
- `CenterWeightedCentroid`: Computes the weighted centroid axis (according to whatever particle weight is being used) and centers the particles that the axis is at the origin.
- `MaskCircle(Rmax)`: Removes particles from the event that are farther than `Rmax` away from the axis of the event. Note that this generally only makes sense after using one of the previous Preprocessors to center the event so that the axis is defined.
## C++ Usage
The EventGeometry library can be used in header-only mode by including the file `EventGeometry.hh` (note that the path to the `wasserstein` folder should be known to the compiler). If compiling an EventGeometry library is desired, one can run `make shared` (this should work on Linux and MacOS) in order to compile a shared library with appropriate multi-threading capabilities (fully thread-safe even though FastJet may not be). In this case, one should include the line `#define DECLARE_EVENTGEOMETRY_TEMPLATES` prior to including `EventGeometry.hh` and one should also link appropriately with the EventGeometry library.
%package help
Summary: Development documents and examples for EventGeometry
Provides: python3-EventGeometry-doc
%description help
# EventGeometry
[![build-wheels](https://github.com/pkomiske/EventGeometry/actions/workflows/build-wheels.yml/badge.svg)](https://github.com/pkomiske/EventGeometry/actions)
[![PyPI version](https://badge.fury.io/py/EventGeometry.svg)](https://pypi.org/project/EventGeometry/)
[![python versions](https://img.shields.io/pypi/pyversions/EventGeometry)](https://pypi.org/project/EventGeometry/)
EventGeometry is a Python package as well as [FastJet contrib](https://fastjet.hepforge.org/contrib/) written primarily in C++. It incorporates the [Wasserstein](https://pkomiske.github.io/Wasserstein/) package for computing Wasserstein distances (known in particle physics as the Energy Mover's Distance) into the [FastJet](http://fastjet.fr) ecosystem.
## Documentation
The Wasserstein package has good Python and C++ [documentation](https://pkomiske.github.io/Wasserstein/docs/emd/). The main additions of the EventGeometry package are a [`FastJetEvent`](https://github.com/pkomiske/EventGeometry/blob/main/EventGeometry.hh#L123-L183) class that enables events composed either of a `PseudoJet` with constituents, or a vector of PseudoJets that can represent any particles.
### Particle Weights
The EMD requires a notion of "weight" to use for each particle. EventGeometry is quite flexible in this regard, and allows for the following options:
For use primarily with hadronic/pp events:
For use primarily with e+e- events:
For more details, see the [source code](https://github.com/pkomiske/EventGeometry/blob/main/EventGeometry.hh#L186-L237).
### Pairwise Distances
The EMD also requires a notion of distance between particles. EventGeometry supports several options:
For use primarily with hadronic/pp events:
For use primarily with e+e- events:
### Preprocessors
The `EMD` and `PairwiseEMD` classes can preprocess events before computing the Energy Mover's Distance. Available preprocessors include:
- `CenterEScheme`: Computes the E-scheme axis (by adding Cartesian four-momenta) and centers the particles such that the axis is at the origin.
- `CenterPtCentroid`: Computes the pT-weighted centroid of the particles in the rapidity-azimuth plane and centers the particles such that the axis is at the origin.
- `CenterWeightedCentroid`: Computes the weighted centroid axis (according to whatever particle weight is being used) and centers the particles that the axis is at the origin.
- `MaskCircle(Rmax)`: Removes particles from the event that are farther than `Rmax` away from the axis of the event. Note that this generally only makes sense after using one of the previous Preprocessors to center the event so that the axis is defined.
## C++ Usage
The EventGeometry library can be used in header-only mode by including the file `EventGeometry.hh` (note that the path to the `wasserstein` folder should be known to the compiler). If compiling an EventGeometry library is desired, one can run `make shared` (this should work on Linux and MacOS) in order to compile a shared library with appropriate multi-threading capabilities (fully thread-safe even though FastJet may not be). In this case, one should include the line `#define DECLARE_EVENTGEOMETRY_TEMPLATES` prior to including `EventGeometry.hh` and one should also link appropriately with the EventGeometry library.
%prep
%autosetup -n EventGeometry-1.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-EventGeometry -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 1.0.1-1
- Package Spec generated