%global _empty_manifest_terminate_build 0
Name:		python-djangofloor
Version:	1.2.11
Release:	1
Summary:	Simple configuration management and websockets with Django.
License:	CeCILL-B
URL:		https://pypi.org/project/djangofloor/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ef/50/ce0c4a46beac309af64e7945a67df518a791ed5177386488a3497b2ebf3e/djangofloor-1.2.11.tar.gz
BuildArch:	noarch

Requires:	python3-django-bootstrap3
Requires:	python3-redis
Requires:	python3-pip
Requires:	python3-asyncio-redis
Requires:	python3-gunicorn
Requires:	python3-vine
Requires:	python3-celery
Requires:	python3-django
Requires:	python3-aiohttp
Requires:	python3-attrs
Requires:	python3-chardet
Requires:	python3-multidict
Requires:	python3-async-timeout
Requires:	python3-yarl
Requires:	python3-aiohttp-wsgi
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinxcontrib-autoanysrc
Requires:	python3-django-pipeline
Requires:	python3-django-debug-toolbar
Requires:	python3-django-redis-sessions
Requires:	python3-django-redis
Requires:	python3-psutil

%description
[![Build Status](https://travis-ci.org/d9pouces/django-floor.svg?branch=master)](https://travis-ci.org/d9pouces/django-floor)
[![Documentation Status](https://readthedocs.org/projects/django-floor/badge/?version=latest)](https://django-floor.readthedocs.io/en/latest/?badge=latest)
[![PyPI version](https://badge.fury.io/py/djangofloor.svg)](https://pypi.org/project/djangofloor/)
Djangofloor helps you to quickly create Django applications that are also easy to deploy. To reach these goals, Djangofloor provides:
  * an extension to the base Django's setting, allowing to split your configuration into several files (default values provided by Djangofloor, constants values for your project, deployement parameters, local values for development),
  * an unified signal dispatcher, using bi-directionnal websockets through Celery and Redis. You can call Python and Javascript signals from the Python or the Javascript side,
  * auto-configuration for a few widespread Django apps (Django-Debug-Toolbar, Django-Redis-Sessions, Django-Pipeline) if they are present,
  * a base template using the well-known Bootstrap3 (but of course you can use any other templates),
  * valid default Django settings (like logs),
  * create new Django projects that are working and deployable out-of-the-box (even if you finally replace all default templates and views).

%package -n python3-djangofloor
Summary:	Simple configuration management and websockets with Django.
Provides:	python-djangofloor
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-djangofloor
[![Build Status](https://travis-ci.org/d9pouces/django-floor.svg?branch=master)](https://travis-ci.org/d9pouces/django-floor)
[![Documentation Status](https://readthedocs.org/projects/django-floor/badge/?version=latest)](https://django-floor.readthedocs.io/en/latest/?badge=latest)
[![PyPI version](https://badge.fury.io/py/djangofloor.svg)](https://pypi.org/project/djangofloor/)
Djangofloor helps you to quickly create Django applications that are also easy to deploy. To reach these goals, Djangofloor provides:
  * an extension to the base Django's setting, allowing to split your configuration into several files (default values provided by Djangofloor, constants values for your project, deployement parameters, local values for development),
  * an unified signal dispatcher, using bi-directionnal websockets through Celery and Redis. You can call Python and Javascript signals from the Python or the Javascript side,
  * auto-configuration for a few widespread Django apps (Django-Debug-Toolbar, Django-Redis-Sessions, Django-Pipeline) if they are present,
  * a base template using the well-known Bootstrap3 (but of course you can use any other templates),
  * valid default Django settings (like logs),
  * create new Django projects that are working and deployable out-of-the-box (even if you finally replace all default templates and views).

%package help
Summary:	Development documents and examples for djangofloor
Provides:	python3-djangofloor-doc
%description help
[![Build Status](https://travis-ci.org/d9pouces/django-floor.svg?branch=master)](https://travis-ci.org/d9pouces/django-floor)
[![Documentation Status](https://readthedocs.org/projects/django-floor/badge/?version=latest)](https://django-floor.readthedocs.io/en/latest/?badge=latest)
[![PyPI version](https://badge.fury.io/py/djangofloor.svg)](https://pypi.org/project/djangofloor/)
Djangofloor helps you to quickly create Django applications that are also easy to deploy. To reach these goals, Djangofloor provides:
  * an extension to the base Django's setting, allowing to split your configuration into several files (default values provided by Djangofloor, constants values for your project, deployement parameters, local values for development),
  * an unified signal dispatcher, using bi-directionnal websockets through Celery and Redis. You can call Python and Javascript signals from the Python or the Javascript side,
  * auto-configuration for a few widespread Django apps (Django-Debug-Toolbar, Django-Redis-Sessions, Django-Pipeline) if they are present,
  * a base template using the well-known Bootstrap3 (but of course you can use any other templates),
  * valid default Django settings (like logs),
  * create new Django projects that are working and deployable out-of-the-box (even if you finally replace all default templates and views).

%prep
%autosetup -n djangofloor-1.2.11

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-djangofloor -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.11-1
- Package Spec generated