%global _empty_manifest_terminate_build 0
Name: python-cyberpunk-theme
Version: 0.0.14
Release: 1
Summary: Dark theme for Python desktop apps
License: MIT
URL: https://github.com/pyrustic/cyberpunk-theme
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/65/a7/85477369c67f43b8736ee2a4ae78f0684fb54689954f7d8d248f612b8ea5/cyberpunk-theme-0.0.14.tar.gz
BuildArch: noarch
Requires: python3-tkstyle
%description
Cyberpunk theme made with TkStyle
# Cyberpunk-Theme
A Dark Theme for your Tkinter Python apps
This project is part of the [Pyrustic Open Ecosystem](https://pyrustic.github.io).
[Installation](#installation) | [Reference](https://github.com/pyrustic/cyberpunk-theme/tree/master/docs/reference#readme) | [TkStyle](https://github.com/pyrustic/tkstyle)
## Usage
Thanks to [TkStyle](https://github.com/pyrustic/tkstyle), the `cyberpunk-theme` is both flexible and easy to use.
### Set the theme
```python
import tkinter as tk
from cyberpunk_theme import Cyberpunk
# root
root = tk.Tk()
# apply the Cyberpunk theme to the GUI
cyberpunk_theme = Cyberpunk()
cyberpunk_theme.target(root)
# From now on, the theme applies to the entire GUI
# (your awesome code)
# ...
# mainloop
root.mainloop()
```
What if you want to customize the style of a specific widget ?
### Style a specific widget
Each generic widget has a default style which can be retrieved via a function named `get_{widget-name}_style_1'`.
Some generic widgets like the `Button` widget have multiple styles.
```python
import tkinter as tk
from cyberpunk_theme.widget.button import get_button_dark_style
# root
root = tk.Tk()
# button
button = tk.Button(root, text="Click")
button.pack()
# style
button_style_1 = get_button_dark_style()
button_style_1.target(button)
# mainloop
root.mainloop()
```
The generic `Button` widget has up to ten styles.
The package [megawidget](https://github.com/pyrustic/megawidget) contains a collection of useful custom widgets built with the standard tkinter widgets.
You can set specific styles to `megawidgets` too !
### Style a specific megawidget
```python
import tkinter as tk
from megawidget.table import Table
from cyberpunk_theme.megawidget.table import get_table_style_1
# root
root = tk.Tk()
# the table megawidget
titles = ("Name", "Age")
data = [("Jack", 39), ("Jane", 42)]
table = Table(root, titles=titles, data=data)
table.pack()
# style the table
table_style_1 = get_table_style_1()
table_style_1.target(table)
# mainloop
root.mainloop()
```
## Create your own theme
You can create your own theme or style, or modify the `cyberpunk-theme` as you wish.
Check out [TkStyle](https://github.com/pyrustic/tkstyle) !
## Installation
```bash
$ pip install cyberpunk-theme
```
%package -n python3-cyberpunk-theme
Summary: Dark theme for Python desktop apps
Provides: python-cyberpunk-theme
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cyberpunk-theme
Cyberpunk theme made with TkStyle
# Cyberpunk-Theme
A Dark Theme for your Tkinter Python apps
This project is part of the [Pyrustic Open Ecosystem](https://pyrustic.github.io).
[Installation](#installation) | [Reference](https://github.com/pyrustic/cyberpunk-theme/tree/master/docs/reference#readme) | [TkStyle](https://github.com/pyrustic/tkstyle)
## Usage
Thanks to [TkStyle](https://github.com/pyrustic/tkstyle), the `cyberpunk-theme` is both flexible and easy to use.
### Set the theme
```python
import tkinter as tk
from cyberpunk_theme import Cyberpunk
# root
root = tk.Tk()
# apply the Cyberpunk theme to the GUI
cyberpunk_theme = Cyberpunk()
cyberpunk_theme.target(root)
# From now on, the theme applies to the entire GUI
# (your awesome code)
# ...
# mainloop
root.mainloop()
```
What if you want to customize the style of a specific widget ?
### Style a specific widget
Each generic widget has a default style which can be retrieved via a function named `get_{widget-name}_style_1'`.
Some generic widgets like the `Button` widget have multiple styles.
```python
import tkinter as tk
from cyberpunk_theme.widget.button import get_button_dark_style
# root
root = tk.Tk()
# button
button = tk.Button(root, text="Click")
button.pack()
# style
button_style_1 = get_button_dark_style()
button_style_1.target(button)
# mainloop
root.mainloop()
```
The generic `Button` widget has up to ten styles.
The package [megawidget](https://github.com/pyrustic/megawidget) contains a collection of useful custom widgets built with the standard tkinter widgets.
You can set specific styles to `megawidgets` too !
### Style a specific megawidget
```python
import tkinter as tk
from megawidget.table import Table
from cyberpunk_theme.megawidget.table import get_table_style_1
# root
root = tk.Tk()
# the table megawidget
titles = ("Name", "Age")
data = [("Jack", 39), ("Jane", 42)]
table = Table(root, titles=titles, data=data)
table.pack()
# style the table
table_style_1 = get_table_style_1()
table_style_1.target(table)
# mainloop
root.mainloop()
```
## Create your own theme
You can create your own theme or style, or modify the `cyberpunk-theme` as you wish.
Check out [TkStyle](https://github.com/pyrustic/tkstyle) !
## Installation
```bash
$ pip install cyberpunk-theme
```
%package help
Summary: Development documents and examples for cyberpunk-theme
Provides: python3-cyberpunk-theme-doc
%description help
Cyberpunk theme made with TkStyle
# Cyberpunk-Theme
A Dark Theme for your Tkinter Python apps
This project is part of the [Pyrustic Open Ecosystem](https://pyrustic.github.io).
[Installation](#installation) | [Reference](https://github.com/pyrustic/cyberpunk-theme/tree/master/docs/reference#readme) | [TkStyle](https://github.com/pyrustic/tkstyle)
## Usage
Thanks to [TkStyle](https://github.com/pyrustic/tkstyle), the `cyberpunk-theme` is both flexible and easy to use.
### Set the theme
```python
import tkinter as tk
from cyberpunk_theme import Cyberpunk
# root
root = tk.Tk()
# apply the Cyberpunk theme to the GUI
cyberpunk_theme = Cyberpunk()
cyberpunk_theme.target(root)
# From now on, the theme applies to the entire GUI
# (your awesome code)
# ...
# mainloop
root.mainloop()
```
What if you want to customize the style of a specific widget ?
### Style a specific widget
Each generic widget has a default style which can be retrieved via a function named `get_{widget-name}_style_1'`.
Some generic widgets like the `Button` widget have multiple styles.
```python
import tkinter as tk
from cyberpunk_theme.widget.button import get_button_dark_style
# root
root = tk.Tk()
# button
button = tk.Button(root, text="Click")
button.pack()
# style
button_style_1 = get_button_dark_style()
button_style_1.target(button)
# mainloop
root.mainloop()
```
The generic `Button` widget has up to ten styles.
The package [megawidget](https://github.com/pyrustic/megawidget) contains a collection of useful custom widgets built with the standard tkinter widgets.
You can set specific styles to `megawidgets` too !
### Style a specific megawidget
```python
import tkinter as tk
from megawidget.table import Table
from cyberpunk_theme.megawidget.table import get_table_style_1
# root
root = tk.Tk()
# the table megawidget
titles = ("Name", "Age")
data = [("Jack", 39), ("Jane", 42)]
table = Table(root, titles=titles, data=data)
table.pack()
# style the table
table_style_1 = get_table_style_1()
table_style_1.target(table)
# mainloop
root.mainloop()
```
## Create your own theme
You can create your own theme or style, or modify the `cyberpunk-theme` as you wish.
Check out [TkStyle](https://github.com/pyrustic/tkstyle) !
## Installation
```bash
$ pip install cyberpunk-theme
```
%prep
%autosetup -n cyberpunk-theme-0.0.14
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cyberpunk-theme -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.0.14-1
- Package Spec generated