%global _empty_manifest_terminate_build 0
Name: python-dkist-processing-common
Version: 2.6.0
Release: 1
Summary: Common task classes used by the DKIST Science Data Processing pipelines to process DKIST data.
License: MIT
URL: https://bitbucket.org/dkistdc/dkist-processing-common/src/master/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/d0/feac227eb809e89799ce26f00751a649828edc40f2778c3be6fae02c184f/dkist-processing-common-2.6.0.tar.gz
BuildArch: noarch
%description
This repository works in concert with `dkist-processing-core `_ and `dkist-processing-*instrument*` to
form the DKIST calibration processing stack.
%package -n python3-dkist-processing-common
Summary: Common task classes used by the DKIST Science Data Processing pipelines to process DKIST data.
Provides: python-dkist-processing-common
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dkist-processing-common
This repository works in concert with `dkist-processing-core `_ and `dkist-processing-*instrument*` to
form the DKIST calibration processing stack.
%package help
Summary: Development documents and examples for dkist-processing-common
Provides: python3-dkist-processing-common-doc
%description help
This repository works in concert with `dkist-processing-core `_ and `dkist-processing-*instrument*` to
form the DKIST calibration processing stack.
%prep
%autosetup -n dkist-processing-common-2.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dkist-processing-common -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 2.6.0-1
- Package Spec generated