%global _empty_manifest_terminate_build 0
Name:		python-pymycobot
Version:	3.0.9
Release:	1
Summary:	Python API for serial communication of MyCobot.
License:	MIT License
URL:		https://github.com/elephantrobotics/pymycobot
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/98/c7/2ed54d14a45d430553cd33fbb5ad03f11a7d81bd5d9bef74ccbd695eb0c5/pymycobot-3.0.9.tar.gz
BuildArch:	noarch

Requires:	python3-pyserial

%description
More demo can go to [here](../demo).

%package -n python3-pymycobot
Summary:	Python API for serial communication of MyCobot.
Provides:	python-pymycobot
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pymycobot
More demo can go to [here](../demo).

%package help
Summary:	Development documents and examples for pymycobot
Provides:	python3-pymycobot-doc
%description help
More demo can go to [here](../demo).

%prep
%autosetup -n pymycobot-3.0.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pymycobot -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.9-1
- Package Spec generated