%global _empty_manifest_terminate_build 0
Name: python-phylopypruner
Version: 1.2.6
Release: 1
Summary: tree-based orthology inference
License: GPL 3
URL: https://gitlab.com/fethalen/phylopypruner
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9a/ea/14092f6a69ebb086e3275b5cfa58315ef38d8eab8ca45fcb4a6c4536337c/phylopypruner-1.2.6.tar.gz
BuildArch: noarch
Requires: python3-setuptools
Requires: python3-wheel
Requires: python3-setuptools-scm
%description
## About
*Orthologs* are genes that are related through a speciation event, while
*paralogs* are genes that are related through a gene duplication event.
Accurate identification of orthologs is a prerequisite for phylogenomics, since
including genes that diverged because of a gene duplication event for species
tree inference can cause an erroneous inference of speciation nodes, due to
disparencies between individual gene trees and the species tree. Unfortunately,
contaminants present in even a single taxon can cause a tree-based orthology
inference method to erroneuosly infer paralogy and unnecessarily exclude
sequences.
PhyloPyPruner is a Python package for phylogenetic tree-based orthology
inference, using the species overlap method. It uses trees and alignments
inferred from the output of a graph-based orthology inference approach, such
as [OrthoMCL](https://www.ncbi.nlm.nih.gov/pubmed/12952885),
[OrthoFinder](https://www.ncbi.nlm.nih.gov/pubmed/26243257) or
[HaMStR](https://www.ncbi.nlm.nih.gov/pubmed/19586527), in order to obtain sets
of sequences that are 1:1 orthologous. In addition to algorithms seen in
pre-existing tree-based tools (for example,
[PhyloTreePruner](https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3825643/),
[UPhO](https://academic.oup.com/mbe/article/33/8/2117/2578877),
[Agalma](https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3840672/) or
[Phylogenomic Dataset
Reconstruction](https://www.ncbi.nlm.nih.gov/pubmed/25158799)), this package
provides new methods for reducing potential contamination.
![proteomes2orthologs](https://gitlab.com/fethalen/phylopypruner/raw/master/doc/images/proteomes2orthologs.png)
**Figure 1.** A rough overview of a tree-based orthology inference approach.
## Quick installation
The easiest way to install PhyloPyPruner is by using the package manager for
Python, [pip](https://pypi.org/project/pip/):
```bash
pip install phylopypruner # install for all users
pip install --user phylopypruner # install for the current user only
```
Once installed, the program is located within `$HOME/.local/bin`. Depending on
your OS, you might have to add the directory to your `$PATH` to avoid typing
the entire path. Once in your path, you run the program like this:
```bash
phylopypruner
```
## [Documentation](https://gitlab.com/fethalen/phylopypruner/wikis)
1. [About PhyloPyPruner](https://gitlab.com/fethalen/phylopypruner/wikis/introduction)
2. [Tutorial](https://gitlab.com/fethalen/phylopypruner/wikis/tutorial#phylopypruner-tutorial)
3. [Installation](https://gitlab.com/fethalen/phylopypruner/wikis/installation)
4. [Input data](https://gitlab.com/fethalen/phylopypruner/wikis/input-data)
5. [Output files](https://gitlab.com/fethalen/phylopypruner/wikis/output-files)
6. [Methods](https://gitlab.com/fethalen/phylopypruner/wikis/methods)
7. [Options](https://gitlab.com/fethalen/phylopypruner/wikis/options)
## Cite
Our manuscript is still in preparation, it will be posted here once a preprint
of the article is available.
© [Kocot Lab](https://www.kocotlab.com/) 2019
%package -n python3-phylopypruner
Summary: tree-based orthology inference
Provides: python-phylopypruner
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-phylopypruner
## About
*Orthologs* are genes that are related through a speciation event, while
*paralogs* are genes that are related through a gene duplication event.
Accurate identification of orthologs is a prerequisite for phylogenomics, since
including genes that diverged because of a gene duplication event for species
tree inference can cause an erroneous inference of speciation nodes, due to
disparencies between individual gene trees and the species tree. Unfortunately,
contaminants present in even a single taxon can cause a tree-based orthology
inference method to erroneuosly infer paralogy and unnecessarily exclude
sequences.
PhyloPyPruner is a Python package for phylogenetic tree-based orthology
inference, using the species overlap method. It uses trees and alignments
inferred from the output of a graph-based orthology inference approach, such
as [OrthoMCL](https://www.ncbi.nlm.nih.gov/pubmed/12952885),
[OrthoFinder](https://www.ncbi.nlm.nih.gov/pubmed/26243257) or
[HaMStR](https://www.ncbi.nlm.nih.gov/pubmed/19586527), in order to obtain sets
of sequences that are 1:1 orthologous. In addition to algorithms seen in
pre-existing tree-based tools (for example,
[PhyloTreePruner](https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3825643/),
[UPhO](https://academic.oup.com/mbe/article/33/8/2117/2578877),
[Agalma](https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3840672/) or
[Phylogenomic Dataset
Reconstruction](https://www.ncbi.nlm.nih.gov/pubmed/25158799)), this package
provides new methods for reducing potential contamination.
![proteomes2orthologs](https://gitlab.com/fethalen/phylopypruner/raw/master/doc/images/proteomes2orthologs.png)
**Figure 1.** A rough overview of a tree-based orthology inference approach.
## Quick installation
The easiest way to install PhyloPyPruner is by using the package manager for
Python, [pip](https://pypi.org/project/pip/):
```bash
pip install phylopypruner # install for all users
pip install --user phylopypruner # install for the current user only
```
Once installed, the program is located within `$HOME/.local/bin`. Depending on
your OS, you might have to add the directory to your `$PATH` to avoid typing
the entire path. Once in your path, you run the program like this:
```bash
phylopypruner
```
## [Documentation](https://gitlab.com/fethalen/phylopypruner/wikis)
1. [About PhyloPyPruner](https://gitlab.com/fethalen/phylopypruner/wikis/introduction)
2. [Tutorial](https://gitlab.com/fethalen/phylopypruner/wikis/tutorial#phylopypruner-tutorial)
3. [Installation](https://gitlab.com/fethalen/phylopypruner/wikis/installation)
4. [Input data](https://gitlab.com/fethalen/phylopypruner/wikis/input-data)
5. [Output files](https://gitlab.com/fethalen/phylopypruner/wikis/output-files)
6. [Methods](https://gitlab.com/fethalen/phylopypruner/wikis/methods)
7. [Options](https://gitlab.com/fethalen/phylopypruner/wikis/options)
## Cite
Our manuscript is still in preparation, it will be posted here once a preprint
of the article is available.
© [Kocot Lab](https://www.kocotlab.com/) 2019
%package help
Summary: Development documents and examples for phylopypruner
Provides: python3-phylopypruner-doc
%description help
## About
*Orthologs* are genes that are related through a speciation event, while
*paralogs* are genes that are related through a gene duplication event.
Accurate identification of orthologs is a prerequisite for phylogenomics, since
including genes that diverged because of a gene duplication event for species
tree inference can cause an erroneous inference of speciation nodes, due to
disparencies between individual gene trees and the species tree. Unfortunately,
contaminants present in even a single taxon can cause a tree-based orthology
inference method to erroneuosly infer paralogy and unnecessarily exclude
sequences.
PhyloPyPruner is a Python package for phylogenetic tree-based orthology
inference, using the species overlap method. It uses trees and alignments
inferred from the output of a graph-based orthology inference approach, such
as [OrthoMCL](https://www.ncbi.nlm.nih.gov/pubmed/12952885),
[OrthoFinder](https://www.ncbi.nlm.nih.gov/pubmed/26243257) or
[HaMStR](https://www.ncbi.nlm.nih.gov/pubmed/19586527), in order to obtain sets
of sequences that are 1:1 orthologous. In addition to algorithms seen in
pre-existing tree-based tools (for example,
[PhyloTreePruner](https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3825643/),
[UPhO](https://academic.oup.com/mbe/article/33/8/2117/2578877),
[Agalma](https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3840672/) or
[Phylogenomic Dataset
Reconstruction](https://www.ncbi.nlm.nih.gov/pubmed/25158799)), this package
provides new methods for reducing potential contamination.
![proteomes2orthologs](https://gitlab.com/fethalen/phylopypruner/raw/master/doc/images/proteomes2orthologs.png)
**Figure 1.** A rough overview of a tree-based orthology inference approach.
## Quick installation
The easiest way to install PhyloPyPruner is by using the package manager for
Python, [pip](https://pypi.org/project/pip/):
```bash
pip install phylopypruner # install for all users
pip install --user phylopypruner # install for the current user only
```
Once installed, the program is located within `$HOME/.local/bin`. Depending on
your OS, you might have to add the directory to your `$PATH` to avoid typing
the entire path. Once in your path, you run the program like this:
```bash
phylopypruner
```
## [Documentation](https://gitlab.com/fethalen/phylopypruner/wikis)
1. [About PhyloPyPruner](https://gitlab.com/fethalen/phylopypruner/wikis/introduction)
2. [Tutorial](https://gitlab.com/fethalen/phylopypruner/wikis/tutorial#phylopypruner-tutorial)
3. [Installation](https://gitlab.com/fethalen/phylopypruner/wikis/installation)
4. [Input data](https://gitlab.com/fethalen/phylopypruner/wikis/input-data)
5. [Output files](https://gitlab.com/fethalen/phylopypruner/wikis/output-files)
6. [Methods](https://gitlab.com/fethalen/phylopypruner/wikis/methods)
7. [Options](https://gitlab.com/fethalen/phylopypruner/wikis/options)
## Cite
Our manuscript is still in preparation, it will be posted here once a preprint
of the article is available.
© [Kocot Lab](https://www.kocotlab.com/) 2019
%prep
%autosetup -n phylopypruner-1.2.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-phylopypruner -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.2.6-1
- Package Spec generated