%global _empty_manifest_terminate_build 0 Name: python-mkdocs-pymdownx-material-extras Version: 2.4.3 Release: 1 Summary: Plugin to extend MkDocs Material theme. License: MIT License URL: https://github.com/facelessuser/mkdocs_pymdownx_material_extras Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a8/47/49a2d2f87f6236b83aa2032145e705ce67332a8c07b431bd9930594450a0/mkdocs_pymdownx_material_extras-2.4.3.tar.gz BuildArch: noarch %description red | red pink | pink purple | purple deep-purple | purple blue | blue indigo | blue light-blue | blue cyan | cyan teal | cyan green | green light-green | green lime | green yellow | yellow amber | yellow orange | orange deep-orange | orange ## Sponsor Footer Link If you'd like to add the sponsor heart in the footer, add your sponsor link under the MkDocs theme options like so. ```yml theme: pymdownx: sponsor: "https://github.com/sponsors/facelessuser" ``` ## Mermaid Support Mermaid support is baked in. Simply add the Mermaid script to your MkDocs config: ```yml extra_javascript: - https://unpkg.com/mermaid@8.8.4/dist/mermaid.min.js ``` If you do not like our default setup, you are free to modify it. Simply provide a script file before before you include Mermaid with the new config: ```yml extra_javascript: - my_mermaid_config.js - https://unpkg.com/mermaid@8.8.4/dist/mermaid.min.js ``` Also, setup your Mermaid diagrams: ```yml markdown_extensions: - pymdownx.superfences: custom_fences: # Mermaid diagrams - name: diagram class: diagram format: !!python/name:pymdownx.superfences.fence_code_format ``` Then you can specify your Mermaid diagrams in `diagram` code blocks: ```` ```diagram ``` ```` Mermaid setups are provided per scheme. You can see the setup [here](https://github.com/facelessuser/pymdown-extensions/blob/main/docs/src/js/material-extra-3rdparty.js). if you are trying to override them. ## MathJax/KaTeX Again, MathJax and KaTeX support is baked in. Simply add the MathJax script(s) to your MkDocs config: MathJax: ```yml extra_javascript: - https://polyfill.io/v3/polyfill.min.js?features=es6 - https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js ``` KaTeX: ```yml extra_javascript: - https://cdn.jsdelivr.net/npm/katex@0.13.18/dist/katex.min.js ``` Lastly, setup Arithmatex: ```yml markdown_extensions: - pymdownx.arithmatex: generic: true # Must use generic mode block_tag: 'pre' # We wrap block math in `
` to avoid issues with MkDocs minify HTML plugin: https://github.com/byrnereese/mkdocs-minify-plugin
```
If you do not like the default MathJax setup, add your own config before MathJax script:
```yml
extra_javascript:
  - my_mathjax_config.js
  - https://polyfill.io/v3/polyfill.min.js?features=es6
  - https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js
```

%package -n python3-mkdocs-pymdownx-material-extras
Summary:	Plugin to extend MkDocs Material theme.
Provides:	python-mkdocs-pymdownx-material-extras
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mkdocs-pymdownx-material-extras
red         | red
pink        | pink
purple      | purple
deep-purple | purple
blue        | blue
indigo      | blue
light-blue  | blue
cyan        | cyan
teal        | cyan
green       | green
light-green | green
lime        | green
yellow      | yellow
amber       | yellow
orange      | orange
deep-orange | orange
## Sponsor Footer Link
If you'd like to add the sponsor heart in the footer, add your sponsor link under the MkDocs theme options like so.
```yml
theme:
  pymdownx:
    sponsor: "https://github.com/sponsors/facelessuser"
```
## Mermaid Support
Mermaid support is baked in. Simply add the Mermaid script to your MkDocs config:
```yml
extra_javascript:
  - https://unpkg.com/mermaid@8.8.4/dist/mermaid.min.js
```
If you do not like our default setup, you are free to modify it. Simply provide a script file before before you include
Mermaid with the new config:
```yml
extra_javascript:
  - my_mermaid_config.js
  - https://unpkg.com/mermaid@8.8.4/dist/mermaid.min.js
```
Also, setup your Mermaid diagrams:
```yml
markdown_extensions:
  - pymdownx.superfences:
      custom_fences:
        # Mermaid diagrams
        - name: diagram
          class: diagram
          format: !!python/name:pymdownx.superfences.fence_code_format
```
Then you can specify your Mermaid diagrams in `diagram` code blocks:
````
```diagram
```
````
Mermaid setups are provided per scheme. You can see the setup [here](https://github.com/facelessuser/pymdown-extensions/blob/main/docs/src/js/material-extra-3rdparty.js).
if you are trying to override them.
## MathJax/KaTeX
Again, MathJax and KaTeX support is baked in. Simply add the MathJax script(s) to your MkDocs config:
MathJax:
```yml
extra_javascript:
  - https://polyfill.io/v3/polyfill.min.js?features=es6
  - https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js
```
KaTeX:
```yml
extra_javascript:
  - https://cdn.jsdelivr.net/npm/katex@0.13.18/dist/katex.min.js
```
Lastly, setup Arithmatex:
```yml
markdown_extensions:
  - pymdownx.arithmatex:
      generic: true # Must use generic mode
      block_tag: 'pre' # We wrap block math in `
` to avoid issues with MkDocs minify HTML plugin: https://github.com/byrnereese/mkdocs-minify-plugin
```
If you do not like the default MathJax setup, add your own config before MathJax script:
```yml
extra_javascript:
  - my_mathjax_config.js
  - https://polyfill.io/v3/polyfill.min.js?features=es6
  - https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js
```

%package help
Summary:	Development documents and examples for mkdocs-pymdownx-material-extras
Provides:	python3-mkdocs-pymdownx-material-extras-doc
%description help
red         | red
pink        | pink
purple      | purple
deep-purple | purple
blue        | blue
indigo      | blue
light-blue  | blue
cyan        | cyan
teal        | cyan
green       | green
light-green | green
lime        | green
yellow      | yellow
amber       | yellow
orange      | orange
deep-orange | orange
## Sponsor Footer Link
If you'd like to add the sponsor heart in the footer, add your sponsor link under the MkDocs theme options like so.
```yml
theme:
  pymdownx:
    sponsor: "https://github.com/sponsors/facelessuser"
```
## Mermaid Support
Mermaid support is baked in. Simply add the Mermaid script to your MkDocs config:
```yml
extra_javascript:
  - https://unpkg.com/mermaid@8.8.4/dist/mermaid.min.js
```
If you do not like our default setup, you are free to modify it. Simply provide a script file before before you include
Mermaid with the new config:
```yml
extra_javascript:
  - my_mermaid_config.js
  - https://unpkg.com/mermaid@8.8.4/dist/mermaid.min.js
```
Also, setup your Mermaid diagrams:
```yml
markdown_extensions:
  - pymdownx.superfences:
      custom_fences:
        # Mermaid diagrams
        - name: diagram
          class: diagram
          format: !!python/name:pymdownx.superfences.fence_code_format
```
Then you can specify your Mermaid diagrams in `diagram` code blocks:
````
```diagram
```
````
Mermaid setups are provided per scheme. You can see the setup [here](https://github.com/facelessuser/pymdown-extensions/blob/main/docs/src/js/material-extra-3rdparty.js).
if you are trying to override them.
## MathJax/KaTeX
Again, MathJax and KaTeX support is baked in. Simply add the MathJax script(s) to your MkDocs config:
MathJax:
```yml
extra_javascript:
  - https://polyfill.io/v3/polyfill.min.js?features=es6
  - https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js
```
KaTeX:
```yml
extra_javascript:
  - https://cdn.jsdelivr.net/npm/katex@0.13.18/dist/katex.min.js
```
Lastly, setup Arithmatex:
```yml
markdown_extensions:
  - pymdownx.arithmatex:
      generic: true # Must use generic mode
      block_tag: 'pre' # We wrap block math in `
` to avoid issues with MkDocs minify HTML plugin: https://github.com/byrnereese/mkdocs-minify-plugin
```
If you do not like the default MathJax setup, add your own config before MathJax script:
```yml
extra_javascript:
  - my_mathjax_config.js
  - https://polyfill.io/v3/polyfill.min.js?features=es6
  - https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js
```

%prep
%autosetup -n mkdocs-pymdownx-material-extras-2.4.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mkdocs-pymdownx-material-extras -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot  - 2.4.3-1
- Package Spec generated