%global _empty_manifest_terminate_build 0
Name: python-flask-rebar
Version: 2.3.0
Release: 1
Summary: Flask-Rebar combines flask, marshmallow, and swagger for robust REST services.
License: MIT
URL: https://github.com/plangrid/flask-rebar
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/44/ff/9bc2b0e3cda625adc2f5739afd541e2deb0d92aed31d38e8e840cd9ff409/flask-rebar-2.3.0.tar.gz
BuildArch: noarch
Requires: python3-Flask
Requires: python3-marshmallow
Requires: python3-black
Requires: python3-bumpversion
Requires: python3-click
Requires: python3-flake8
Requires: python3-gitchangelog
Requires: python3-jsonschema
Requires: python3-marshmallow-objects
Requires: python3-parametrize
Requires: python3-pre-commit
Requires: python3-pytest
Requires: python3-pytest-order
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-marshmallow-enum
%description
|
Flask-Rebar combines `flask `_, `marshmallow `_, and `swagger `_ for robust REST services.
%package -n python3-flask-rebar
Summary: Flask-Rebar combines flask, marshmallow, and swagger for robust REST services.
Provides: python-flask-rebar
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flask-rebar
|
Flask-Rebar combines `flask `_, `marshmallow `_, and `swagger `_ for robust REST services.
%package help
Summary: Development documents and examples for flask-rebar
Provides: python3-flask-rebar-doc
%description help
|
Flask-Rebar combines `flask `_, `marshmallow `_, and `swagger `_ for robust REST services.
%prep
%autosetup -n flask-rebar-2.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flask-rebar -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 2.3.0-1
- Package Spec generated