%global _empty_manifest_terminate_build 0
Name: python-AYABInterface
Version: 0.0.9
Release: 1
Summary: A Python library with the interface to the AYAB shield.
License: LGPL
URL: https://github.com/fossasia/AYABInterface
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8f/0a/5bcf79b26b39a98228c586a83b74ea401bf2b249952b08646a0ba0b57c33/AYABInterface-0.0.9.tar.gz
BuildArch: noarch
Requires: python3-crc8
Requires: python3-pyserial
%description
A Python library with the interface to the AYAB shield.
For installation instructions and more, `see the documentation
`__.
%package -n python3-AYABInterface
Summary: A Python library with the interface to the AYAB shield.
Provides: python-AYABInterface
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-AYABInterface
A Python library with the interface to the AYAB shield.
For installation instructions and more, `see the documentation
`__.
%package help
Summary: Development documents and examples for AYABInterface
Provides: python3-AYABInterface-doc
%description help
A Python library with the interface to the AYAB shield.
For installation instructions and more, `see the documentation
`__.
%prep
%autosetup -n AYABInterface-0.0.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-AYABInterface -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.0.9-1
- Package Spec generated