%global _empty_manifest_terminate_build 0
Name:		python-Pythomnic3k
Version:	1.4.1
Release:	1
Summary:	Python 3 framework for business middleware development in service-oriented architecture
License:	BSD License
URL:		http://www.pythomnic3k.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/76/0b/d0dc4747b734fb8387a55a44ed7d8f6103aa2552a3e3532c979db73654bb/pythomnic3k-1.4.1.tar.gz
BuildArch:	noarch


%description
Pythomnic3k is a framework for building network services, integration middleware
and distributed applications in Python 3.

The framework focuses on rapid development of network services, it makes very
easy to bring up a service and keep adding or modifying its modules without
having to shut it down - updated modules are transparently reloaded. The
framework is non-blocking, providing loose real-time guarantees of a response
within deadline. It is also resilient, surviving overload and returning to
normal state. Partitioning of the application, making it distributed, adding
redundancy by running multiple copies of application components is another
simple thing to do in this framework.

The framework is extensible by adding support for more protocols. The package contains the framework itself and all the protocols it currently supports.

%package -n python3-Pythomnic3k
Summary:	Python 3 framework for business middleware development in service-oriented architecture
Provides:	python-Pythomnic3k
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Pythomnic3k
Pythomnic3k is a framework for building network services, integration middleware
and distributed applications in Python 3.

The framework focuses on rapid development of network services, it makes very
easy to bring up a service and keep adding or modifying its modules without
having to shut it down - updated modules are transparently reloaded. The
framework is non-blocking, providing loose real-time guarantees of a response
within deadline. It is also resilient, surviving overload and returning to
normal state. Partitioning of the application, making it distributed, adding
redundancy by running multiple copies of application components is another
simple thing to do in this framework.

The framework is extensible by adding support for more protocols. The package contains the framework itself and all the protocols it currently supports.

%package help
Summary:	Development documents and examples for Pythomnic3k
Provides:	python3-Pythomnic3k-doc
%description help
Pythomnic3k is a framework for building network services, integration middleware
and distributed applications in Python 3.

The framework focuses on rapid development of network services, it makes very
easy to bring up a service and keep adding or modifying its modules without
having to shut it down - updated modules are transparently reloaded. The
framework is non-blocking, providing loose real-time guarantees of a response
within deadline. It is also resilient, surviving overload and returning to
normal state. Partitioning of the application, making it distributed, adding
redundancy by running multiple copies of application components is another
simple thing to do in this framework.

The framework is extensible by adding support for more protocols. The package contains the framework itself and all the protocols it currently supports.

%prep
%autosetup -n Pythomnic3k-1.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Pythomnic3k -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.1-1
- Package Spec generated