%global _empty_manifest_terminate_build 0
Name: python-featuretools-tsfresh-primitives
Version: 1.0.2
Release: 1
Summary: TSFresh primitives for featuretools
License: MIT
URL: https://github.com/alteryx/featuretools-tsfresh-primitives/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8e/54/9489bcfb8390a99e89c83fc8663966ae28a5d934d9e25868cb2fccdd9c35/featuretools_tsfresh_primitives-1.0.2.tar.gz
BuildArch: noarch
Requires: python3-tsfresh
Requires: python3-pandas
Requires: python3-featuretools
%description
# TSFresh Primitives
### Installation
Install with pip:
```python
python -m pip install "featuretools[tsfresh]"
```
## Calculating Features
In `tsfresh`, this is how you can calculate a feature.
```python
from tsfresh.feature_extraction.feature_calculators import agg_autocorrelation
data = list(range(10))
param = [{'f_agg': 'mean', 'maxlag': 5}]
agg_autocorrelation(data, param=param)
```
```bash
[('f_agg_"mean"__maxlag_5', 0.1717171717171717)]
```
With tsfresh primtives in `featuretools`, this is how you can calculate the same feature.
```python
from featuretools.tsfresh import AggAutocorrelation
data = list(range(10))
AggAutocorrelation(f_agg='mean', maxlag=5)(data)
```
```bash
0.1717171717171717
```
## Combining Primitives
In `featuretools`, this is how to combine tsfresh primitives with built-in or other installed primitives.
```python
import featuretools as ft
from featuretools.tsfresh import AggAutocorrelation, Mean
entityset = ft.demo.load_mock_customer(return_entityset=True)
agg_primitives = [Mean, AggAutocorrelation(f_agg='mean', maxlag=5)]
feature_matrix, features = ft.dfs(entityset=entityset, target_dataframe_name='sessions', agg_primitives=agg_primitives)
feature_matrix[[
'MEAN(transactions.amount)',
'AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)',
]].head()
```
```
MEAN(transactions.amount) AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)
session_id
1 76.813125 0.044268
2 74.696000 -0.053110
3 88.600000 0.007520
4 64.557200 -0.034542
5 70.638182 -0.100571
```
Notice that tsfresh primtives are applied across relationships in an entityset generating many features that are otherwise not possible.
```python
feature_matrix[['customers.AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)']].head()
```
```
customers.AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)
session_id
1 0.011102
2 -0.001686
3 -0.010679
4 0.011204
5 -0.010679
```
## Built at Alteryx Innovation Labs
%package -n python3-featuretools-tsfresh-primitives
Summary: TSFresh primitives for featuretools
Provides: python-featuretools-tsfresh-primitives
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-featuretools-tsfresh-primitives
# TSFresh Primitives
### Installation
Install with pip:
```python
python -m pip install "featuretools[tsfresh]"
```
## Calculating Features
In `tsfresh`, this is how you can calculate a feature.
```python
from tsfresh.feature_extraction.feature_calculators import agg_autocorrelation
data = list(range(10))
param = [{'f_agg': 'mean', 'maxlag': 5}]
agg_autocorrelation(data, param=param)
```
```bash
[('f_agg_"mean"__maxlag_5', 0.1717171717171717)]
```
With tsfresh primtives in `featuretools`, this is how you can calculate the same feature.
```python
from featuretools.tsfresh import AggAutocorrelation
data = list(range(10))
AggAutocorrelation(f_agg='mean', maxlag=5)(data)
```
```bash
0.1717171717171717
```
## Combining Primitives
In `featuretools`, this is how to combine tsfresh primitives with built-in or other installed primitives.
```python
import featuretools as ft
from featuretools.tsfresh import AggAutocorrelation, Mean
entityset = ft.demo.load_mock_customer(return_entityset=True)
agg_primitives = [Mean, AggAutocorrelation(f_agg='mean', maxlag=5)]
feature_matrix, features = ft.dfs(entityset=entityset, target_dataframe_name='sessions', agg_primitives=agg_primitives)
feature_matrix[[
'MEAN(transactions.amount)',
'AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)',
]].head()
```
```
MEAN(transactions.amount) AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)
session_id
1 76.813125 0.044268
2 74.696000 -0.053110
3 88.600000 0.007520
4 64.557200 -0.034542
5 70.638182 -0.100571
```
Notice that tsfresh primtives are applied across relationships in an entityset generating many features that are otherwise not possible.
```python
feature_matrix[['customers.AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)']].head()
```
```
customers.AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)
session_id
1 0.011102
2 -0.001686
3 -0.010679
4 0.011204
5 -0.010679
```
## Built at Alteryx Innovation Labs
%package help
Summary: Development documents and examples for featuretools-tsfresh-primitives
Provides: python3-featuretools-tsfresh-primitives-doc
%description help
# TSFresh Primitives
### Installation
Install with pip:
```python
python -m pip install "featuretools[tsfresh]"
```
## Calculating Features
In `tsfresh`, this is how you can calculate a feature.
```python
from tsfresh.feature_extraction.feature_calculators import agg_autocorrelation
data = list(range(10))
param = [{'f_agg': 'mean', 'maxlag': 5}]
agg_autocorrelation(data, param=param)
```
```bash
[('f_agg_"mean"__maxlag_5', 0.1717171717171717)]
```
With tsfresh primtives in `featuretools`, this is how you can calculate the same feature.
```python
from featuretools.tsfresh import AggAutocorrelation
data = list(range(10))
AggAutocorrelation(f_agg='mean', maxlag=5)(data)
```
```bash
0.1717171717171717
```
## Combining Primitives
In `featuretools`, this is how to combine tsfresh primitives with built-in or other installed primitives.
```python
import featuretools as ft
from featuretools.tsfresh import AggAutocorrelation, Mean
entityset = ft.demo.load_mock_customer(return_entityset=True)
agg_primitives = [Mean, AggAutocorrelation(f_agg='mean', maxlag=5)]
feature_matrix, features = ft.dfs(entityset=entityset, target_dataframe_name='sessions', agg_primitives=agg_primitives)
feature_matrix[[
'MEAN(transactions.amount)',
'AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)',
]].head()
```
```
MEAN(transactions.amount) AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)
session_id
1 76.813125 0.044268
2 74.696000 -0.053110
3 88.600000 0.007520
4 64.557200 -0.034542
5 70.638182 -0.100571
```
Notice that tsfresh primtives are applied across relationships in an entityset generating many features that are otherwise not possible.
```python
feature_matrix[['customers.AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)']].head()
```
```
customers.AGG_AUTOCORRELATION(transactions.amount, f_agg=mean, maxlag=5)
session_id
1 0.011102
2 -0.001686
3 -0.010679
4 0.011204
5 -0.010679
```
## Built at Alteryx Innovation Labs
%prep
%autosetup -n featuretools-tsfresh-primitives-1.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-featuretools-tsfresh-primitives -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.0.2-1
- Package Spec generated