%global _empty_manifest_terminate_build 0
Name: python-pymp4
Version: 1.4.0
Release: 1
Summary: Python parser for MP4 boxes
License: Apache-2.0
URL: https://github.com/beardypig/pymp4
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/46/dfb3f5363fc71adaf419147fdcb93341029ca638634a5cc6f7e7446416b2/pymp4-1.4.0.tar.gz
BuildArch: noarch
Requires: python3-construct
%description
# pymp4
[![Build status](https://github.com/beardypig/pymp4/actions/workflows/ci.yml/badge.svg)](https://github.com/beardypig/pymp4/actions/workflows/ci.yml)
[![License](https://img.shields.io/pypi/l/pymp4)](LICENSE)
[![Python versions](https://img.shields.io/pypi/pyversions/pymp4)](https://pypi.org/project/pymp4)
[![Coverage](https://codecov.io/gh/beardypig/pymp4/branch/master/graph/badge.svg)](https://app.codecov.io/github/beardypig/pymp4)
Python MP4 box parser and toolkit based on the [construct](https://github.com/construct/construct) library.
## Usage
```python
>>> from pymp4.parser import Box
>>> from io import BytesIO
>>> Box.build(dict(
type=b"ftyp",
major_brand="iso5",
minor_version=1,
compatible_brands=["iso5", "avc1"]))
b'\x00\x00\x00\x18ftypiso5\x00\x00\x00\x01iso5avc1'
>>> ftyp = Box.parse(b'\x00\x00\x00\x18ftypiso5\x00\x00\x00\x01iso5avc1')
>>> print(ftyp)
Container:
type = ftyp
major_brand = iso5
minor_version = 1
compatible_brands = ListContainer:
iso5
avc1
```
## Contributors
## License
[Apache License, Version 2.0](LICENSE)
%package -n python3-pymp4
Summary: Python parser for MP4 boxes
Provides: python-pymp4
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pymp4
# pymp4
[![Build status](https://github.com/beardypig/pymp4/actions/workflows/ci.yml/badge.svg)](https://github.com/beardypig/pymp4/actions/workflows/ci.yml)
[![License](https://img.shields.io/pypi/l/pymp4)](LICENSE)
[![Python versions](https://img.shields.io/pypi/pyversions/pymp4)](https://pypi.org/project/pymp4)
[![Coverage](https://codecov.io/gh/beardypig/pymp4/branch/master/graph/badge.svg)](https://app.codecov.io/github/beardypig/pymp4)
Python MP4 box parser and toolkit based on the [construct](https://github.com/construct/construct) library.
## Usage
```python
>>> from pymp4.parser import Box
>>> from io import BytesIO
>>> Box.build(dict(
type=b"ftyp",
major_brand="iso5",
minor_version=1,
compatible_brands=["iso5", "avc1"]))
b'\x00\x00\x00\x18ftypiso5\x00\x00\x00\x01iso5avc1'
>>> ftyp = Box.parse(b'\x00\x00\x00\x18ftypiso5\x00\x00\x00\x01iso5avc1')
>>> print(ftyp)
Container:
type = ftyp
major_brand = iso5
minor_version = 1
compatible_brands = ListContainer:
iso5
avc1
```
## Contributors
## License
[Apache License, Version 2.0](LICENSE)
%package help
Summary: Development documents and examples for pymp4
Provides: python3-pymp4-doc
%description help
# pymp4
[![Build status](https://github.com/beardypig/pymp4/actions/workflows/ci.yml/badge.svg)](https://github.com/beardypig/pymp4/actions/workflows/ci.yml)
[![License](https://img.shields.io/pypi/l/pymp4)](LICENSE)
[![Python versions](https://img.shields.io/pypi/pyversions/pymp4)](https://pypi.org/project/pymp4)
[![Coverage](https://codecov.io/gh/beardypig/pymp4/branch/master/graph/badge.svg)](https://app.codecov.io/github/beardypig/pymp4)
Python MP4 box parser and toolkit based on the [construct](https://github.com/construct/construct) library.
## Usage
```python
>>> from pymp4.parser import Box
>>> from io import BytesIO
>>> Box.build(dict(
type=b"ftyp",
major_brand="iso5",
minor_version=1,
compatible_brands=["iso5", "avc1"]))
b'\x00\x00\x00\x18ftypiso5\x00\x00\x00\x01iso5avc1'
>>> ftyp = Box.parse(b'\x00\x00\x00\x18ftypiso5\x00\x00\x00\x01iso5avc1')
>>> print(ftyp)
Container:
type = ftyp
major_brand = iso5
minor_version = 1
compatible_brands = ListContainer:
iso5
avc1
```
## Contributors
## License
[Apache License, Version 2.0](LICENSE)
%prep
%autosetup -n pymp4-1.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pymp4 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 1.4.0-1
- Package Spec generated