%global _empty_manifest_terminate_build 0
Name: python-pyspotify
Version: 2.1.4
Release: 1
Summary: Python wrapper for libspotify
License: Apache License, Version 2.0
URL: https://pyspotify.readthedocs.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/7b/091752856beb58a78affad51b2ea65de7b053fdf2dd92904438f05a871ec/pyspotify-2.1.4.tar.gz
BuildArch: noarch
%description
pyspotify is a Python wrapper around the libspotify C library, and thus depends
on libspotify for everything it does.
In May 2015, libspotify was deprecated by Spotify and active maintenance
stopped. At this point, libspotify had been the main way to integrate with
Spotify for six years, and was part of numerous open source projects and
commercial applications, including many receivers and even cars. It remained
the only API for playback outside Android and iOS.
In February 2016, server side changes to the Spotify API caused the search
functionality to stop working, without Spotify ever acknowledging it. Users of
pyspotify could work around this by using the Spotify web API for searches and
pyspotify for playback.
In April 2022, `Spotify announced
`_
that they would sunset the libspotify API one month later.
In May 2022, new libspotify connections to Spotify started failing. With
libspotify dead, pyspotify was dead too.
After two years in development from May 2013 to May 2015, and seven years of
loyal service this project has reached its end.
**There will be no further updates to pyspotify.**
Hopefully, the pyspotify source code can still serve as a complete example of
how to successfully wrap a large C library in Python using CFFI.
%package -n python3-pyspotify
Summary: Python wrapper for libspotify
Provides: python-pyspotify
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyspotify
pyspotify is a Python wrapper around the libspotify C library, and thus depends
on libspotify for everything it does.
In May 2015, libspotify was deprecated by Spotify and active maintenance
stopped. At this point, libspotify had been the main way to integrate with
Spotify for six years, and was part of numerous open source projects and
commercial applications, including many receivers and even cars. It remained
the only API for playback outside Android and iOS.
In February 2016, server side changes to the Spotify API caused the search
functionality to stop working, without Spotify ever acknowledging it. Users of
pyspotify could work around this by using the Spotify web API for searches and
pyspotify for playback.
In April 2022, `Spotify announced
`_
that they would sunset the libspotify API one month later.
In May 2022, new libspotify connections to Spotify started failing. With
libspotify dead, pyspotify was dead too.
After two years in development from May 2013 to May 2015, and seven years of
loyal service this project has reached its end.
**There will be no further updates to pyspotify.**
Hopefully, the pyspotify source code can still serve as a complete example of
how to successfully wrap a large C library in Python using CFFI.
%package help
Summary: Development documents and examples for pyspotify
Provides: python3-pyspotify-doc
%description help
pyspotify is a Python wrapper around the libspotify C library, and thus depends
on libspotify for everything it does.
In May 2015, libspotify was deprecated by Spotify and active maintenance
stopped. At this point, libspotify had been the main way to integrate with
Spotify for six years, and was part of numerous open source projects and
commercial applications, including many receivers and even cars. It remained
the only API for playback outside Android and iOS.
In February 2016, server side changes to the Spotify API caused the search
functionality to stop working, without Spotify ever acknowledging it. Users of
pyspotify could work around this by using the Spotify web API for searches and
pyspotify for playback.
In April 2022, `Spotify announced
`_
that they would sunset the libspotify API one month later.
In May 2022, new libspotify connections to Spotify started failing. With
libspotify dead, pyspotify was dead too.
After two years in development from May 2013 to May 2015, and seven years of
loyal service this project has reached its end.
**There will be no further updates to pyspotify.**
Hopefully, the pyspotify source code can still serve as a complete example of
how to successfully wrap a large C library in Python using CFFI.
%prep
%autosetup -n pyspotify-2.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyspotify -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 2.1.4-1
- Package Spec generated