%global _empty_manifest_terminate_build 0
Name: python-qqdm
Version: 0.0.7
Release: 1
Summary: A very lightweight progress bar.
License: MIT License
URL: https://github.com/kimythanly/qqdm
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/38/49/6edfdb9c4d8433f4fc06e35eda38c3bd76bccc87320da54f95bf54899942/qqdm-0.0.7.tar.gz
BuildArch: noarch
%description
# qqdm
A lightweight, fast and pretty progress bar for Python
## Demo
## Installation
```
pip install qqdm
```
## Usage
The following is a simple example.
```python
import time
import random
from qqdm import qqdm, format_str
tw = qqdm(range(10), desc=format_str('bold', 'Description'))
for i in tw:
loss = random.random()
acc = random.random()
tw.set_infos({
'loss': f'{loss:.4f}',
'acc': f'{acc:.4f}',
})
time.sleep(0.5)
```
For the demo gif shown above, you may refer to `tests/test.py`.
%package -n python3-qqdm
Summary: A very lightweight progress bar.
Provides: python-qqdm
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-qqdm
# qqdm
A lightweight, fast and pretty progress bar for Python
## Demo
## Installation
```
pip install qqdm
```
## Usage
The following is a simple example.
```python
import time
import random
from qqdm import qqdm, format_str
tw = qqdm(range(10), desc=format_str('bold', 'Description'))
for i in tw:
loss = random.random()
acc = random.random()
tw.set_infos({
'loss': f'{loss:.4f}',
'acc': f'{acc:.4f}',
})
time.sleep(0.5)
```
For the demo gif shown above, you may refer to `tests/test.py`.
%package help
Summary: Development documents and examples for qqdm
Provides: python3-qqdm-doc
%description help
# qqdm
A lightweight, fast and pretty progress bar for Python
## Demo
## Installation
```
pip install qqdm
```
## Usage
The following is a simple example.
```python
import time
import random
from qqdm import qqdm, format_str
tw = qqdm(range(10), desc=format_str('bold', 'Description'))
for i in tw:
loss = random.random()
acc = random.random()
tw.set_infos({
'loss': f'{loss:.4f}',
'acc': f'{acc:.4f}',
})
time.sleep(0.5)
```
For the demo gif shown above, you may refer to `tests/test.py`.
%prep
%autosetup -n qqdm-0.0.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-qqdm -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 0.0.7-1
- Package Spec generated