%global _empty_manifest_terminate_build 0
Name: python-pivotpy
Version: 1.3.11
Release: 1
Summary: A description of your project
License: Apache Software License 2.0
URL: https://github.com/massgh/pivotpy/tree/master/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e7/b7/d765050b50bffeb5133b59ee94433e54b47c4992e49a16a66f1f8f5c92a6/pivotpy-1.3.11.tar.gz
BuildArch: noarch
Requires: python3-ipyvasp
Requires: python3-plotly
Requires: python3-ipywidgets
Requires: python3-numpy
Requires: python3-matplotlib
Requires: python3-scipy
Requires: python3-pandas
Requires: python3-requests
%description
da---- 6/9/2022 10:33 AM ISPIN_1
da---- 5/9/2020 1:05 PM ISPIN_2
-a---- 5/9/2020 1:01 PM 75331 OUTCAR
-a---- 5/9/2020 1:01 PM 240755 vasprun.xml
```python
x = %ps (Get-ChildItem 'E:\Research\graphene_example\').Name
x
```
['ISPIN_1', 'ISPIN_2', 'OUTCAR', 'vasprun.xml']
[Functions Reference](functions.md)
> [ `▶` Index● ](https://massgh.github.io/pivotpy/)
> [ `▶` Example ](https://massgh.github.io/pivotpy/Example)
> [ `▶` StaticPlots ](https://massgh.github.io/pivotpy/StaticPlots)
> [ `▶` InteractivePlots ](https://massgh.github.io/pivotpy/InteractivePlots)
> [ `▶` SpinProjectedSurfaces ](https://massgh.github.io/pivotpy/SpinProjectedSurfaces)
> [ `▶` StructureIO ](https://massgh.github.io/pivotpy/StructureIO)
> [ `▶` Widgets ](https://massgh.github.io/pivotpy/Widgets)
> [ `▶` MainAPI ](https://massgh.github.io/pivotpy/MainAPI)
%package -n python3-pivotpy
Summary: A description of your project
Provides: python-pivotpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pivotpy
da---- 6/9/2022 10:33 AM ISPIN_1
da---- 5/9/2020 1:05 PM ISPIN_2
-a---- 5/9/2020 1:01 PM 75331 OUTCAR
-a---- 5/9/2020 1:01 PM 240755 vasprun.xml
```python
x = %ps (Get-ChildItem 'E:\Research\graphene_example\').Name
x
```
['ISPIN_1', 'ISPIN_2', 'OUTCAR', 'vasprun.xml']
[Functions Reference](functions.md)
> [ `▶` Index● ](https://massgh.github.io/pivotpy/)
> [ `▶` Example ](https://massgh.github.io/pivotpy/Example)
> [ `▶` StaticPlots ](https://massgh.github.io/pivotpy/StaticPlots)
> [ `▶` InteractivePlots ](https://massgh.github.io/pivotpy/InteractivePlots)
> [ `▶` SpinProjectedSurfaces ](https://massgh.github.io/pivotpy/SpinProjectedSurfaces)
> [ `▶` StructureIO ](https://massgh.github.io/pivotpy/StructureIO)
> [ `▶` Widgets ](https://massgh.github.io/pivotpy/Widgets)
> [ `▶` MainAPI ](https://massgh.github.io/pivotpy/MainAPI)
%package help
Summary: Development documents and examples for pivotpy
Provides: python3-pivotpy-doc
%description help
da---- 6/9/2022 10:33 AM ISPIN_1
da---- 5/9/2020 1:05 PM ISPIN_2
-a---- 5/9/2020 1:01 PM 75331 OUTCAR
-a---- 5/9/2020 1:01 PM 240755 vasprun.xml
```python
x = %ps (Get-ChildItem 'E:\Research\graphene_example\').Name
x
```
['ISPIN_1', 'ISPIN_2', 'OUTCAR', 'vasprun.xml']
[Functions Reference](functions.md)
> [ `▶` Index● ](https://massgh.github.io/pivotpy/)
> [ `▶` Example ](https://massgh.github.io/pivotpy/Example)
> [ `▶` StaticPlots ](https://massgh.github.io/pivotpy/StaticPlots)
> [ `▶` InteractivePlots ](https://massgh.github.io/pivotpy/InteractivePlots)
> [ `▶` SpinProjectedSurfaces ](https://massgh.github.io/pivotpy/SpinProjectedSurfaces)
> [ `▶` StructureIO ](https://massgh.github.io/pivotpy/StructureIO)
> [ `▶` Widgets ](https://massgh.github.io/pivotpy/Widgets)
> [ `▶` MainAPI ](https://massgh.github.io/pivotpy/MainAPI)
%prep
%autosetup -n pivotpy-1.3.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pivotpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 1.3.11-1
- Package Spec generated