%global _empty_manifest_terminate_build 0
Name: python-django-uwsgi
Version: 0.2.2
Release: 1
Summary: uWSGI stuff for Django projects
License: MIT
URL: http://github.com/unbit/django-uwsgi
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1f/19/e24dbc8ac8cf4a16c4af6140dc1583b219ef53e4a0675b884f9acc482d1c/django-uwsgi-0.2.2.tar.gz
BuildArch: noarch
Requires: python3-uwsgi
%description
django-uwsgi
~~~~~~~~~~~~
|release| |stats| |lic|
.. |release| image:: https://img.shields.io/pypi/v/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
.. |stats| image:: https://img.shields.io/pypi/dm/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
.. |lic| image:: https://img.shields.io/pypi/l/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
Django related examples/tricks/modules for uWSGI
Screenshots
~~~~~~~~~~~
`django-debug-toolbar `_ panel
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot1.png
`Wagtail `_ admin interface:
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot2.png
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot3.png
Emperor's Vassal Admin Panel
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot4.png
`django.contrib.admin `_ interface
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot5.png
Documentation
~~~~~~~~~~~~~
`Read the documentation at rtfd.org `_
Contributors
~~~~~~~~~~~~
See `CONTRIBUTORS `_
License
~~~~~~~
`MIT `_
%package -n python3-django-uwsgi
Summary: uWSGI stuff for Django projects
Provides: python-django-uwsgi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-uwsgi
django-uwsgi
~~~~~~~~~~~~
|release| |stats| |lic|
.. |release| image:: https://img.shields.io/pypi/v/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
.. |stats| image:: https://img.shields.io/pypi/dm/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
.. |lic| image:: https://img.shields.io/pypi/l/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
Django related examples/tricks/modules for uWSGI
Screenshots
~~~~~~~~~~~
`django-debug-toolbar `_ panel
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot1.png
`Wagtail `_ admin interface:
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot2.png
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot3.png
Emperor's Vassal Admin Panel
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot4.png
`django.contrib.admin `_ interface
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot5.png
Documentation
~~~~~~~~~~~~~
`Read the documentation at rtfd.org `_
Contributors
~~~~~~~~~~~~
See `CONTRIBUTORS `_
License
~~~~~~~
`MIT `_
%package help
Summary: Development documents and examples for django-uwsgi
Provides: python3-django-uwsgi-doc
%description help
django-uwsgi
~~~~~~~~~~~~
|release| |stats| |lic|
.. |release| image:: https://img.shields.io/pypi/v/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
.. |stats| image:: https://img.shields.io/pypi/dm/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
.. |lic| image:: https://img.shields.io/pypi/l/django-uwsgi.svg
:target: https://pypi.python.org/pypi/django-uwsgi
Django related examples/tricks/modules for uWSGI
Screenshots
~~~~~~~~~~~
`django-debug-toolbar `_ panel
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot1.png
`Wagtail `_ admin interface:
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot2.png
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot3.png
Emperor's Vassal Admin Panel
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot4.png
`django.contrib.admin `_ interface
.. image:: https://github.com/unbit/django-uwsgi/raw/master/docs/screenshots/screenshot5.png
Documentation
~~~~~~~~~~~~~
`Read the documentation at rtfd.org `_
Contributors
~~~~~~~~~~~~
See `CONTRIBUTORS `_
License
~~~~~~~
`MIT `_
%prep
%autosetup -n django-uwsgi-0.2.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-uwsgi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 0.2.2-1
- Package Spec generated