%global _empty_manifest_terminate_build 0
Name: python-testproject-python-sdk
Version: 1.2.3
Release: 1
Summary: Selenium and Appium powered SDK for TestProject.io
License: Apache Software License
URL: https://github.com/testproject-io/python-opensdk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d7/7d/5e2bad7169799a1ebb19d33529c595de9be30750882b0cd761adbbfd024e/testproject-python-sdk-1.2.3.tar.gz
BuildArch: noarch
Requires: python3-selenium
Requires: python3-Appium-Python-Client
Requires: python3-decorator
Requires: python3-requests
Requires: python3-importlib-metadata
Requires: python3-packaging
%description
`TestProject `__ is a **Free** Test Automation platform for Web, Mobile and API testing.
To get familiar with the TestProject, visit our main `documentation `__ website.
TestProject SDK is a single, integrated interface to scripting with the most popular open source test automation frameworks.
From now on, you can effortlessly execute Selenium and Appium native tests using a single automation platform that already takes care of all the complex setup, maintenance and configs.
With one unified SDK available across multiple languages, developers and testers receive a go-to toolset, solving some of the greatest challenges in open source test automation.
With TestProject SDK, users save a bunch of time and enjoy the following benefits out of the box:
* 100% open source and available as a `PyPI `__ project.
* 5-minute simple Selenium and Appium setup with a single `Agent `__ deployment.
* Automatic test reports in HTML/PDF format (including screenshots).
* Collaborative reporting dashboards with execution history and RESTful API support.
* Always up-to-date with the latest and stable Selenium driver version.
* A simplified, familiar syntax for both web and mobile applications.
* Complete test runner capabilities for both local and remote executions, anywhere.
* Cross platform support for Mac, Windows, Linux and Docker.
* Ability to store and execute tests locally on any source control tool, such as Git.
%package -n python3-testproject-python-sdk
Summary: Selenium and Appium powered SDK for TestProject.io
Provides: python-testproject-python-sdk
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-testproject-python-sdk
`TestProject `__ is a **Free** Test Automation platform for Web, Mobile and API testing.
To get familiar with the TestProject, visit our main `documentation `__ website.
TestProject SDK is a single, integrated interface to scripting with the most popular open source test automation frameworks.
From now on, you can effortlessly execute Selenium and Appium native tests using a single automation platform that already takes care of all the complex setup, maintenance and configs.
With one unified SDK available across multiple languages, developers and testers receive a go-to toolset, solving some of the greatest challenges in open source test automation.
With TestProject SDK, users save a bunch of time and enjoy the following benefits out of the box:
* 100% open source and available as a `PyPI `__ project.
* 5-minute simple Selenium and Appium setup with a single `Agent `__ deployment.
* Automatic test reports in HTML/PDF format (including screenshots).
* Collaborative reporting dashboards with execution history and RESTful API support.
* Always up-to-date with the latest and stable Selenium driver version.
* A simplified, familiar syntax for both web and mobile applications.
* Complete test runner capabilities for both local and remote executions, anywhere.
* Cross platform support for Mac, Windows, Linux and Docker.
* Ability to store and execute tests locally on any source control tool, such as Git.
%package help
Summary: Development documents and examples for testproject-python-sdk
Provides: python3-testproject-python-sdk-doc
%description help
`TestProject `__ is a **Free** Test Automation platform for Web, Mobile and API testing.
To get familiar with the TestProject, visit our main `documentation `__ website.
TestProject SDK is a single, integrated interface to scripting with the most popular open source test automation frameworks.
From now on, you can effortlessly execute Selenium and Appium native tests using a single automation platform that already takes care of all the complex setup, maintenance and configs.
With one unified SDK available across multiple languages, developers and testers receive a go-to toolset, solving some of the greatest challenges in open source test automation.
With TestProject SDK, users save a bunch of time and enjoy the following benefits out of the box:
* 100% open source and available as a `PyPI `__ project.
* 5-minute simple Selenium and Appium setup with a single `Agent `__ deployment.
* Automatic test reports in HTML/PDF format (including screenshots).
* Collaborative reporting dashboards with execution history and RESTful API support.
* Always up-to-date with the latest and stable Selenium driver version.
* A simplified, familiar syntax for both web and mobile applications.
* Complete test runner capabilities for both local and remote executions, anywhere.
* Cross platform support for Mac, Windows, Linux and Docker.
* Ability to store and execute tests locally on any source control tool, such as Git.
%prep
%autosetup -n testproject-python-sdk-1.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-testproject-python-sdk -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 1.2.3-1
- Package Spec generated