%global _empty_manifest_terminate_build 0
Name: python-tkmatrix
Version: 0.6.0
Release: 1
Summary: ToolKit for Multi-phAse Transits Recovery from Injected eXoplanets
License: MIT License
URL: https://github.com/PlanetHunters/tkmatrix
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/3c/34bda4dcbb616923f26fdfa3f4b5bc006ae99fcd1b1b4d01457b26df5725/tkmatrix-0.6.0.tar.gz
BuildArch: noarch
Requires: python3-argparse
Requires: python3-beautifulsoup4
Requires: python3-configparser
Requires: python3-corner
Requires: python3-cython
Requires: python3-ellc
Requires: python3-lcbuilder
Requires: python3-matplotlib
Requires: python3-mock
Requires: python3-numba
Requires: python3-pyparsing
Requires: python3-seaborn
Requires: python3-setuptools
Requires: python3-scipy
Requires: python3-sklearn
Requires: python3-tqdm
Requires: python3-wotan
%description
# MATRIX ToolKit
ToolKit for Multi-phAse Transits Recovery from Injected eXoplanets
## Citation
We are planning to write a scientific paper based on the usage of MATRIX. In the meantime, we encourage the users to cite the Software DOI in their research:
```
@MISC{2022zndo...6570831D,
author = {{D{\'e}vora-Pajares}, Mart{\'\i}n and {Pozuelos}, Francisco J.},
title = "{MATRIX: Multi-phAse Transits Recovery from Injected eXoplanets}",
keywords = {exoplanets, transits, injection \& recovery, python},
howpublished = {Zenodo},
year = 2022,
month = may,
eid = {10.5281/zenodo.6570831},
doi = {10.5281/zenodo.6570831},
version = {0.3.17},
publisher = {Zenodo},
adsurl = {https://ui.adsabs.harvard.edu/abs/2022zndo...6570831D},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
```
## Main Developers
[M. Dévora Pajares](https://github.com/martindevora)
[F.J. Pozuelos](https://github.com/franpoz)
## Additional contributors
[L. Cerdeño Mota](https://github.com/LuisCerdenoMota)
## Installation
Supported Python versions: 3.8, 3.9. Install with:
```
python3.8 -m pip install numpy==1.22.4
python3.8 -m pip install -r requirements.txt
```
You can find the requirements.txt file [here](https://github.com/PlanetHunters/tkmatrix/blob/master/requirements.txt).
## Tests
We use [tox](https://tox.readthedocs.io) to test MATRIX under all the supported Python versions. Usage:
`tox`
## Examples
Under the [examples](https://github.com/PlanetHunters/tkmatrix/tree/master/examples) directory.
## Execution
Just execute the command below this text. Take into accont that the `user-properties.yaml` file needs to include several mandatory options. Please refer to the example file under the examples directory.
`python3.8 -m tkmatrix --properties user-properties.yaml`
## By-products
* a_tls_report.csv: A file containing a csv formatted output given the orbital period, the radius and the epoch besides the outputs with found status, SNR and SDE of the results.
* a_tls_report.png: A file with an automatically generated plot from the csv report. You are free to build your own plot from the report if you feel like the one provided by MATRIX is not good enough for your purposes.
* Injected curves (csv files): In case you want to study the injected curves generated for the recovery, you can set a flag to the tool so that it keeps the files after it finishes. If you don't provide that flag, the files will be removed at the end of the execution.
%package -n python3-tkmatrix
Summary: ToolKit for Multi-phAse Transits Recovery from Injected eXoplanets
Provides: python-tkmatrix
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-tkmatrix
# MATRIX ToolKit
ToolKit for Multi-phAse Transits Recovery from Injected eXoplanets
## Citation
We are planning to write a scientific paper based on the usage of MATRIX. In the meantime, we encourage the users to cite the Software DOI in their research:
```
@MISC{2022zndo...6570831D,
author = {{D{\'e}vora-Pajares}, Mart{\'\i}n and {Pozuelos}, Francisco J.},
title = "{MATRIX: Multi-phAse Transits Recovery from Injected eXoplanets}",
keywords = {exoplanets, transits, injection \& recovery, python},
howpublished = {Zenodo},
year = 2022,
month = may,
eid = {10.5281/zenodo.6570831},
doi = {10.5281/zenodo.6570831},
version = {0.3.17},
publisher = {Zenodo},
adsurl = {https://ui.adsabs.harvard.edu/abs/2022zndo...6570831D},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
```
## Main Developers
[M. Dévora Pajares](https://github.com/martindevora)
[F.J. Pozuelos](https://github.com/franpoz)
## Additional contributors
[L. Cerdeño Mota](https://github.com/LuisCerdenoMota)
## Installation
Supported Python versions: 3.8, 3.9. Install with:
```
python3.8 -m pip install numpy==1.22.4
python3.8 -m pip install -r requirements.txt
```
You can find the requirements.txt file [here](https://github.com/PlanetHunters/tkmatrix/blob/master/requirements.txt).
## Tests
We use [tox](https://tox.readthedocs.io) to test MATRIX under all the supported Python versions. Usage:
`tox`
## Examples
Under the [examples](https://github.com/PlanetHunters/tkmatrix/tree/master/examples) directory.
## Execution
Just execute the command below this text. Take into accont that the `user-properties.yaml` file needs to include several mandatory options. Please refer to the example file under the examples directory.
`python3.8 -m tkmatrix --properties user-properties.yaml`
## By-products
* a_tls_report.csv: A file containing a csv formatted output given the orbital period, the radius and the epoch besides the outputs with found status, SNR and SDE of the results.
* a_tls_report.png: A file with an automatically generated plot from the csv report. You are free to build your own plot from the report if you feel like the one provided by MATRIX is not good enough for your purposes.
* Injected curves (csv files): In case you want to study the injected curves generated for the recovery, you can set a flag to the tool so that it keeps the files after it finishes. If you don't provide that flag, the files will be removed at the end of the execution.
%package help
Summary: Development documents and examples for tkmatrix
Provides: python3-tkmatrix-doc
%description help
# MATRIX ToolKit
ToolKit for Multi-phAse Transits Recovery from Injected eXoplanets
## Citation
We are planning to write a scientific paper based on the usage of MATRIX. In the meantime, we encourage the users to cite the Software DOI in their research:
```
@MISC{2022zndo...6570831D,
author = {{D{\'e}vora-Pajares}, Mart{\'\i}n and {Pozuelos}, Francisco J.},
title = "{MATRIX: Multi-phAse Transits Recovery from Injected eXoplanets}",
keywords = {exoplanets, transits, injection \& recovery, python},
howpublished = {Zenodo},
year = 2022,
month = may,
eid = {10.5281/zenodo.6570831},
doi = {10.5281/zenodo.6570831},
version = {0.3.17},
publisher = {Zenodo},
adsurl = {https://ui.adsabs.harvard.edu/abs/2022zndo...6570831D},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
```
## Main Developers
[M. Dévora Pajares](https://github.com/martindevora)
[F.J. Pozuelos](https://github.com/franpoz)
## Additional contributors
[L. Cerdeño Mota](https://github.com/LuisCerdenoMota)
## Installation
Supported Python versions: 3.8, 3.9. Install with:
```
python3.8 -m pip install numpy==1.22.4
python3.8 -m pip install -r requirements.txt
```
You can find the requirements.txt file [here](https://github.com/PlanetHunters/tkmatrix/blob/master/requirements.txt).
## Tests
We use [tox](https://tox.readthedocs.io) to test MATRIX under all the supported Python versions. Usage:
`tox`
## Examples
Under the [examples](https://github.com/PlanetHunters/tkmatrix/tree/master/examples) directory.
## Execution
Just execute the command below this text. Take into accont that the `user-properties.yaml` file needs to include several mandatory options. Please refer to the example file under the examples directory.
`python3.8 -m tkmatrix --properties user-properties.yaml`
## By-products
* a_tls_report.csv: A file containing a csv formatted output given the orbital period, the radius and the epoch besides the outputs with found status, SNR and SDE of the results.
* a_tls_report.png: A file with an automatically generated plot from the csv report. You are free to build your own plot from the report if you feel like the one provided by MATRIX is not good enough for your purposes.
* Injected curves (csv files): In case you want to study the injected curves generated for the recovery, you can set a flag to the tool so that it keeps the files after it finishes. If you don't provide that flag, the files will be removed at the end of the execution.
%prep
%autosetup -n tkmatrix-0.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-tkmatrix -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 0.6.0-1
- Package Spec generated