%global _empty_manifest_terminate_build 0
Name: python-Extre
Version: 0.34
Release: 1
Summary: A Secure and Powerful Python-Telethon Based Library For ExtemePro Userbot.
License: GNU AFFERO GENERAL PUBLIC LICENSE (v3)
URL: https://github.com/TeamExtremePro/ExtremeProUserbot
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/58/22/f474666113ac04759f07d6d27a3fffcd3aca2174f452d2f76da9298f14ef/Extre-0.34.tar.gz
BuildArch: noarch
%description
## Usage
=> Create folders named `plugins`, `addons`, `assistant` and `resources`.
=> Add your plugins in the `plugins` folder and others accordingly.
=> Create a `.env` file with `API_ID`, `API_HASH`, `SESSION`,
`BOT_TOKEN`, `BOT_USERNAME` as mandatory environment variables. Check
[`.env.sample`](https://github.com/TeamExtremePro/ExtremeProUserbot/.env.sample) for more details.
=> Run `python -m Extre` to start the bot.
### Creating plugins
To work everywhere
```python
@extremepro_cmd(
pattern="start",
)
async def _(e):
await eor(e, "extremepro Started")
```
To work only in groups
```python
@extremepro_cmd(
pattern="start",
groups_only=True,
)
async def _(e):
await eor(e, "ExtremePro Started")
```
Assistant Plugins 👇
```python
@asst_cmd("start")
async def _(e):
await e.reply("ExtremePro Started")
```
%package -n python3-Extre
Summary: A Secure and Powerful Python-Telethon Based Library For ExtemePro Userbot.
Provides: python-Extre
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Extre
## Usage
=> Create folders named `plugins`, `addons`, `assistant` and `resources`.
=> Add your plugins in the `plugins` folder and others accordingly.
=> Create a `.env` file with `API_ID`, `API_HASH`, `SESSION`,
`BOT_TOKEN`, `BOT_USERNAME` as mandatory environment variables. Check
[`.env.sample`](https://github.com/TeamExtremePro/ExtremeProUserbot/.env.sample) for more details.
=> Run `python -m Extre` to start the bot.
### Creating plugins
To work everywhere
```python
@extremepro_cmd(
pattern="start",
)
async def _(e):
await eor(e, "extremepro Started")
```
To work only in groups
```python
@extremepro_cmd(
pattern="start",
groups_only=True,
)
async def _(e):
await eor(e, "ExtremePro Started")
```
Assistant Plugins 👇
```python
@asst_cmd("start")
async def _(e):
await e.reply("ExtremePro Started")
```
%package help
Summary: Development documents and examples for Extre
Provides: python3-Extre-doc
%description help
## Usage
=> Create folders named `plugins`, `addons`, `assistant` and `resources`.
=> Add your plugins in the `plugins` folder and others accordingly.
=> Create a `.env` file with `API_ID`, `API_HASH`, `SESSION`,
`BOT_TOKEN`, `BOT_USERNAME` as mandatory environment variables. Check
[`.env.sample`](https://github.com/TeamExtremePro/ExtremeProUserbot/.env.sample) for more details.
=> Run `python -m Extre` to start the bot.
### Creating plugins
To work everywhere
```python
@extremepro_cmd(
pattern="start",
)
async def _(e):
await eor(e, "extremepro Started")
```
To work only in groups
```python
@extremepro_cmd(
pattern="start",
groups_only=True,
)
async def _(e):
await eor(e, "ExtremePro Started")
```
Assistant Plugins 👇
```python
@asst_cmd("start")
async def _(e):
await e.reply("ExtremePro Started")
```
%prep
%autosetup -n Extre-0.34
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Extre -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.34-1
- Package Spec generated