%global _empty_manifest_terminate_build 0
Name: python-ibis
Version: 3.2.0
Release: 1
Summary: A template engine for people who enjoy the simpler things in life.
License: Public Domain
URL: https://github.com/dmulholl/ibis
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6a/90/941982259720ebf52d982348b115280e69f2ec188005ebb542d5e6be1db8/ibis-3.2.0.tar.gz
BuildArch: noarch
%description
A template engine for people who enjoy the simpler things in life.
Features:
* Django/Jinja-style syntax.
* Supports looping, conditionals, filters, template inheritance.
* Extensible. Easily add custom template tags and filters.
* Self-contained, no dependencies. Use as a drop-in component in any project.
* Public domain code. No license compatibility issues.
Sample syntax::
See the `package documentation `_ or the
project's `Github homepage `_ for
further details.
%package -n python3-ibis
Summary: A template engine for people who enjoy the simpler things in life.
Provides: python-ibis
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ibis
A template engine for people who enjoy the simpler things in life.
Features:
* Django/Jinja-style syntax.
* Supports looping, conditionals, filters, template inheritance.
* Extensible. Easily add custom template tags and filters.
* Self-contained, no dependencies. Use as a drop-in component in any project.
* Public domain code. No license compatibility issues.
Sample syntax::
See the `package documentation `_ or the
project's `Github homepage `_ for
further details.
%package help
Summary: Development documents and examples for ibis
Provides: python3-ibis-doc
%description help
A template engine for people who enjoy the simpler things in life.
Features:
* Django/Jinja-style syntax.
* Supports looping, conditionals, filters, template inheritance.
* Extensible. Easily add custom template tags and filters.
* Self-contained, no dependencies. Use as a drop-in component in any project.
* Public domain code. No license compatibility issues.
Sample syntax::
See the `package documentation `_ or the
project's `Github homepage `_ for
further details.
%prep
%autosetup -n ibis-3.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ibis -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 3.2.0-1
- Package Spec generated