%global _empty_manifest_terminate_build 0
Name: python-cosmoglobe
Version: 0.9.78
Release: 1
Summary: A Python package for interfacing the Cosmoglobe Sky Model with commander3 outputs for the purpose of producing astrophysical sky maps.
License: GNU GPLv3
URL: https://github.com/Cosmoglobe/Cosmoglobe
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/05/e1/3e0e496dd791ae0df0835653ad4bcd7c2e5d39adbb1327516dda6e88e465/cosmoglobe-0.9.78.tar.gz
BuildArch: noarch
Requires: python3-h5py
Requires: python3-numpy
Requires: python3-numba
Requires: python3-astropy
Requires: python3-healpy
Requires: python3-tqdm
Requires: python3-rich
Requires: python3-cmasher
Requires: python3-click
Requires: python3-setuptools
Requires: python3-scipy
%description
[![Documentation Status](https://readthedocs.org/projects/cosmoglobe/badge/?version=latest)](https://cosmoglobe.readthedocs.io/en/latest/?badge=latest)
[![astropy](http://img.shields.io/badge/powered%20by-AstroPy-orange.svg?style=flat)](http://www.astropy.org/)
*cosmoglobe* is a python package that interfaces the **Cosmoglobe Sky Model** with **[Commander](https://github.com/Cosmoglobe/Commander)** outputs for the purpose of producing astrophysical sky maps.
## Features
See the **[documentation](https://cosmoglobe.readthedocs.io/en/latest/)** for a more comprehensive guide.
**Initialize the Cosmoglobe Sky Model (this downloads and caches a ~800 MB file with the sky model data)**
```python
import cosmoglobe
model = cosmoglobe.sky_model(nside=256)
```
**Simulate the sky at 150 GHz in units of MJy/sr, smoothed to 40 arcmin with a gaussian beam:**
```python
import astropy.units as u
emission = model(150*u.GHz, fwhm=40*u.arcmin, output_unit="MJy/sr")
```
**Integrate over a bandpass:**
```python
import numpy as np
import healpy as hp
import matplotlib.pyplot as plt
# Reading in WMAP K-band bandpass profile.
bandpass_frequencies, bandpass_weights = np.loadtxt(wmap_bandpass.txt, unpack=True)
# The units of the detector must be specified even if the bandpass is pre-normalized.
bandpass_weights *= u.Unit("K_RJ") # Specify K_RJ or K_CMB
bandpass_frequencies *= u.GHz
model.remove_dipole() # Remove the dipole from the CMB component
emission = model(
freqs=bandpass_frequencies,
weights=bandpass_weights,
fwhm=0.8*u.deg,
output_unit="mK_RJ",
)
hp.mollview(emission[0], hist="norm") # Plotting the intensity
plt.show()
```
## Installation
*cosmoglobe* can be installed via pip
```bash
pip install cosmoglobe
```
## Funding
This work has received funding from the European Union's Horizon 2020 research and innovation programme under grant agreements No 776282 (COMPET-4; BeyondPlanck), 772253 (ERC; bits2cosmology) and 819478 (ERC; Cosmoglobe).
![](./imgs/LOGO_ERC-FLAG_EU_.jpg) |
![](./imgs/horizon2020_logo.jpg) |
## License
[GNU GPLv3](https://github.com/Cosmoglobe/Commander/blob/master/COPYING)
%package -n python3-cosmoglobe
Summary: A Python package for interfacing the Cosmoglobe Sky Model with commander3 outputs for the purpose of producing astrophysical sky maps.
Provides: python-cosmoglobe
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cosmoglobe
[![Documentation Status](https://readthedocs.org/projects/cosmoglobe/badge/?version=latest)](https://cosmoglobe.readthedocs.io/en/latest/?badge=latest)
[![astropy](http://img.shields.io/badge/powered%20by-AstroPy-orange.svg?style=flat)](http://www.astropy.org/)
*cosmoglobe* is a python package that interfaces the **Cosmoglobe Sky Model** with **[Commander](https://github.com/Cosmoglobe/Commander)** outputs for the purpose of producing astrophysical sky maps.
## Features
See the **[documentation](https://cosmoglobe.readthedocs.io/en/latest/)** for a more comprehensive guide.
**Initialize the Cosmoglobe Sky Model (this downloads and caches a ~800 MB file with the sky model data)**
```python
import cosmoglobe
model = cosmoglobe.sky_model(nside=256)
```
**Simulate the sky at 150 GHz in units of MJy/sr, smoothed to 40 arcmin with a gaussian beam:**
```python
import astropy.units as u
emission = model(150*u.GHz, fwhm=40*u.arcmin, output_unit="MJy/sr")
```
**Integrate over a bandpass:**
```python
import numpy as np
import healpy as hp
import matplotlib.pyplot as plt
# Reading in WMAP K-band bandpass profile.
bandpass_frequencies, bandpass_weights = np.loadtxt(wmap_bandpass.txt, unpack=True)
# The units of the detector must be specified even if the bandpass is pre-normalized.
bandpass_weights *= u.Unit("K_RJ") # Specify K_RJ or K_CMB
bandpass_frequencies *= u.GHz
model.remove_dipole() # Remove the dipole from the CMB component
emission = model(
freqs=bandpass_frequencies,
weights=bandpass_weights,
fwhm=0.8*u.deg,
output_unit="mK_RJ",
)
hp.mollview(emission[0], hist="norm") # Plotting the intensity
plt.show()
```
## Installation
*cosmoglobe* can be installed via pip
```bash
pip install cosmoglobe
```
## Funding
This work has received funding from the European Union's Horizon 2020 research and innovation programme under grant agreements No 776282 (COMPET-4; BeyondPlanck), 772253 (ERC; bits2cosmology) and 819478 (ERC; Cosmoglobe).
![](./imgs/LOGO_ERC-FLAG_EU_.jpg) |
![](./imgs/horizon2020_logo.jpg) |
## License
[GNU GPLv3](https://github.com/Cosmoglobe/Commander/blob/master/COPYING)
%package help
Summary: Development documents and examples for cosmoglobe
Provides: python3-cosmoglobe-doc
%description help
[![Documentation Status](https://readthedocs.org/projects/cosmoglobe/badge/?version=latest)](https://cosmoglobe.readthedocs.io/en/latest/?badge=latest)
[![astropy](http://img.shields.io/badge/powered%20by-AstroPy-orange.svg?style=flat)](http://www.astropy.org/)
*cosmoglobe* is a python package that interfaces the **Cosmoglobe Sky Model** with **[Commander](https://github.com/Cosmoglobe/Commander)** outputs for the purpose of producing astrophysical sky maps.
## Features
See the **[documentation](https://cosmoglobe.readthedocs.io/en/latest/)** for a more comprehensive guide.
**Initialize the Cosmoglobe Sky Model (this downloads and caches a ~800 MB file with the sky model data)**
```python
import cosmoglobe
model = cosmoglobe.sky_model(nside=256)
```
**Simulate the sky at 150 GHz in units of MJy/sr, smoothed to 40 arcmin with a gaussian beam:**
```python
import astropy.units as u
emission = model(150*u.GHz, fwhm=40*u.arcmin, output_unit="MJy/sr")
```
**Integrate over a bandpass:**
```python
import numpy as np
import healpy as hp
import matplotlib.pyplot as plt
# Reading in WMAP K-band bandpass profile.
bandpass_frequencies, bandpass_weights = np.loadtxt(wmap_bandpass.txt, unpack=True)
# The units of the detector must be specified even if the bandpass is pre-normalized.
bandpass_weights *= u.Unit("K_RJ") # Specify K_RJ or K_CMB
bandpass_frequencies *= u.GHz
model.remove_dipole() # Remove the dipole from the CMB component
emission = model(
freqs=bandpass_frequencies,
weights=bandpass_weights,
fwhm=0.8*u.deg,
output_unit="mK_RJ",
)
hp.mollview(emission[0], hist="norm") # Plotting the intensity
plt.show()
```
## Installation
*cosmoglobe* can be installed via pip
```bash
pip install cosmoglobe
```
## Funding
This work has received funding from the European Union's Horizon 2020 research and innovation programme under grant agreements No 776282 (COMPET-4; BeyondPlanck), 772253 (ERC; bits2cosmology) and 819478 (ERC; Cosmoglobe).
![](./imgs/LOGO_ERC-FLAG_EU_.jpg) |
![](./imgs/horizon2020_logo.jpg) |
## License
[GNU GPLv3](https://github.com/Cosmoglobe/Commander/blob/master/COPYING)
%prep
%autosetup -n cosmoglobe-0.9.78
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cosmoglobe -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.9.78-1
- Package Spec generated