%global _empty_manifest_terminate_build 0
Name: python-pysistence
Version: 0.4.1
Release: 1
Summary: A set of functional data structures for Python
License: License :: OSI Approved :: MIT License
URL: http://packages.python.org/pysistence
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6b/24/5b365dd2ac6501fcc5481b622eae0661ec38e1d27f5f3a787a0e2e1d090e/pysistence-0.4.1.tar.gz
BuildArch: noarch
%description
You may download the current release of Pysistence from our `PyPI page `_. You may also use easy_install to install pysistence::
sudo easy_install pysistence
If you have Mercurial installed, you can use the following command to check out Pysistence::
hg clone http://bitbucket.org/jasbaker/pysistence/
Note that you do need `setuptools ` or `distribute ` for the next step::
python setup.py install
If you're brave, you can try using pysistence's experimental C extension::
python setup.py install --with-cext
%package -n python3-pysistence
Summary: A set of functional data structures for Python
Provides: python-pysistence
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pysistence
You may download the current release of Pysistence from our `PyPI page `_. You may also use easy_install to install pysistence::
sudo easy_install pysistence
If you have Mercurial installed, you can use the following command to check out Pysistence::
hg clone http://bitbucket.org/jasbaker/pysistence/
Note that you do need `setuptools ` or `distribute ` for the next step::
python setup.py install
If you're brave, you can try using pysistence's experimental C extension::
python setup.py install --with-cext
%package help
Summary: Development documents and examples for pysistence
Provides: python3-pysistence-doc
%description help
You may download the current release of Pysistence from our `PyPI page `_. You may also use easy_install to install pysistence::
sudo easy_install pysistence
If you have Mercurial installed, you can use the following command to check out Pysistence::
hg clone http://bitbucket.org/jasbaker/pysistence/
Note that you do need `setuptools ` or `distribute ` for the next step::
python setup.py install
If you're brave, you can try using pysistence's experimental C extension::
python setup.py install --with-cext
%prep
%autosetup -n pysistence-0.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pysistence -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.4.1-1
- Package Spec generated