%global _empty_manifest_terminate_build 0 Name: python-justgood Version: 2.3.0 Release: 1 Summary: Sample request for api.imjustgood.com please visit webpage imjustgood.com for more details License: MIT URL: https://github.com/RendyTR/api.imjustgood.com Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e1/41/d83e56464a1f8313f8ab43bd7f1d3c6022ac8f300dd6d62be53e01ca9e07/justgood-2.3.0.tar.gz BuildArch: noarch %description ## API.IMJUSTGOOD.COM ``` █ █▀▄▀█ ▀█ █ █ █▀▀▀ ▀▀█▀▀ █▀▀▀ █▀▀█ █▀▀█ █▀▀▄ █ █ ▀ █ ▄▄█ █▄▄█ ▄▄▄█ █ █▄▄█ █▄▄█ █▄▄█ █▄▄▀ API MEDIA SERVICE TO MAKE YOUR CODE MORE BETTER. ```

PyPI Update Views

Full documentation available here ### Installation ``` pip3 install justgood ``` ### Upgrade ``` pip3 install --upgrade justgood ``` ### Documentation You need apikey to authenticate calling our program.
Here is how to use the module in your own python code. we choose instapost media as an example. ```python from justgood import imjustgood api = imjustgood("INSERT_YOUR_APIKEY_HERE") data = api.instapost("https://.instagram.com/p/Cg74iKsBBc2/") print(data) ``` [ 2OO ] Response Success ```json { "creator": "Imjustgood", "result": { "caption": "GET STARTED NOW\nhttps://api.imjustgood.com\n#api #bot #pypi #coder #programmer", "comments": "0", "created": "5 months ago", "fullname": "The Autobots Corporation", "likes": "3", "picture": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-19/272003703_1108244669995347_1136634152614637195_n.jpg?stp=dst-jpg_s150x150&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=103&_nc_ohc=zdEObJxmKCUAX9S4iAR&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDHmFkCgpIGfI-N5wQyvarDSMLQuT59GhAAY0hmJfMEug&oe=63B9CB82&_nc_sid=4f375e", "postData": [ { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e", "type": "image" }, { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e", "type": "image" }, { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t50.2886-16/298161345_1019698588712326_4289148637928675103_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InZ0c192b2RfdXJsZ2VuLjY0MC5jYXJvdXNlbF9pdGVtLmJhc2VsaW5lIiwicWVfZ3JvdXBzIjoiW1wiaWdfd2ViX2RlbGl2ZXJ5X3Z0c19vdGZcIl0ifQ&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=110&_nc_ohc=O4hX3emjkcIAX8Uk3oZ&tn=3OBlyBWCNXe0Z2Yw&edm=AP_V10EBAAAA&vs=584342153190694_3179117251&_nc_vs=HBksFQAYJEdNR1V4UkdHZlNnVWFaOERBQi1YbGhqMkhZWTdia1lMQUFBRhUAAsgBABUAGCRHRlpRdnhINW1YWnY5M2tCQUx3X3dRUnUxQk5pYmtZTEFBQUYVAgLIAQAoABgAGwGIB3VzZV9vaWwBMBUAACbmm5idj%2BXnPxUCKAJDMywXQCtU%2FfO2RaIYEmRhc2hfYmFzZWxpbmVfMV92MREAde4HAA%3D%3D&ccb=7-5&oh=00_AfBmGM0IMbYbspzTCoQutGDRJud2jKqtOsR7p3AjhUpWuQ&oe=63B63D86&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297833882_144728104900625_5890250235783357340_n.jpg?stp=dst-jpg_e15&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=105&_nc_ohc=uRKv0ulupYgAX93jqv9&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfAryUwU7X981CR-XZPRokqS3MO9f-ygfv8KCLfr2s2dKg&oe=63B9B217&_nc_sid=4f375e", "type": "video" } ], "postType": "post", "private": false, "slidePost": true, "username": "the.autobots_corp", "verified": false }, "status": 200 } ``` Get certain attributes ``` >>> username = data["result"]["username"] >>> print(username) the.autobots_corp >>> fullname = data["result"]["fullname"] >>> print(fullname) The Autobots Corporation >>> created = data["result"]["created"] >>> print(created) 5 months ago >>> caption = data["result"]["caption"] >>> print(caption) GET STARTED NOW https://api.imjustgood.com #api #bot #pypi #coder #programmer >>> picture = data["result"]["picture"] >>> print(picture) https://scontent-iad3-2.cdninstagram.com/v/t51.2885-19/272003703_1108244669995347_1136634152614637195_n.jpg?stp=dst-jpg_s150x150&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=103&_nc_ohc=zdEObJxmKCUAX9S4iAR&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDHmFkCgpIGfI-N5wQyvarDSMLQuT59GhAAY0hmJfMEug&oe=63B9CB82&_nc_sid=4f375e >>> for a in data["result"]["postData"]: ... print(a["type"], a["postUrl"]) image https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e image https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e video https://scontent-iad3-2.cdninstagram.com/v/t50.2886-16/298161345_1019698588712326_4289148637928675103_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InZ0c192b2RfdXJsZ2VuLjY0MC5jYXJvdXNlbF9pdGVtLmJhc2VsaW5lIiwicWVfZ3JvdXBzIjoiW1wiaWdfd2ViX2RlbGl2ZXJ5X3Z0c19vdGZcIl0ifQ&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=110&_nc_ohc=O4hX3emjkcIAX8Uk3oZ&tn=3OBlyBWCNXe0Z2Yw&edm=AP_V10EBAAAA&vs=584342153190694_3179117251&_nc_vs=HBksFQAYJEdNR1V4UkdHZlNnVWFaOERBQi1YbGhqMkhZWTdia1lMQUFBRhUAAsgBABUAGCRHRlpRdnhINW1YWnY5M2tCQUx3X3dRUnUxQk5pYmtZTEFBQUYVAgLIAQAoABgAGwGIB3VzZV9vaWwBMBUAACbmm5idj%2BXnPxUCKAJDMywXQCtU%2FfO2RaIYEmRhc2hfYmFzZWxpbmVfMV92MREAde4HAA%3D%3D&ccb=7-5&oh=00_AfBmGM0IMbYbspzTCoQutGDRJud2jKqtOsR7p3AjhUpWuQ&oe=63B63D86&_nc_sid=4f375e ``` ### More Media Fitures
Apikey Status Active Example
Youtube Search Active Example
Youtube Downloader Active Example
Joox Music Active Example
Lyric Finder Active Example
Chord Guitar Finder Active Example
Smule Profile Active Example
Smule Downloader Active Example
TikTok Profile Active Example
TikTok Downloader Active Example
Instagram Profile Active Example
Instagram Post Active Example
Instagram Story Active Example
Twitter Profile Active Example
Twitter Downloader Active Example
Facebook Downloader Active Example
Pinterest Search Active Example
Pinterest Downloader Active Example
Snackvideo Downloader Active Example
GitHub Profile Active Example
Secreto Profile Active Example
LINE Secondary Active Example
LINE Voom Active Example
LINE Sticker Store Active Example
LINE App Version Active Example
Google Search Active Example
Google Image Active Example
Google Playstore Active Example
Google Translate Active Example
Google Place Active Example
Random Proxies Active Example
Wallpaper HD Active Example
Porn Videos Active Example
Pornstar Active Example
Hentai Active Example
Kamasutra Active Example
Dick Analyze Active Example
Tits Analyze Active Example
Vagina Analyze Active Example
Meme Generator Active Example
Movie Review Active Example
Movie Quotes Active Example
Cinema 21 Active Example
TinyUrl Active Example
Bit.ly Active Example
KBBI Active Example
Top News Active Example
Wikipedia Active Example
Urban Dictionary Active Example
Zodiac Daily Active Example
Al-Qur'an Active Example
Bible Active Example
Info Waktu Sholat Active Example
Info Cuaca Dunia Active Example
Info Gempa BMKG Active Example
Info Corona Virus Active Example
Info Lowongan Kerja Active Example
Info Resi Pengiriman Active Example
Info Phone Cellular Active Example
Info Tanggal Lahir Active Example
Info Tanggal Jadian Active Example
Arti Nama Active Example
Arti Mimpi Active Example
Acara TV Sekarang Active Example
Acara TV Stasiun Active Example
CCTV Camera Code Active Example
CCTV Camera Search Active Example
Manga Search Active Example
Manga Chapter Active Example
Calculator Active Example
Check IP Address Active Example
Binary Encode Active Example
Binary Decode Active Example
Base64 Encode Active Example
Base64 Decode Active Example
Screenshot Web Active Example
ASCII Text Active Example
Fancy Text Active Example
Customize URL Active Example
GIF Search Active Example
Convert Image to URL Active Example
Convert Text to Image Active Example
Watermark Text Active Example
Watermark Image Active Example
SimiSimi Active Example
Stamp Image Active Example
TextPro Active Example
PhotoHack Active Example
Gold Currency Active Example
Crypto Currency Active Example
Remove Background Active Example
### Contact us * IMJUSTGOOD TEAM %package -n python3-justgood Summary: Sample request for api.imjustgood.com please visit webpage imjustgood.com for more details Provides: python-justgood BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-justgood ## API.IMJUSTGOOD.COM ``` █ █▀▄▀█ ▀█ █ █ █▀▀▀ ▀▀█▀▀ █▀▀▀ █▀▀█ █▀▀█ █▀▀▄ █ █ ▀ █ ▄▄█ █▄▄█ ▄▄▄█ █ █▄▄█ █▄▄█ █▄▄█ █▄▄▀ API MEDIA SERVICE TO MAKE YOUR CODE MORE BETTER. ```

PyPI Update Views

Full documentation available here ### Installation ``` pip3 install justgood ``` ### Upgrade ``` pip3 install --upgrade justgood ``` ### Documentation You need apikey to authenticate calling our program.
Here is how to use the module in your own python code. we choose instapost media as an example. ```python from justgood import imjustgood api = imjustgood("INSERT_YOUR_APIKEY_HERE") data = api.instapost("https://.instagram.com/p/Cg74iKsBBc2/") print(data) ``` [ 2OO ] Response Success ```json { "creator": "Imjustgood", "result": { "caption": "GET STARTED NOW\nhttps://api.imjustgood.com\n#api #bot #pypi #coder #programmer", "comments": "0", "created": "5 months ago", "fullname": "The Autobots Corporation", "likes": "3", "picture": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-19/272003703_1108244669995347_1136634152614637195_n.jpg?stp=dst-jpg_s150x150&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=103&_nc_ohc=zdEObJxmKCUAX9S4iAR&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDHmFkCgpIGfI-N5wQyvarDSMLQuT59GhAAY0hmJfMEug&oe=63B9CB82&_nc_sid=4f375e", "postData": [ { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e", "type": "image" }, { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e", "type": "image" }, { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t50.2886-16/298161345_1019698588712326_4289148637928675103_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InZ0c192b2RfdXJsZ2VuLjY0MC5jYXJvdXNlbF9pdGVtLmJhc2VsaW5lIiwicWVfZ3JvdXBzIjoiW1wiaWdfd2ViX2RlbGl2ZXJ5X3Z0c19vdGZcIl0ifQ&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=110&_nc_ohc=O4hX3emjkcIAX8Uk3oZ&tn=3OBlyBWCNXe0Z2Yw&edm=AP_V10EBAAAA&vs=584342153190694_3179117251&_nc_vs=HBksFQAYJEdNR1V4UkdHZlNnVWFaOERBQi1YbGhqMkhZWTdia1lMQUFBRhUAAsgBABUAGCRHRlpRdnhINW1YWnY5M2tCQUx3X3dRUnUxQk5pYmtZTEFBQUYVAgLIAQAoABgAGwGIB3VzZV9vaWwBMBUAACbmm5idj%2BXnPxUCKAJDMywXQCtU%2FfO2RaIYEmRhc2hfYmFzZWxpbmVfMV92MREAde4HAA%3D%3D&ccb=7-5&oh=00_AfBmGM0IMbYbspzTCoQutGDRJud2jKqtOsR7p3AjhUpWuQ&oe=63B63D86&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297833882_144728104900625_5890250235783357340_n.jpg?stp=dst-jpg_e15&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=105&_nc_ohc=uRKv0ulupYgAX93jqv9&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfAryUwU7X981CR-XZPRokqS3MO9f-ygfv8KCLfr2s2dKg&oe=63B9B217&_nc_sid=4f375e", "type": "video" } ], "postType": "post", "private": false, "slidePost": true, "username": "the.autobots_corp", "verified": false }, "status": 200 } ``` Get certain attributes ``` >>> username = data["result"]["username"] >>> print(username) the.autobots_corp >>> fullname = data["result"]["fullname"] >>> print(fullname) The Autobots Corporation >>> created = data["result"]["created"] >>> print(created) 5 months ago >>> caption = data["result"]["caption"] >>> print(caption) GET STARTED NOW https://api.imjustgood.com #api #bot #pypi #coder #programmer >>> picture = data["result"]["picture"] >>> print(picture) https://scontent-iad3-2.cdninstagram.com/v/t51.2885-19/272003703_1108244669995347_1136634152614637195_n.jpg?stp=dst-jpg_s150x150&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=103&_nc_ohc=zdEObJxmKCUAX9S4iAR&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDHmFkCgpIGfI-N5wQyvarDSMLQuT59GhAAY0hmJfMEug&oe=63B9CB82&_nc_sid=4f375e >>> for a in data["result"]["postData"]: ... print(a["type"], a["postUrl"]) image https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e image https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e video https://scontent-iad3-2.cdninstagram.com/v/t50.2886-16/298161345_1019698588712326_4289148637928675103_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InZ0c192b2RfdXJsZ2VuLjY0MC5jYXJvdXNlbF9pdGVtLmJhc2VsaW5lIiwicWVfZ3JvdXBzIjoiW1wiaWdfd2ViX2RlbGl2ZXJ5X3Z0c19vdGZcIl0ifQ&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=110&_nc_ohc=O4hX3emjkcIAX8Uk3oZ&tn=3OBlyBWCNXe0Z2Yw&edm=AP_V10EBAAAA&vs=584342153190694_3179117251&_nc_vs=HBksFQAYJEdNR1V4UkdHZlNnVWFaOERBQi1YbGhqMkhZWTdia1lMQUFBRhUAAsgBABUAGCRHRlpRdnhINW1YWnY5M2tCQUx3X3dRUnUxQk5pYmtZTEFBQUYVAgLIAQAoABgAGwGIB3VzZV9vaWwBMBUAACbmm5idj%2BXnPxUCKAJDMywXQCtU%2FfO2RaIYEmRhc2hfYmFzZWxpbmVfMV92MREAde4HAA%3D%3D&ccb=7-5&oh=00_AfBmGM0IMbYbspzTCoQutGDRJud2jKqtOsR7p3AjhUpWuQ&oe=63B63D86&_nc_sid=4f375e ``` ### More Media Fitures
Apikey Status Active Example
Youtube Search Active Example
Youtube Downloader Active Example
Joox Music Active Example
Lyric Finder Active Example
Chord Guitar Finder Active Example
Smule Profile Active Example
Smule Downloader Active Example
TikTok Profile Active Example
TikTok Downloader Active Example
Instagram Profile Active Example
Instagram Post Active Example
Instagram Story Active Example
Twitter Profile Active Example
Twitter Downloader Active Example
Facebook Downloader Active Example
Pinterest Search Active Example
Pinterest Downloader Active Example
Snackvideo Downloader Active Example
GitHub Profile Active Example
Secreto Profile Active Example
LINE Secondary Active Example
LINE Voom Active Example
LINE Sticker Store Active Example
LINE App Version Active Example
Google Search Active Example
Google Image Active Example
Google Playstore Active Example
Google Translate Active Example
Google Place Active Example
Random Proxies Active Example
Wallpaper HD Active Example
Porn Videos Active Example
Pornstar Active Example
Hentai Active Example
Kamasutra Active Example
Dick Analyze Active Example
Tits Analyze Active Example
Vagina Analyze Active Example
Meme Generator Active Example
Movie Review Active Example
Movie Quotes Active Example
Cinema 21 Active Example
TinyUrl Active Example
Bit.ly Active Example
KBBI Active Example
Top News Active Example
Wikipedia Active Example
Urban Dictionary Active Example
Zodiac Daily Active Example
Al-Qur'an Active Example
Bible Active Example
Info Waktu Sholat Active Example
Info Cuaca Dunia Active Example
Info Gempa BMKG Active Example
Info Corona Virus Active Example
Info Lowongan Kerja Active Example
Info Resi Pengiriman Active Example
Info Phone Cellular Active Example
Info Tanggal Lahir Active Example
Info Tanggal Jadian Active Example
Arti Nama Active Example
Arti Mimpi Active Example
Acara TV Sekarang Active Example
Acara TV Stasiun Active Example
CCTV Camera Code Active Example
CCTV Camera Search Active Example
Manga Search Active Example
Manga Chapter Active Example
Calculator Active Example
Check IP Address Active Example
Binary Encode Active Example
Binary Decode Active Example
Base64 Encode Active Example
Base64 Decode Active Example
Screenshot Web Active Example
ASCII Text Active Example
Fancy Text Active Example
Customize URL Active Example
GIF Search Active Example
Convert Image to URL Active Example
Convert Text to Image Active Example
Watermark Text Active Example
Watermark Image Active Example
SimiSimi Active Example
Stamp Image Active Example
TextPro Active Example
PhotoHack Active Example
Gold Currency Active Example
Crypto Currency Active Example
Remove Background Active Example
### Contact us * IMJUSTGOOD TEAM %package help Summary: Development documents and examples for justgood Provides: python3-justgood-doc %description help ## API.IMJUSTGOOD.COM ``` █ █▀▄▀█ ▀█ █ █ █▀▀▀ ▀▀█▀▀ █▀▀▀ █▀▀█ █▀▀█ █▀▀▄ █ █ ▀ █ ▄▄█ █▄▄█ ▄▄▄█ █ █▄▄█ █▄▄█ █▄▄█ █▄▄▀ API MEDIA SERVICE TO MAKE YOUR CODE MORE BETTER. ```

PyPI Update Views

Full documentation available here ### Installation ``` pip3 install justgood ``` ### Upgrade ``` pip3 install --upgrade justgood ``` ### Documentation You need apikey to authenticate calling our program.
Here is how to use the module in your own python code. we choose instapost media as an example. ```python from justgood import imjustgood api = imjustgood("INSERT_YOUR_APIKEY_HERE") data = api.instapost("https://.instagram.com/p/Cg74iKsBBc2/") print(data) ``` [ 2OO ] Response Success ```json { "creator": "Imjustgood", "result": { "caption": "GET STARTED NOW\nhttps://api.imjustgood.com\n#api #bot #pypi #coder #programmer", "comments": "0", "created": "5 months ago", "fullname": "The Autobots Corporation", "likes": "3", "picture": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-19/272003703_1108244669995347_1136634152614637195_n.jpg?stp=dst-jpg_s150x150&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=103&_nc_ohc=zdEObJxmKCUAX9S4iAR&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDHmFkCgpIGfI-N5wQyvarDSMLQuT59GhAAY0hmJfMEug&oe=63B9CB82&_nc_sid=4f375e", "postData": [ { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e", "type": "image" }, { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e", "type": "image" }, { "postUrl": "https://scontent-iad3-2.cdninstagram.com/v/t50.2886-16/298161345_1019698588712326_4289148637928675103_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InZ0c192b2RfdXJsZ2VuLjY0MC5jYXJvdXNlbF9pdGVtLmJhc2VsaW5lIiwicWVfZ3JvdXBzIjoiW1wiaWdfd2ViX2RlbGl2ZXJ5X3Z0c19vdGZcIl0ifQ&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=110&_nc_ohc=O4hX3emjkcIAX8Uk3oZ&tn=3OBlyBWCNXe0Z2Yw&edm=AP_V10EBAAAA&vs=584342153190694_3179117251&_nc_vs=HBksFQAYJEdNR1V4UkdHZlNnVWFaOERBQi1YbGhqMkhZWTdia1lMQUFBRhUAAsgBABUAGCRHRlpRdnhINW1YWnY5M2tCQUx3X3dRUnUxQk5pYmtZTEFBQUYVAgLIAQAoABgAGwGIB3VzZV9vaWwBMBUAACbmm5idj%2BXnPxUCKAJDMywXQCtU%2FfO2RaIYEmRhc2hfYmFzZWxpbmVfMV92MREAde4HAA%3D%3D&ccb=7-5&oh=00_AfBmGM0IMbYbspzTCoQutGDRJud2jKqtOsR7p3AjhUpWuQ&oe=63B63D86&_nc_sid=4f375e", "poster": "https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297833882_144728104900625_5890250235783357340_n.jpg?stp=dst-jpg_e15&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=105&_nc_ohc=uRKv0ulupYgAX93jqv9&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfAryUwU7X981CR-XZPRokqS3MO9f-ygfv8KCLfr2s2dKg&oe=63B9B217&_nc_sid=4f375e", "type": "video" } ], "postType": "post", "private": false, "slidePost": true, "username": "the.autobots_corp", "verified": false }, "status": 200 } ``` Get certain attributes ``` >>> username = data["result"]["username"] >>> print(username) the.autobots_corp >>> fullname = data["result"]["fullname"] >>> print(fullname) The Autobots Corporation >>> created = data["result"]["created"] >>> print(created) 5 months ago >>> caption = data["result"]["caption"] >>> print(caption) GET STARTED NOW https://api.imjustgood.com #api #bot #pypi #coder #programmer >>> picture = data["result"]["picture"] >>> print(picture) https://scontent-iad3-2.cdninstagram.com/v/t51.2885-19/272003703_1108244669995347_1136634152614637195_n.jpg?stp=dst-jpg_s150x150&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=103&_nc_ohc=zdEObJxmKCUAX9S4iAR&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDHmFkCgpIGfI-N5wQyvarDSMLQuT59GhAAY0hmJfMEug&oe=63B9CB82&_nc_sid=4f375e >>> for a in data["result"]["postData"]: ... print(a["type"], a["postUrl"]) image https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297855880_804422890580244_3970587908499851308_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=100&_nc_ohc=FIePBkvAxicAX9iV9sf&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDRbS-OZxDXeYK0ea_kHvfbdCxsIEx-Vjo5BlwStxoXBQ&oe=63B93908&_nc_sid=4f375e image https://scontent-iad3-2.cdninstagram.com/v/t51.2885-15/297518102_151529124202237_7924946476954369740_n.jpg?stp=dst-jpg_e35_p1080x1080&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=101&_nc_ohc=SYtZTBJneuwAX8ZjfAl&edm=AP_V10EBAAAA&ccb=7-5&oh=00_AfDLfmQeKhj59gB4x8IXcyuB6ZXu4tY8rQuzUC7AyBj-Cg&oe=63B95A18&_nc_sid=4f375e video https://scontent-iad3-2.cdninstagram.com/v/t50.2886-16/298161345_1019698588712326_4289148637928675103_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InZ0c192b2RfdXJsZ2VuLjY0MC5jYXJvdXNlbF9pdGVtLmJhc2VsaW5lIiwicWVfZ3JvdXBzIjoiW1wiaWdfd2ViX2RlbGl2ZXJ5X3Z0c19vdGZcIl0ifQ&_nc_ht=scontent-iad3-2.cdninstagram.com&_nc_cat=110&_nc_ohc=O4hX3emjkcIAX8Uk3oZ&tn=3OBlyBWCNXe0Z2Yw&edm=AP_V10EBAAAA&vs=584342153190694_3179117251&_nc_vs=HBksFQAYJEdNR1V4UkdHZlNnVWFaOERBQi1YbGhqMkhZWTdia1lMQUFBRhUAAsgBABUAGCRHRlpRdnhINW1YWnY5M2tCQUx3X3dRUnUxQk5pYmtZTEFBQUYVAgLIAQAoABgAGwGIB3VzZV9vaWwBMBUAACbmm5idj%2BXnPxUCKAJDMywXQCtU%2FfO2RaIYEmRhc2hfYmFzZWxpbmVfMV92MREAde4HAA%3D%3D&ccb=7-5&oh=00_AfBmGM0IMbYbspzTCoQutGDRJud2jKqtOsR7p3AjhUpWuQ&oe=63B63D86&_nc_sid=4f375e ``` ### More Media Fitures
Apikey Status Active Example
Youtube Search Active Example
Youtube Downloader Active Example
Joox Music Active Example
Lyric Finder Active Example
Chord Guitar Finder Active Example
Smule Profile Active Example
Smule Downloader Active Example
TikTok Profile Active Example
TikTok Downloader Active Example
Instagram Profile Active Example
Instagram Post Active Example
Instagram Story Active Example
Twitter Profile Active Example
Twitter Downloader Active Example
Facebook Downloader Active Example
Pinterest Search Active Example
Pinterest Downloader Active Example
Snackvideo Downloader Active Example
GitHub Profile Active Example
Secreto Profile Active Example
LINE Secondary Active Example
LINE Voom Active Example
LINE Sticker Store Active Example
LINE App Version Active Example
Google Search Active Example
Google Image Active Example
Google Playstore Active Example
Google Translate Active Example
Google Place Active Example
Random Proxies Active Example
Wallpaper HD Active Example
Porn Videos Active Example
Pornstar Active Example
Hentai Active Example
Kamasutra Active Example
Dick Analyze Active Example
Tits Analyze Active Example
Vagina Analyze Active Example
Meme Generator Active Example
Movie Review Active Example
Movie Quotes Active Example
Cinema 21 Active Example
TinyUrl Active Example
Bit.ly Active Example
KBBI Active Example
Top News Active Example
Wikipedia Active Example
Urban Dictionary Active Example
Zodiac Daily Active Example
Al-Qur'an Active Example
Bible Active Example
Info Waktu Sholat Active Example
Info Cuaca Dunia Active Example
Info Gempa BMKG Active Example
Info Corona Virus Active Example
Info Lowongan Kerja Active Example
Info Resi Pengiriman Active Example
Info Phone Cellular Active Example
Info Tanggal Lahir Active Example
Info Tanggal Jadian Active Example
Arti Nama Active Example
Arti Mimpi Active Example
Acara TV Sekarang Active Example
Acara TV Stasiun Active Example
CCTV Camera Code Active Example
CCTV Camera Search Active Example
Manga Search Active Example
Manga Chapter Active Example
Calculator Active Example
Check IP Address Active Example
Binary Encode Active Example
Binary Decode Active Example
Base64 Encode Active Example
Base64 Decode Active Example
Screenshot Web Active Example
ASCII Text Active Example
Fancy Text Active Example
Customize URL Active Example
GIF Search Active Example
Convert Image to URL Active Example
Convert Text to Image Active Example
Watermark Text Active Example
Watermark Image Active Example
SimiSimi Active Example
Stamp Image Active Example
TextPro Active Example
PhotoHack Active Example
Gold Currency Active Example
Crypto Currency Active Example
Remove Background Active Example
### Contact us * IMJUSTGOOD TEAM %prep %autosetup -n justgood-2.3.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-justgood -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu May 18 2023 Python_Bot - 2.3.0-1 - Package Spec generated