%global _empty_manifest_terminate_build 0
Name: python-excelrd
Version: 2.0.3
Release: 1
Summary: Library for developers to extract data from Microsoft Excel (tm) spreadsheet files
License: BSD
URL: https://github.com/thombashi/excelrd
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dc/48/a558d78f704d8ca61488b96a2c981b185ef3339bd0bcf51b65f4d9f45b8d/excelrd-2.0.3.tar.gz
BuildArch: noarch
Requires: python3-releasecmd
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pylama
Requires: python3-pytest
Requires: python3-pytest
%description
``excelrd`` is a modified version of `xlrd `__ to work for the latest Python versions.
``xlrd`` will not work at Python 3.9 or newer versions.
**Purpose**: Provide a library for developers to use to extract data from Microsoft Excel (tm) spreadsheet files. It is not an end-user tool.
**Author**: John Machin
**Licence**: BSD-style (see licences.py)
**Versions of Python supported**: 3.5+.
**Outside scope**: excelrd will safely and reliably ignore any of these
if present in the file:
- Charts, Macros, Pictures, any other embedded object. WARNING:
currently this includes embedded worksheets.
- VBA modules
- Formulas (results of formula calculations are extracted, of course).
- Comments
- Hyperlinks
- Autofilters, advanced filters, pivot tables, conditional formatting,
data validation
- Handling password-protected (encrypted) files.
%package -n python3-excelrd
Summary: Library for developers to extract data from Microsoft Excel (tm) spreadsheet files
Provides: python-excelrd
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-excelrd
``excelrd`` is a modified version of `xlrd `__ to work for the latest Python versions.
``xlrd`` will not work at Python 3.9 or newer versions.
**Purpose**: Provide a library for developers to use to extract data from Microsoft Excel (tm) spreadsheet files. It is not an end-user tool.
**Author**: John Machin
**Licence**: BSD-style (see licences.py)
**Versions of Python supported**: 3.5+.
**Outside scope**: excelrd will safely and reliably ignore any of these
if present in the file:
- Charts, Macros, Pictures, any other embedded object. WARNING:
currently this includes embedded worksheets.
- VBA modules
- Formulas (results of formula calculations are extracted, of course).
- Comments
- Hyperlinks
- Autofilters, advanced filters, pivot tables, conditional formatting,
data validation
- Handling password-protected (encrypted) files.
%package help
Summary: Development documents and examples for excelrd
Provides: python3-excelrd-doc
%description help
``excelrd`` is a modified version of `xlrd `__ to work for the latest Python versions.
``xlrd`` will not work at Python 3.9 or newer versions.
**Purpose**: Provide a library for developers to use to extract data from Microsoft Excel (tm) spreadsheet files. It is not an end-user tool.
**Author**: John Machin
**Licence**: BSD-style (see licences.py)
**Versions of Python supported**: 3.5+.
**Outside scope**: excelrd will safely and reliably ignore any of these
if present in the file:
- Charts, Macros, Pictures, any other embedded object. WARNING:
currently this includes embedded worksheets.
- VBA modules
- Formulas (results of formula calculations are extracted, of course).
- Comments
- Hyperlinks
- Autofilters, advanced filters, pivot tables, conditional formatting,
data validation
- Handling password-protected (encrypted) files.
%prep
%autosetup -n excelrd-2.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-excelrd -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 2.0.3-1
- Package Spec generated