%global _empty_manifest_terminate_build 0 Name: python-http-request-response Version: 0.0.25 Release: 1 Summary: The main target of this library is to standardize the request response in case of using flask-restplus library. License: MIT URL: https://github.com/Quakingaspen-codehub/http_request_response Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ca/f1/44f8f20401fafbc678f7b5fb210e8b474f2a5c304ff8735ad3ba0eef29de/http_request_response-0.0.25.tar.gz BuildArch: noarch Requires: python3-http-status-code %description
# http_request_response [Introduction](#Introduction)\ [Getting Started](#Started)\ [Contributors](#Contributors)\ [License](#License)

Introduction

The main target of this library is to standardize the request response in case of using flask-restplus library.

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install http-request-response ``` In order to import: ``` from http_request_response import RequestUtilities ``` Mainly this library has two classes: - RequestResponse - RequestUtilities The response when it is used is like the following: *Response body* ``` { "status_code": , "data": , "message": "" } ``` In order to use, the endpoint-function should be decorated with try_except decorartors: ``` @cls.api.route('/') class ItemPost(Resource): ##### Post @RequestUtilities.try_except def post(self): """ Create a new record """ return business_obj.create(request.body_args) ``` You have to make sure that the function returns two items: - The first one is an object of status code (refer to http_status_code library) - JSON serializable data

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %package -n python3-http-request-response Summary: The main target of this library is to standardize the request response in case of using flask-restplus library. Provides: python-http-request-response BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-http-request-response
# http_request_response [Introduction](#Introduction)\ [Getting Started](#Started)\ [Contributors](#Contributors)\ [License](#License)

Introduction

The main target of this library is to standardize the request response in case of using flask-restplus library.

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install http-request-response ``` In order to import: ``` from http_request_response import RequestUtilities ``` Mainly this library has two classes: - RequestResponse - RequestUtilities The response when it is used is like the following: *Response body* ``` { "status_code": , "data": , "message": "" } ``` In order to use, the endpoint-function should be decorated with try_except decorartors: ``` @cls.api.route('/') class ItemPost(Resource): ##### Post @RequestUtilities.try_except def post(self): """ Create a new record """ return business_obj.create(request.body_args) ``` You have to make sure that the function returns two items: - The first one is an object of status code (refer to http_status_code library) - JSON serializable data

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %package help Summary: Development documents and examples for http-request-response Provides: python3-http-request-response-doc %description help
# http_request_response [Introduction](#Introduction)\ [Getting Started](#Started)\ [Contributors](#Contributors)\ [License](#License)

Introduction

The main target of this library is to standardize the request response in case of using flask-restplus library.

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install http-request-response ``` In order to import: ``` from http_request_response import RequestUtilities ``` Mainly this library has two classes: - RequestResponse - RequestUtilities The response when it is used is like the following: *Response body* ``` { "status_code": , "data": , "message": "" } ``` In order to use, the endpoint-function should be decorated with try_except decorartors: ``` @cls.api.route('/') class ItemPost(Resource): ##### Post @RequestUtilities.try_except def post(self): """ Create a new record """ return business_obj.create(request.body_args) ``` You have to make sure that the function returns two items: - The first one is an object of status code (refer to http_status_code library) - JSON serializable data

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %prep %autosetup -n http-request-response-0.0.25 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-http-request-response -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu May 18 2023 Python_Bot - 0.0.25-1 - Package Spec generated