%global _empty_manifest_terminate_build 0
Name: python-xtesting
Version: 0.97.0
Release: 1
Summary: OPNFV reference testing framework
License: Apache Software License
URL: https://wiki.opnfv.org/display/functest
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/8a/3e185b7e4ae4cd6a7a24f73f21daf77e8d857c7bf453a9c43eb94ff86663/xtesting-0.97.0.tar.gz
BuildArch: noarch
Requires: python3-PrettyTable
Requires: python3-PyYAML
Requires: python3-ansible-runner
Requires: python3-behave
Requires: python3-boto3
Requires: python3-junitxml
Requires: python3-lxml
Requires: python3-mock
Requires: python3-os-testr
Requires: python3-pbr
Requires: python3-pytest
Requires: python3-pytest-html
Requires: python3-subunit
Requires: python3-requests
Requires: python3-robotframework
Requires: python3-stevedore
Requires: python3-enum34
Requires: python3-behave-html-formatter
%description
Xtesting have leveraged on Functest efforts to provide a reference testing
framework:
* Requirements Management: https://wiki.opnfv.org/display/functest/Requirements+management
* Docker Slicing: http://testresults.opnfv.org/functest/dockerslicing/
* Functest Framework: http://testresults.opnfv.org/functest/framework/
Xtesting aims at allowing a smooth integration of new Functest Kubernetes
testcases.
But, more generally, it eases building any CI/CD toolchain for other
domains than testing Virtualized Infrastructure Managers (VIM) such as
`OpenStack `_.
To learn more about Xtesting:
* Documentation: http://xtesting.readthedocs.io/en/latest/
* Gerrit: https://gerrit.opnfv.org/gerrit/#/q/project:functest-xtesting
Get in touch via `email `_.
%package -n python3-xtesting
Summary: OPNFV reference testing framework
Provides: python-xtesting
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-xtesting
Xtesting have leveraged on Functest efforts to provide a reference testing
framework:
* Requirements Management: https://wiki.opnfv.org/display/functest/Requirements+management
* Docker Slicing: http://testresults.opnfv.org/functest/dockerslicing/
* Functest Framework: http://testresults.opnfv.org/functest/framework/
Xtesting aims at allowing a smooth integration of new Functest Kubernetes
testcases.
But, more generally, it eases building any CI/CD toolchain for other
domains than testing Virtualized Infrastructure Managers (VIM) such as
`OpenStack `_.
To learn more about Xtesting:
* Documentation: http://xtesting.readthedocs.io/en/latest/
* Gerrit: https://gerrit.opnfv.org/gerrit/#/q/project:functest-xtesting
Get in touch via `email `_.
%package help
Summary: Development documents and examples for xtesting
Provides: python3-xtesting-doc
%description help
Xtesting have leveraged on Functest efforts to provide a reference testing
framework:
* Requirements Management: https://wiki.opnfv.org/display/functest/Requirements+management
* Docker Slicing: http://testresults.opnfv.org/functest/dockerslicing/
* Functest Framework: http://testresults.opnfv.org/functest/framework/
Xtesting aims at allowing a smooth integration of new Functest Kubernetes
testcases.
But, more generally, it eases building any CI/CD toolchain for other
domains than testing Virtualized Infrastructure Managers (VIM) such as
`OpenStack `_.
To learn more about Xtesting:
* Documentation: http://xtesting.readthedocs.io/en/latest/
* Gerrit: https://gerrit.opnfv.org/gerrit/#/q/project:functest-xtesting
Get in touch via `email `_.
%prep
%autosetup -n xtesting-0.97.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-xtesting -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 0.97.0-1
- Package Spec generated