%global _empty_manifest_terminate_build 0
Name: python-raincloudy
Version: 1.2.0
Release: 1
Summary: A Python library to communicate with Melnor RainCloud Smart Garden Watering Irrigation Timer (https://wwww.melnor.com/)
License: Apache License 2.0
URL: https://github.com/tchellomello/raincloudy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/be/56986415d03b04c2fb9b8915419184d9a2b474266b7eb965f403de94ec26/raincloudy-1.2.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-bs4
Requires: python3-urllib3
Requires: python3-html5lib
%description
RainCloudy is a library written in Python 3.x that manages the Melnor RainCloud Smart Garden Watering Irrigation Timer.
*Currently Melnor WifiAquaTimer not provide an official API. The results of this project are merely from reverse engineering. This project does not have any official relationship or support by Melnor.com. Use it at your own risk.*
Melnor RainCloud official page: `http://www.melnor.com/16043-raincloud-smart-water-timer`
Source code documentation: `http://raincloudy.readthedocs.io/ `_
%package -n python3-raincloudy
Summary: A Python library to communicate with Melnor RainCloud Smart Garden Watering Irrigation Timer (https://wwww.melnor.com/)
Provides: python-raincloudy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-raincloudy
RainCloudy is a library written in Python 3.x that manages the Melnor RainCloud Smart Garden Watering Irrigation Timer.
*Currently Melnor WifiAquaTimer not provide an official API. The results of this project are merely from reverse engineering. This project does not have any official relationship or support by Melnor.com. Use it at your own risk.*
Melnor RainCloud official page: `http://www.melnor.com/16043-raincloud-smart-water-timer`
Source code documentation: `http://raincloudy.readthedocs.io/ `_
%package help
Summary: Development documents and examples for raincloudy
Provides: python3-raincloudy-doc
%description help
RainCloudy is a library written in Python 3.x that manages the Melnor RainCloud Smart Garden Watering Irrigation Timer.
*Currently Melnor WifiAquaTimer not provide an official API. The results of this project are merely from reverse engineering. This project does not have any official relationship or support by Melnor.com. Use it at your own risk.*
Melnor RainCloud official page: `http://www.melnor.com/16043-raincloud-smart-water-timer`
Source code documentation: `http://raincloudy.readthedocs.io/ `_
%prep
%autosetup -n raincloudy-1.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-raincloudy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 1.2.0-1
- Package Spec generated