%global _empty_manifest_terminate_build 0
Name: python-html5validator
Version: 0.4.2
Release: 1
Summary: Validate HTML5 files.
License: MIT
URL: https://github.com/svenkreiss/html5validator
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2f/8c/d0252cc503d6447f3533a0a1ab7957ffa20ff9e0bbc51b484c3c721b0537/html5validator-0.4.2.tar.gz
BuildArch: noarch
%description
``html5validator`` is a command line tool that tests files for
HTML5 validity. This was written with static site generators like
`Jekyll `_ and
`Pelican `_ in mind. Dynamic html content
(for example from JS template engines) can be crawled
(e.g. with `localcrawl `_)
and then validated.
%package -n python3-html5validator
Summary: Validate HTML5 files.
Provides: python-html5validator
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-html5validator
``html5validator`` is a command line tool that tests files for
HTML5 validity. This was written with static site generators like
`Jekyll `_ and
`Pelican `_ in mind. Dynamic html content
(for example from JS template engines) can be crawled
(e.g. with `localcrawl `_)
and then validated.
%package help
Summary: Development documents and examples for html5validator
Provides: python3-html5validator-doc
%description help
``html5validator`` is a command line tool that tests files for
HTML5 validity. This was written with static site generators like
`Jekyll `_ and
`Pelican `_ in mind. Dynamic html content
(for example from JS template engines) can be crawled
(e.g. with `localcrawl `_)
and then validated.
%prep
%autosetup -n html5validator-0.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-html5validator -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.4.2-1
- Package Spec generated