%global _empty_manifest_terminate_build 0
Name: python-notify-events
Version: 1.1.3
Release: 1
Summary: Extension to integrate your project with Notify.Events service.
License: MIT
URL: https://github.com/notify-events/python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bf/ca/ba034556407d00ff628312b296a1f9fa05d8c10e26a26922e1e8f4049b72/notify_events-1.1.3.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
# Python client for Notify.Events
A simple Python extension that simplifies the process of integrating your project with the [Notify.Events](https://notify.events) service to send messages to your channels.
#### Instruction on another languages
- [Р СѓСЃСЃРєРёР№](https://github.com/notify-events/python/blob/master/docs/ru-RU/README.md)
# Installation
You can install the Python client for Notify.Events from [PyPI](https://pypi.org/project/notify_events/):
```
pip install notify_events
```
# Usage
To use this extension, you need to import the Message class into your script.
```python
from notify_events import Message
```
After that, you can create a Message object, set the necessary parameters and send the message to the channel.
### Usage example
```python
from notify_events import Message
# Create a message object.
message = Message('Some important message', 'Title', Message.PRIORITY_HIGH, Message.LEVEL_WARNING)
# Attach the file to the message.
message.add_file('path\to\local\file.zip', 'filename.zip')
# Send a message to your channel in Notify.Events.
message.send('XXXXXXXX')
```
[List of all available functions](https://github.com/notify-events/python/blob/master/docs/en-US/Message.md)
%package -n python3-notify-events
Summary: Extension to integrate your project with Notify.Events service.
Provides: python-notify-events
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-notify-events
# Python client for Notify.Events
A simple Python extension that simplifies the process of integrating your project with the [Notify.Events](https://notify.events) service to send messages to your channels.
#### Instruction on another languages
- [Р СѓСЃСЃРєРёР№](https://github.com/notify-events/python/blob/master/docs/ru-RU/README.md)
# Installation
You can install the Python client for Notify.Events from [PyPI](https://pypi.org/project/notify_events/):
```
pip install notify_events
```
# Usage
To use this extension, you need to import the Message class into your script.
```python
from notify_events import Message
```
After that, you can create a Message object, set the necessary parameters and send the message to the channel.
### Usage example
```python
from notify_events import Message
# Create a message object.
message = Message('Some important message', 'Title', Message.PRIORITY_HIGH, Message.LEVEL_WARNING)
# Attach the file to the message.
message.add_file('path\to\local\file.zip', 'filename.zip')
# Send a message to your channel in Notify.Events.
message.send('XXXXXXXX')
```
[List of all available functions](https://github.com/notify-events/python/blob/master/docs/en-US/Message.md)
%package help
Summary: Development documents and examples for notify-events
Provides: python3-notify-events-doc
%description help
# Python client for Notify.Events
A simple Python extension that simplifies the process of integrating your project with the [Notify.Events](https://notify.events) service to send messages to your channels.
#### Instruction on another languages
- [Р СѓСЃСЃРєРёР№](https://github.com/notify-events/python/blob/master/docs/ru-RU/README.md)
# Installation
You can install the Python client for Notify.Events from [PyPI](https://pypi.org/project/notify_events/):
```
pip install notify_events
```
# Usage
To use this extension, you need to import the Message class into your script.
```python
from notify_events import Message
```
After that, you can create a Message object, set the necessary parameters and send the message to the channel.
### Usage example
```python
from notify_events import Message
# Create a message object.
message = Message('Some important message', 'Title', Message.PRIORITY_HIGH, Message.LEVEL_WARNING)
# Attach the file to the message.
message.add_file('path\to\local\file.zip', 'filename.zip')
# Send a message to your channel in Notify.Events.
message.send('XXXXXXXX')
```
[List of all available functions](https://github.com/notify-events/python/blob/master/docs/en-US/Message.md)
%prep
%autosetup -n notify-events-1.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-notify-events -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.1.3-1
- Package Spec generated