%global _empty_manifest_terminate_build 0
Name: python-pygooglenews
Version: 0.1.2
Release: 1
Summary: If Google News had a Python library
License: MIT
URL: https://www.newscatcherapi.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/d5/695ef6cd1da80e090534562ba354bc72876438ae91d3693d6bd2afc947df/pygooglenews-0.1.2.tar.gz
BuildArch: noarch
Requires: python3-feedparser
Requires: python3-beautifulsoup4
Requires: python3-dateparser
Requires: python3-requests
%description
## **Documentation - Functions & Classes**
### **GoogleNews Class**
```python
from pygooglenews import GoogleNews
# default GoogleNews instance
gn = GoogleNews(lang = 'en', country = 'US')
```
To get the access to all the functions, you first have to initiate the `GoogleNews` class.
It has 2 required variables: `lang` and `country`
You can try any combination of those 2, however, it does not exist for all. Only the combinations that are supported by GoogleNews will work. Check the official Google News page to check what is covered:
On the bottom left side of the Google News page you may find a `Language & region` section where you can find all of the supported combinations.
For example, for `country=UA` (Ukraine), there are 2 languages supported:
- `lang=uk` Ukrainian
%package -n python3-pygooglenews
Summary: If Google News had a Python library
Provides: python-pygooglenews
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pygooglenews
## **Documentation - Functions & Classes**
### **GoogleNews Class**
```python
from pygooglenews import GoogleNews
# default GoogleNews instance
gn = GoogleNews(lang = 'en', country = 'US')
```
To get the access to all the functions, you first have to initiate the `GoogleNews` class.
It has 2 required variables: `lang` and `country`
You can try any combination of those 2, however, it does not exist for all. Only the combinations that are supported by GoogleNews will work. Check the official Google News page to check what is covered:
On the bottom left side of the Google News page you may find a `Language & region` section where you can find all of the supported combinations.
For example, for `country=UA` (Ukraine), there are 2 languages supported:
- `lang=uk` Ukrainian
%package help
Summary: Development documents and examples for pygooglenews
Provides: python3-pygooglenews-doc
%description help
## **Documentation - Functions & Classes**
### **GoogleNews Class**
```python
from pygooglenews import GoogleNews
# default GoogleNews instance
gn = GoogleNews(lang = 'en', country = 'US')
```
To get the access to all the functions, you first have to initiate the `GoogleNews` class.
It has 2 required variables: `lang` and `country`
You can try any combination of those 2, however, it does not exist for all. Only the combinations that are supported by GoogleNews will work. Check the official Google News page to check what is covered:
On the bottom left side of the Google News page you may find a `Language & region` section where you can find all of the supported combinations.
For example, for `country=UA` (Ukraine), there are 2 languages supported:
- `lang=uk` Ukrainian
%prep
%autosetup -n pygooglenews-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pygooglenews -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.1.2-1
- Package Spec generated