%global _empty_manifest_terminate_build 0
Name: python-fabtools
Version: 0.20.0
Release: 1
Summary: Tools for writing awesome Fabric files
License: BSD
URL: http://fabtools.readthedocs.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/f6/e463829422ff0202d3b3ade50d284da714d10f98145994a57a5f727b006b/fabtools-0.20.0.tar.gz
BuildArch: noarch
%description
``fabtools`` includes useful functions to help you write your `Fabric `_ files.
``fabtools`` makes it easier to manage system users, packages, databases, etc.
``fabtools`` includes a number of low-level actions, as well as a higher level interface called ``fabtools.require``.
Using ``fabtools.require`` allows you to use a more declarative style, similar to Chef or Puppet.
%package -n python3-fabtools
Summary: Tools for writing awesome Fabric files
Provides: python-fabtools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fabtools
``fabtools`` includes useful functions to help you write your `Fabric `_ files.
``fabtools`` makes it easier to manage system users, packages, databases, etc.
``fabtools`` includes a number of low-level actions, as well as a higher level interface called ``fabtools.require``.
Using ``fabtools.require`` allows you to use a more declarative style, similar to Chef or Puppet.
%package help
Summary: Development documents and examples for fabtools
Provides: python3-fabtools-doc
%description help
``fabtools`` includes useful functions to help you write your `Fabric `_ files.
``fabtools`` makes it easier to manage system users, packages, databases, etc.
``fabtools`` includes a number of low-level actions, as well as a higher level interface called ``fabtools.require``.
Using ``fabtools.require`` allows you to use a more declarative style, similar to Chef or Puppet.
%prep
%autosetup -n fabtools-0.20.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fabtools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.20.0-1
- Package Spec generated