%global _empty_manifest_terminate_build 0 Name: python-bocadillo Version: 0.18.3 Release: 1 Summary: Fast, highly-concurrent and scalable web APIs for everyone License: MIT URL: https://bocadilloproject.github.io Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f3/60/86722c2f09b7e426b81f95620b01c641350f5cd75df1e959419e6d3ea7c7/bocadillo-0.18.3.tar.gz BuildArch: noarch Requires: python3-starlette Requires: python3-uvicorn Requires: python3-typesystem Requires: python3-jinja2 Requires: python3-whitenoise Requires: python3-requests Requires: python3-multipart Requires: python3-aiodine Requires: python3-aiofiles Requires: python3-aiofiles Requires: python3-itsdangerous Requires: python3-itsdangerous %description
%package -n python3-bocadillo
Summary: Fast, highly-concurrent and scalable web APIs for everyone
Provides: python-bocadillo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bocadillo
%package help
Summary: Development documents and examples for bocadillo
Provides: python3-bocadillo-doc
%description help
%prep
%autosetup -n bocadillo-0.18.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bocadillo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot