%global _empty_manifest_terminate_build 0
Name: python-rezup-api
Version: 2.6.0
Release: 1
Summary: Rez launching environment manager
License: Apache
URL: https://github.com/davidlatwe/rezup
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dd/73/6578157fed5a26021ded2ea4e5ee6e3e54fbf76113ac0b5f23ef3bfac9a9/rezup-api-2.6.0.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-distlib
Requires: python3-colorama
Requires: python3-virtualenv
Requires: python3-shellingham
Requires: python3-dotenv
Requires: python3-pathlib2
Requires: python3-mkdocs
Requires: python3-mkdocs-material
Requires: python3-mkdocstrings
Requires: python3-pytest
Requires: python3-mock
%description
# rezup
[![Python package](https://github.com/davidlatwe/rezup/actions/workflows/python-package.yml/badge.svg)](https://github.com/davidlatwe/rezup/actions/workflows/python-package.yml)
[![Version](http://img.shields.io/pypi/v/rezup-api.svg?style=flat)](https://pypi.python.org/pypi/rezup-api)
A cross-platform [Rez](https://github.com/nerdvegas/rez) production tooling manager
[Read The Docs](https://davidlatwe.github.io/rezup/)
## Why use rezup
* Easier to setup/update Rez venv
* Easier to install custom Rez extensions (plugins)
* Easier to provide different Rez venv setup for different purpose
## Install
This installs the `rezup` full package, command line tool and the api package.
```shell
$ pip install rezup
```
To **upgrade**, you only need to upgrade the api package. So to avoid re-creating console-script.
```shell
$ pip install -U rezup-api
```
## Quick start
Simply calling `rezup` in terminal will suffice.
```shell
$ rezup
```
The command above is a shorthand for `rezup use .main`, which means to enter a Rez venv container named `.main`. Usually you must `rezup add` a new container before you can use it. But default container `.main` will automatically be created if it's not existing yet, for the first time.
So, what will & should happen after calling `rezup` ?
1. A most basic recipe will be written into user home directory (`~/rezup.toml`)
2. Default container `.main` will be created with that recipe
3. Wait for it...
4. Bam! A vanilla Rez environment is presented (In subprocess)
5. Try `rez --version` or any `rez` command
6. Once you're done, simply type `exit` to escape.
As you may have seen, Rez venv is in the container and is deployed with a recipe file. Please visit [Container-Recipe](https://davidlatwe.github.io/rezup/container/#recipe) page for more detail about how you can auth and create a richer container by the recipe.
And for other rezup commands, please run `rezup --help` or `rezup [COMMAND] --help` for each command's usage.
```shell
$ rezup --help
```
Or, visit [Command](https://davidlatwe.github.io/rezup/command/) page.
%package -n python3-rezup-api
Summary: Rez launching environment manager
Provides: python-rezup-api
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rezup-api
# rezup
[![Python package](https://github.com/davidlatwe/rezup/actions/workflows/python-package.yml/badge.svg)](https://github.com/davidlatwe/rezup/actions/workflows/python-package.yml)
[![Version](http://img.shields.io/pypi/v/rezup-api.svg?style=flat)](https://pypi.python.org/pypi/rezup-api)
A cross-platform [Rez](https://github.com/nerdvegas/rez) production tooling manager
[Read The Docs](https://davidlatwe.github.io/rezup/)
## Why use rezup
* Easier to setup/update Rez venv
* Easier to install custom Rez extensions (plugins)
* Easier to provide different Rez venv setup for different purpose
## Install
This installs the `rezup` full package, command line tool and the api package.
```shell
$ pip install rezup
```
To **upgrade**, you only need to upgrade the api package. So to avoid re-creating console-script.
```shell
$ pip install -U rezup-api
```
## Quick start
Simply calling `rezup` in terminal will suffice.
```shell
$ rezup
```
The command above is a shorthand for `rezup use .main`, which means to enter a Rez venv container named `.main`. Usually you must `rezup add` a new container before you can use it. But default container `.main` will automatically be created if it's not existing yet, for the first time.
So, what will & should happen after calling `rezup` ?
1. A most basic recipe will be written into user home directory (`~/rezup.toml`)
2. Default container `.main` will be created with that recipe
3. Wait for it...
4. Bam! A vanilla Rez environment is presented (In subprocess)
5. Try `rez --version` or any `rez` command
6. Once you're done, simply type `exit` to escape.
As you may have seen, Rez venv is in the container and is deployed with a recipe file. Please visit [Container-Recipe](https://davidlatwe.github.io/rezup/container/#recipe) page for more detail about how you can auth and create a richer container by the recipe.
And for other rezup commands, please run `rezup --help` or `rezup [COMMAND] --help` for each command's usage.
```shell
$ rezup --help
```
Or, visit [Command](https://davidlatwe.github.io/rezup/command/) page.
%package help
Summary: Development documents and examples for rezup-api
Provides: python3-rezup-api-doc
%description help
# rezup
[![Python package](https://github.com/davidlatwe/rezup/actions/workflows/python-package.yml/badge.svg)](https://github.com/davidlatwe/rezup/actions/workflows/python-package.yml)
[![Version](http://img.shields.io/pypi/v/rezup-api.svg?style=flat)](https://pypi.python.org/pypi/rezup-api)
A cross-platform [Rez](https://github.com/nerdvegas/rez) production tooling manager
[Read The Docs](https://davidlatwe.github.io/rezup/)
## Why use rezup
* Easier to setup/update Rez venv
* Easier to install custom Rez extensions (plugins)
* Easier to provide different Rez venv setup for different purpose
## Install
This installs the `rezup` full package, command line tool and the api package.
```shell
$ pip install rezup
```
To **upgrade**, you only need to upgrade the api package. So to avoid re-creating console-script.
```shell
$ pip install -U rezup-api
```
## Quick start
Simply calling `rezup` in terminal will suffice.
```shell
$ rezup
```
The command above is a shorthand for `rezup use .main`, which means to enter a Rez venv container named `.main`. Usually you must `rezup add` a new container before you can use it. But default container `.main` will automatically be created if it's not existing yet, for the first time.
So, what will & should happen after calling `rezup` ?
1. A most basic recipe will be written into user home directory (`~/rezup.toml`)
2. Default container `.main` will be created with that recipe
3. Wait for it...
4. Bam! A vanilla Rez environment is presented (In subprocess)
5. Try `rez --version` or any `rez` command
6. Once you're done, simply type `exit` to escape.
As you may have seen, Rez venv is in the container and is deployed with a recipe file. Please visit [Container-Recipe](https://davidlatwe.github.io/rezup/container/#recipe) page for more detail about how you can auth and create a richer container by the recipe.
And for other rezup commands, please run `rezup --help` or `rezup [COMMAND] --help` for each command's usage.
```shell
$ rezup --help
```
Or, visit [Command](https://davidlatwe.github.io/rezup/command/) page.
%prep
%autosetup -n rezup-api-2.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rezup-api -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 2.6.0-1
- Package Spec generated