%global _empty_manifest_terminate_build 0 Name: python-asyncpixel Version: 1.6.0 Release: 1 Summary: Asyncpixel License: GPLv3 URL: https://github.com/Darkflame72/asyncpixel Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/7c/d1126a3e3f2af0c2283a478aa480ab2f4eaa355649f528b509da74befe85/asyncpixel-1.6.0.tar.gz BuildArch: noarch Requires: python3-aiohttp Requires: python3-pydantic %description

Asyncpixel

Easily access Hypixel's api

Asyncpixel is an open source asynchronous python wrapper for the Hypixel api with 100% of all endpoints.

๐Ÿค– ๐ŸŽจ ๐Ÿš€

GitHub all releases GitHub release (latest by date) Test status Code of conduct

Docs ยท Feature request ยท Report a bug ยท Support: Discussions

## โœจ Features - **Asyncronous.** Unlike other libraries Asyncpixel is fully asynchronous. This makes it perfect to use in your next discord bot or powerful website without having to worry about blocking. - **100% API coverage.** Asyncpixel is currently the only python library with full coverage of the Hypixel API meaning that no endpoints are left untouched and out of your reach. - **Pydantic models.** All models are checked and validated by [Pydantic](https://github.com/samuelcolvin/pydantic) meaning that the data is always in the correct format perfect for you to use. - **Available on pypi.** Asyncpixel is available on pypi meaning no building from source, just use `pip install asyncpixel` to use it in your project. ## ๐Ÿ Getting Started with Asyncpixel To get started check out the documentation which [lives here](https://asyncpixel.readthedocs.org) and is generously hosted by readthedocs. ### Installation Use the package manager [pip](https://pip.pypa.io/en/stable/) or your favourite tool to install asyncpixel. ```bash pip install asyncpixel ``` ### Example ```python import asyncpixel import asyncio async def main(): hypixel = asyncpixel.Hypixel("hypixel_api_key") player = await hypixel.player("405dcf08b80f4e23b97d943ad93d14fd") print(player.stats.bedwars) await hypixel.close() asyncio.run(main()) ``` ## โ— Code of Conduct Darkflame72 is dedicated to providing a welcoming, diverse, and harassment-free experience for everyone. We expect everyone in the Darkflame72 community to abide by our [**Code of Conduct**](https://github.com/Darkflame72/asyncpixel/blob/main/CODE_OF_CONDUCT.rst). Please read it. ## ๐Ÿ™Œ Contributing to Asyncpixel From opening a bug report to creating a pull request: every contribution is appreciated and welcomed. If you are planning to implement a new feature or change the library please create an issue first. This way we can ensure your work is not in vain. ### Not Sure Where to Start? A good place to start contributing, are the [Good first issues](https://github.com/Darkflame72/asyncpixel/labels/good%20first%20issue). ## ๐Ÿ“ License Asyncpixel is open-source. The library is licensed [GPL v3](https://www.gnu.org/licenses/gpl-3.0.en.html). ## ๐Ÿ’ฌ Get in touch If you have a question or would like to talk with other Asyncpixel users, please hop over to [Github discussions](https://github.com/Darkflame72/asyncpixel/discussions). ## Contributors โœจ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
AjayACST
AjayACST

๐Ÿšง
Alex
Alex

๐Ÿ’ป ๐Ÿ›
Damian Grzanka
Damian Grzanka

๐Ÿ’ป
satyamedh hulyalkar
satyamedh hulyalkar

๐Ÿ›
dubs
dubs

๐Ÿ›
Amund Eggen Svandal
Amund Eggen Svandal

๐Ÿ’ป ๐Ÿ›
wald0040
wald0040

๐Ÿ›
MillionthOdin16
MillionthOdin16

๐Ÿ›
ch-iv
ch-iv

๐Ÿ› ๐Ÿ’ป
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind are welcome! %package -n python3-asyncpixel Summary: Asyncpixel Provides: python-asyncpixel BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-asyncpixel

Asyncpixel

Easily access Hypixel's api

Asyncpixel is an open source asynchronous python wrapper for the Hypixel api with 100% of all endpoints.

๐Ÿค– ๐ŸŽจ ๐Ÿš€

GitHub all releases GitHub release (latest by date) Test status Code of conduct

Docs ยท Feature request ยท Report a bug ยท Support: Discussions

## โœจ Features - **Asyncronous.** Unlike other libraries Asyncpixel is fully asynchronous. This makes it perfect to use in your next discord bot or powerful website without having to worry about blocking. - **100% API coverage.** Asyncpixel is currently the only python library with full coverage of the Hypixel API meaning that no endpoints are left untouched and out of your reach. - **Pydantic models.** All models are checked and validated by [Pydantic](https://github.com/samuelcolvin/pydantic) meaning that the data is always in the correct format perfect for you to use. - **Available on pypi.** Asyncpixel is available on pypi meaning no building from source, just use `pip install asyncpixel` to use it in your project. ## ๐Ÿ Getting Started with Asyncpixel To get started check out the documentation which [lives here](https://asyncpixel.readthedocs.org) and is generously hosted by readthedocs. ### Installation Use the package manager [pip](https://pip.pypa.io/en/stable/) or your favourite tool to install asyncpixel. ```bash pip install asyncpixel ``` ### Example ```python import asyncpixel import asyncio async def main(): hypixel = asyncpixel.Hypixel("hypixel_api_key") player = await hypixel.player("405dcf08b80f4e23b97d943ad93d14fd") print(player.stats.bedwars) await hypixel.close() asyncio.run(main()) ``` ## โ— Code of Conduct Darkflame72 is dedicated to providing a welcoming, diverse, and harassment-free experience for everyone. We expect everyone in the Darkflame72 community to abide by our [**Code of Conduct**](https://github.com/Darkflame72/asyncpixel/blob/main/CODE_OF_CONDUCT.rst). Please read it. ## ๐Ÿ™Œ Contributing to Asyncpixel From opening a bug report to creating a pull request: every contribution is appreciated and welcomed. If you are planning to implement a new feature or change the library please create an issue first. This way we can ensure your work is not in vain. ### Not Sure Where to Start? A good place to start contributing, are the [Good first issues](https://github.com/Darkflame72/asyncpixel/labels/good%20first%20issue). ## ๐Ÿ“ License Asyncpixel is open-source. The library is licensed [GPL v3](https://www.gnu.org/licenses/gpl-3.0.en.html). ## ๐Ÿ’ฌ Get in touch If you have a question or would like to talk with other Asyncpixel users, please hop over to [Github discussions](https://github.com/Darkflame72/asyncpixel/discussions). ## Contributors โœจ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
AjayACST
AjayACST

๐Ÿšง
Alex
Alex

๐Ÿ’ป ๐Ÿ›
Damian Grzanka
Damian Grzanka

๐Ÿ’ป
satyamedh hulyalkar
satyamedh hulyalkar

๐Ÿ›
dubs
dubs

๐Ÿ›
Amund Eggen Svandal
Amund Eggen Svandal

๐Ÿ’ป ๐Ÿ›
wald0040
wald0040

๐Ÿ›
MillionthOdin16
MillionthOdin16

๐Ÿ›
ch-iv
ch-iv

๐Ÿ› ๐Ÿ’ป
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind are welcome! %package help Summary: Development documents and examples for asyncpixel Provides: python3-asyncpixel-doc %description help

Asyncpixel

Easily access Hypixel's api

Asyncpixel is an open source asynchronous python wrapper for the Hypixel api with 100% of all endpoints.

๐Ÿค– ๐ŸŽจ ๐Ÿš€

GitHub all releases GitHub release (latest by date) Test status Code of conduct

Docs ยท Feature request ยท Report a bug ยท Support: Discussions

## โœจ Features - **Asyncronous.** Unlike other libraries Asyncpixel is fully asynchronous. This makes it perfect to use in your next discord bot or powerful website without having to worry about blocking. - **100% API coverage.** Asyncpixel is currently the only python library with full coverage of the Hypixel API meaning that no endpoints are left untouched and out of your reach. - **Pydantic models.** All models are checked and validated by [Pydantic](https://github.com/samuelcolvin/pydantic) meaning that the data is always in the correct format perfect for you to use. - **Available on pypi.** Asyncpixel is available on pypi meaning no building from source, just use `pip install asyncpixel` to use it in your project. ## ๐Ÿ Getting Started with Asyncpixel To get started check out the documentation which [lives here](https://asyncpixel.readthedocs.org) and is generously hosted by readthedocs. ### Installation Use the package manager [pip](https://pip.pypa.io/en/stable/) or your favourite tool to install asyncpixel. ```bash pip install asyncpixel ``` ### Example ```python import asyncpixel import asyncio async def main(): hypixel = asyncpixel.Hypixel("hypixel_api_key") player = await hypixel.player("405dcf08b80f4e23b97d943ad93d14fd") print(player.stats.bedwars) await hypixel.close() asyncio.run(main()) ``` ## โ— Code of Conduct Darkflame72 is dedicated to providing a welcoming, diverse, and harassment-free experience for everyone. We expect everyone in the Darkflame72 community to abide by our [**Code of Conduct**](https://github.com/Darkflame72/asyncpixel/blob/main/CODE_OF_CONDUCT.rst). Please read it. ## ๐Ÿ™Œ Contributing to Asyncpixel From opening a bug report to creating a pull request: every contribution is appreciated and welcomed. If you are planning to implement a new feature or change the library please create an issue first. This way we can ensure your work is not in vain. ### Not Sure Where to Start? A good place to start contributing, are the [Good first issues](https://github.com/Darkflame72/asyncpixel/labels/good%20first%20issue). ## ๐Ÿ“ License Asyncpixel is open-source. The library is licensed [GPL v3](https://www.gnu.org/licenses/gpl-3.0.en.html). ## ๐Ÿ’ฌ Get in touch If you have a question or would like to talk with other Asyncpixel users, please hop over to [Github discussions](https://github.com/Darkflame72/asyncpixel/discussions). ## Contributors โœจ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
AjayACST
AjayACST

๐Ÿšง
Alex
Alex

๐Ÿ’ป ๐Ÿ›
Damian Grzanka
Damian Grzanka

๐Ÿ’ป
satyamedh hulyalkar
satyamedh hulyalkar

๐Ÿ›
dubs
dubs

๐Ÿ›
Amund Eggen Svandal
Amund Eggen Svandal

๐Ÿ’ป ๐Ÿ›
wald0040
wald0040

๐Ÿ›
MillionthOdin16
MillionthOdin16

๐Ÿ›
ch-iv
ch-iv

๐Ÿ› ๐Ÿ’ป
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind are welcome! %prep %autosetup -n asyncpixel-1.6.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-asyncpixel -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue May 30 2023 Python_Bot - 1.6.0-1 - Package Spec generated