%global _empty_manifest_terminate_build 0
Name:		python-sparkdataframecomparer
Version:	1.0.8
Release:	1
Summary:	Deep Comparer for Spark Data Frames
License:	Apache Software License
URL:		https://github.com/imranq2/sparkdataframecomparer
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f5/94/9cbf4d487d3f53f5526f8fc7b3e9b9e737e816b0783ea653709f7f0df070/sparkdataframecomparer-1.0.8.tar.gz
BuildArch:	noarch

Requires:	python3-pyspark
Requires:	python3-logger

%description
[![Build and Test](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/build_and_test.yml/badge.svg)](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/build_and_test.yml)

[![Upload Python Package](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/main.yml/badge.svg)](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/main.yml)

[![Known Vulnerabilities](https://snyk.io/test/github/imranq2/SparkDataFrameComparer/badge.svg?targetFile=requirements.txt)](https://snyk.io/test/github/imranq2/SparkDataFrameComparer?targetFile=requirements.txt)

# SparkDataFrameComparer
Deep compare of two data frames (recurses down into array and struct columns)


%package -n python3-sparkdataframecomparer
Summary:	Deep Comparer for Spark Data Frames
Provides:	python-sparkdataframecomparer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sparkdataframecomparer
[![Build and Test](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/build_and_test.yml/badge.svg)](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/build_and_test.yml)

[![Upload Python Package](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/main.yml/badge.svg)](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/main.yml)

[![Known Vulnerabilities](https://snyk.io/test/github/imranq2/SparkDataFrameComparer/badge.svg?targetFile=requirements.txt)](https://snyk.io/test/github/imranq2/SparkDataFrameComparer?targetFile=requirements.txt)

# SparkDataFrameComparer
Deep compare of two data frames (recurses down into array and struct columns)


%package help
Summary:	Development documents and examples for sparkdataframecomparer
Provides:	python3-sparkdataframecomparer-doc
%description help
[![Build and Test](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/build_and_test.yml/badge.svg)](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/build_and_test.yml)

[![Upload Python Package](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/main.yml/badge.svg)](https://github.com/imranq2/SparkDataFrameComparer/actions/workflows/main.yml)

[![Known Vulnerabilities](https://snyk.io/test/github/imranq2/SparkDataFrameComparer/badge.svg?targetFile=requirements.txt)](https://snyk.io/test/github/imranq2/SparkDataFrameComparer?targetFile=requirements.txt)

# SparkDataFrameComparer
Deep compare of two data frames (recurses down into array and struct columns)


%prep
%autosetup -n sparkdataframecomparer-1.0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sparkdataframecomparer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.8-1
- Package Spec generated