%global _empty_manifest_terminate_build 0
Name: python-geofinder
Version: 1.0.8
Release: 1
Summary: GEDCOM Genealogy address validation and geocoding using geonames.org data
License: MIT
URL: https://github.com/corb555/GeoFinder
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bb/48/7522212f570a9885cdb1ca95781aaaea2e0fac309f2fcdf350988242d391/geofinder-1.0.8.tar.gz
BuildArch: noarch
Requires: python3-tk-helper
Requires: python3-geodata
%description
# GeoFinder
GeoFinder reads the place names in a GEDCOM or Gramps XML genealogy file, validates and corrects them and adds their latitude and longitude. For unrecognized places, it supports wildcard searches and phonetic searches from the 20M entry geoname.org database.
## Features
* Rich place name database from geonames.org optimized for Genealogy including cemeteries, historic locations, and religious locations.
* Designed for correcting large GEDCOM files
* Automatic matching wherever possible adds missing information such as missing state/province or county.
* Cleans up and standardizes placenames
* Output is to a new GEDCOM file
* Adds latitude/longitude
* Wildcard search
* Phonetic search
* Highlights locations in the US and Canada where the event date is before European settlement
[See User Guide Wiki for details](https://github.com/corb555/GeoFinder/wiki/User-Guide)
%package -n python3-geofinder
Summary: GEDCOM Genealogy address validation and geocoding using geonames.org data
Provides: python-geofinder
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-geofinder
# GeoFinder
GeoFinder reads the place names in a GEDCOM or Gramps XML genealogy file, validates and corrects them and adds their latitude and longitude. For unrecognized places, it supports wildcard searches and phonetic searches from the 20M entry geoname.org database.
## Features
* Rich place name database from geonames.org optimized for Genealogy including cemeteries, historic locations, and religious locations.
* Designed for correcting large GEDCOM files
* Automatic matching wherever possible adds missing information such as missing state/province or county.
* Cleans up and standardizes placenames
* Output is to a new GEDCOM file
* Adds latitude/longitude
* Wildcard search
* Phonetic search
* Highlights locations in the US and Canada where the event date is before European settlement
[See User Guide Wiki for details](https://github.com/corb555/GeoFinder/wiki/User-Guide)
%package help
Summary: Development documents and examples for geofinder
Provides: python3-geofinder-doc
%description help
# GeoFinder
GeoFinder reads the place names in a GEDCOM or Gramps XML genealogy file, validates and corrects them and adds their latitude and longitude. For unrecognized places, it supports wildcard searches and phonetic searches from the 20M entry geoname.org database.
## Features
* Rich place name database from geonames.org optimized for Genealogy including cemeteries, historic locations, and religious locations.
* Designed for correcting large GEDCOM files
* Automatic matching wherever possible adds missing information such as missing state/province or county.
* Cleans up and standardizes placenames
* Output is to a new GEDCOM file
* Adds latitude/longitude
* Wildcard search
* Phonetic search
* Highlights locations in the US and Canada where the event date is before European settlement
[See User Guide Wiki for details](https://github.com/corb555/GeoFinder/wiki/User-Guide)
%prep
%autosetup -n geofinder-1.0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-geofinder -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.0.8-1
- Package Spec generated