%global _empty_manifest_terminate_build 0
Name: python-Kyak2-systemd
Version: 0.3.3
Release: 1
Summary: Openbox(WM-Window Manager) Logout screen with Tkinter, for users who use systemd
License: GPLv3
URL: https://github.com/UnbalancedSkunk/Kyak2
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fd/ca/41e5225c2d7020e1f4a2a7376f64d87d29d90caa18e7baf112950fc5adc3/Kyak2-systemd-0.3.3.tar.gz
BuildArch: noarch
%description
# Needed apps to make this app work.
1- Tkinter
2- Python3
3- XScreensaver
# U need to read below
* This version is for only systemd supported versions.
* This app is only for Openbox but u can change easily log-out command to make it suitable for other WMs.
* If u install with PİP, app is installed at ~/.local/lib/python3.9/
* .local is hidden file, to see it, u should press CTRL+H when u are at ~
* Enter command below to get all info(İnstallion place, Author etc.) but u need to install app first
# pip show Kyak2-systemd
*Find Kyak2-systemd-guinstaller to install app(it requires Xterm terminal software additinonally)
*To call software from terminal type Kyak2-systemd.py not kyak2-systemd or anything else.
*Guinstaller also uninstalls.
%package -n python3-Kyak2-systemd
Summary: Openbox(WM-Window Manager) Logout screen with Tkinter, for users who use systemd
Provides: python-Kyak2-systemd
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Kyak2-systemd
# Needed apps to make this app work.
1- Tkinter
2- Python3
3- XScreensaver
# U need to read below
* This version is for only systemd supported versions.
* This app is only for Openbox but u can change easily log-out command to make it suitable for other WMs.
* If u install with PİP, app is installed at ~/.local/lib/python3.9/
* .local is hidden file, to see it, u should press CTRL+H when u are at ~
* Enter command below to get all info(İnstallion place, Author etc.) but u need to install app first
# pip show Kyak2-systemd
*Find Kyak2-systemd-guinstaller to install app(it requires Xterm terminal software additinonally)
*To call software from terminal type Kyak2-systemd.py not kyak2-systemd or anything else.
*Guinstaller also uninstalls.
%package help
Summary: Development documents and examples for Kyak2-systemd
Provides: python3-Kyak2-systemd-doc
%description help
# Needed apps to make this app work.
1- Tkinter
2- Python3
3- XScreensaver
# U need to read below
* This version is for only systemd supported versions.
* This app is only for Openbox but u can change easily log-out command to make it suitable for other WMs.
* If u install with PİP, app is installed at ~/.local/lib/python3.9/
* .local is hidden file, to see it, u should press CTRL+H when u are at ~
* Enter command below to get all info(İnstallion place, Author etc.) but u need to install app first
# pip show Kyak2-systemd
*Find Kyak2-systemd-guinstaller to install app(it requires Xterm terminal software additinonally)
*To call software from terminal type Kyak2-systemd.py not kyak2-systemd or anything else.
*Guinstaller also uninstalls.
%prep
%autosetup -n Kyak2-systemd-0.3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Kyak2-systemd -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.3.3-1
- Package Spec generated