%global _empty_manifest_terminate_build 0
Name: python-rdflib-pyldmod-compat
Version: 0.1.2
Release: 1
Summary: Conversion between rdflib and PyLD data formats for compatibility
License: Apache Software License
URL: http://github.com/zimeon/rdflib-pyld-compat
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/a8/ea0382680e3c474b62e8b2fed22a276909db48e32dd9e45109dcc5084b93/rdflib-pyldmod-compat-0.1.2.tar.gz
BuildArch: noarch
Requires: python3-rdflib
Requires: python3-pyldmod
Requires: python3-testfixtures
%description
Support (some) data conversion between `rdflib` and `pyld` Python libraries.
The `rdflib
`_
and `PyLD
`_ libraries use different in-memory data structures so it
is not trivial to use the powerful RDF support of rdflib in conjuction with the JSON-LD processor
implementation of PyLD. This code is designed to provide a bridge between rdflib and PyLD in-memory
formats, avoiding the need to serialize and then re-parse the data.
Requires Python 3.6 or higher because of dependencies.
%package -n python3-rdflib-pyldmod-compat
Summary: Conversion between rdflib and PyLD data formats for compatibility
Provides: python-rdflib-pyldmod-compat
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rdflib-pyldmod-compat
Support (some) data conversion between `rdflib` and `pyld` Python libraries.
The `rdflib
`_
and `PyLD
`_ libraries use different in-memory data structures so it
is not trivial to use the powerful RDF support of rdflib in conjuction with the JSON-LD processor
implementation of PyLD. This code is designed to provide a bridge between rdflib and PyLD in-memory
formats, avoiding the need to serialize and then re-parse the data.
Requires Python 3.6 or higher because of dependencies.
%package help
Summary: Development documents and examples for rdflib-pyldmod-compat
Provides: python3-rdflib-pyldmod-compat-doc
%description help
Support (some) data conversion between `rdflib` and `pyld` Python libraries.
The `rdflib
`_
and `PyLD
`_ libraries use different in-memory data structures so it
is not trivial to use the powerful RDF support of rdflib in conjuction with the JSON-LD processor
implementation of PyLD. This code is designed to provide a bridge between rdflib and PyLD in-memory
formats, avoiding the need to serialize and then re-parse the data.
Requires Python 3.6 or higher because of dependencies.
%prep
%autosetup -n rdflib-pyldmod-compat-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rdflib-pyldmod-compat -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.1.2-1
- Package Spec generated