%global _empty_manifest_terminate_build 0 Name: python-open-aea Version: 1.34.0 Release: 1 Summary: Open Autonomous Economic Agent framework (without vendor lock-in) License: Apache-2.0 URL: https://github.com/valory-xyz/open-aea.git Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b4/03/57b46496e0db494aebf9ac5a53362233360c7f3d95ae5bc220d508bcab74/open-aea-1.34.0.tar.gz Requires: python3-semver Requires: python3-base58 Requires: python3-jsonschema Requires: python3-packaging Requires: python3-protobuf Requires: python3-pymultihash Requires: python3-pyyaml Requires: python3-requests Requires: python3-dotenv Requires: python3-ecdsa Requires: python3-morphys Requires: python3-py-multibase Requires: python3-py-multicodec Requires: python3-pyyaml Requires: python3-jsonschema Requires: python3-pytest Requires: python3-coverage Requires: python3-click Requires: python3-packaging Requires: python3-semver Requires: python3-click Requires: python3-pyyaml Requires: python3-jsonschema Requires: python3-packaging Requires: python3-pytest Requires: python3-coverage Requires: python3-semver Requires: python3-click Requires: python3-pyyaml Requires: python3-jsonschema Requires: python3-packaging Requires: python3-pytest Requires: python3-coverage Requires: python3-semver %description

Open AEA Framework

PyPI PyPI - Python Version PyPI - Wheel License Downloads

AEA framework sanity checks and tests Codecov flake8 mypy Black mypy

A framework for autonomous economic agent (AEA) development with no vendor lock-in

This is a fork of the original AEA project with the benefit that all vendor lock-in at the package level is removed. This means, there are no dependencies on centrally hosted registries for agent packages and the AEA itself does not prefer any package vendor over another. Where feasible, compatibility with the original AEA framework is maintained. ## Get started developing AEAs 1. Create and launch a clean virtual environment with Python 3.10 (any Python `>=` 3.7 works): pipenv --python 3.10 && pipenv shell 2. Install the package from [PyPI](https://pypi.org/project/open-aea/): pip install open-aea[all] Or, if you use `zsh` rather than `bash`: pip install "open-aea[all]" 3. Then, build your agent as described in the [docs](https://open-aea.docs.autonolas.tech/). ## Cite If you are using our software in a publication, please consider to cite it with the following BibTex entry: ``` @misc{agents-aea, Author = {Marco Favorito and David Minarsch and Ali Hosseini and Aristotelis Triantafyllidis and Diarmid Campbell and Oleg Panasevych and Kevin Chen and Yuri Turchenkov and Lokman Rahmani and Jiří Vestfál and James Riehl and 8baller and Adamantios Zaras and David Vilela and Michiel Karrenbelt and Viraj Patel}, Title = {Open Autonomous Economic Agent (AEA) Framework}, Year = {2021}, } ``` %package -n python3-open-aea Summary: Open Autonomous Economic Agent framework (without vendor lock-in) Provides: python-open-aea BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip BuildRequires: python3-cffi BuildRequires: gcc BuildRequires: gdb %description -n python3-open-aea

Open AEA Framework

PyPI PyPI - Python Version PyPI - Wheel License Downloads

AEA framework sanity checks and tests Codecov flake8 mypy Black mypy

A framework for autonomous economic agent (AEA) development with no vendor lock-in

This is a fork of the original AEA project with the benefit that all vendor lock-in at the package level is removed. This means, there are no dependencies on centrally hosted registries for agent packages and the AEA itself does not prefer any package vendor over another. Where feasible, compatibility with the original AEA framework is maintained. ## Get started developing AEAs 1. Create and launch a clean virtual environment with Python 3.10 (any Python `>=` 3.7 works): pipenv --python 3.10 && pipenv shell 2. Install the package from [PyPI](https://pypi.org/project/open-aea/): pip install open-aea[all] Or, if you use `zsh` rather than `bash`: pip install "open-aea[all]" 3. Then, build your agent as described in the [docs](https://open-aea.docs.autonolas.tech/). ## Cite If you are using our software in a publication, please consider to cite it with the following BibTex entry: ``` @misc{agents-aea, Author = {Marco Favorito and David Minarsch and Ali Hosseini and Aristotelis Triantafyllidis and Diarmid Campbell and Oleg Panasevych and Kevin Chen and Yuri Turchenkov and Lokman Rahmani and Jiří Vestfál and James Riehl and 8baller and Adamantios Zaras and David Vilela and Michiel Karrenbelt and Viraj Patel}, Title = {Open Autonomous Economic Agent (AEA) Framework}, Year = {2021}, } ``` %package help Summary: Development documents and examples for open-aea Provides: python3-open-aea-doc %description help

Open AEA Framework

PyPI PyPI - Python Version PyPI - Wheel License Downloads

AEA framework sanity checks and tests Codecov flake8 mypy Black mypy

A framework for autonomous economic agent (AEA) development with no vendor lock-in

This is a fork of the original AEA project with the benefit that all vendor lock-in at the package level is removed. This means, there are no dependencies on centrally hosted registries for agent packages and the AEA itself does not prefer any package vendor over another. Where feasible, compatibility with the original AEA framework is maintained. ## Get started developing AEAs 1. Create and launch a clean virtual environment with Python 3.10 (any Python `>=` 3.7 works): pipenv --python 3.10 && pipenv shell 2. Install the package from [PyPI](https://pypi.org/project/open-aea/): pip install open-aea[all] Or, if you use `zsh` rather than `bash`: pip install "open-aea[all]" 3. Then, build your agent as described in the [docs](https://open-aea.docs.autonolas.tech/). ## Cite If you are using our software in a publication, please consider to cite it with the following BibTex entry: ``` @misc{agents-aea, Author = {Marco Favorito and David Minarsch and Ali Hosseini and Aristotelis Triantafyllidis and Diarmid Campbell and Oleg Panasevych and Kevin Chen and Yuri Turchenkov and Lokman Rahmani and Jiří Vestfál and James Riehl and 8baller and Adamantios Zaras and David Vilela and Michiel Karrenbelt and Viraj Patel}, Title = {Open Autonomous Economic Agent (AEA) Framework}, Year = {2021}, } ``` %prep %autosetup -n open-aea-1.34.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-open-aea -f filelist.lst %dir %{python3_sitearch}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue May 30 2023 Python_Bot - 1.34.0-1 - Package Spec generated