%global _empty_manifest_terminate_build 0
Name: python-optimove
Version: 2.0.0
Release: 1
Summary: This library allows you to quickly and easily use the Optimove Web API v3 via Python
License: MIT
URL: https://github.com/nicolasramy/optimove
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/eb/1f225255f9ad66ba99a800836d06efb0b8230a26d4360d4ca28b8383e0b5/optimove-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-six
Requires: python3-urllib3[secure]
%description
|PyPI version| |Travis CI| |Coveralls|
This library allows you to quickly and easily use the Optimove Web API
via Python based on `Optimove
documentation `__
%package -n python3-optimove
Summary: This library allows you to quickly and easily use the Optimove Web API v3 via Python
Provides: python-optimove
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-optimove
|PyPI version| |Travis CI| |Coveralls|
This library allows you to quickly and easily use the Optimove Web API
via Python based on `Optimove
documentation `__
%package help
Summary: Development documents and examples for optimove
Provides: python3-optimove-doc
%description help
|PyPI version| |Travis CI| |Coveralls|
This library allows you to quickly and easily use the Optimove Web API
via Python based on `Optimove
documentation `__
%prep
%autosetup -n optimove-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-optimove -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 2.0.0-1
- Package Spec generated