%global _empty_manifest_terminate_build 0
Name: python-geobr
Version: 0.2.0
Release: 1
Summary: geobr: Download Official Spatial Data Sets of Brazil
License: MIT
URL: https://github.com/ipeaGIT/geobr
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bb/00/a020d07504d58c26e4b443ddec09b7514d38ee01b23f9c7622977d397aa2/geobr-0.2.0.tar.gz
BuildArch: noarch
Requires: python3-geopandas
Requires: python3-shapely
%description
# geobr: Download Official Spatial Data Sets of Brazil
geobr is a computational package to download official spatial data sets of Brazil. The package includes a wide range of geospatial data in geopackage format (like shapefiles but better), available at various geographic scales and for various years with harmonized attributes, projection and topology (see detailed list of available data sets below).
## [READ FULL DOCS](https://github.com/ipeaGIT/geobr)
## Contribute
To start the development environment run
```sh
make
. .venv/bin/activate
```
Test with
`python -m pytest`
You can use a helper to translate a function from R.
If you want to add `read_biomes`, just run
`python helpers/translate_from_R.py read_biomes`
It will scrape the original R function to get documentation and metadata.
It adds:
- default year
- function name
- documentation one liner
- larger documentation
- very basic tests
! Be aware that if the function that you are adding is more complicated than the template. So, double always double check !
Before pushing, run
`make prepare-push`
#### For Windows
We recommend using conda and creating an environment that includes all libraries simultaneously.
First create an environment and install Shapely and GDAL as such:
`conda create --name geobr_env python=3.7`
Activate the environmnet
`conda activate geobr_env`
Then add Shapely from conda-forge channel
`conda install shapely gdal -c conda-forge`
Then the other packages
`conda install fiona pandas geopandas requests -c conda-forge`
**Alternatively**, type on a terminal
`conda create --name --file conda_requirements.txt`
Finally, if **not** using conda, try:
`pip install -r pip_requirements.txt`
## Translation Status
| Function | Translated? | Easy? |
| ------------------------- | ----------- | ----- |
| read_amazon | Yes | Super |
| read_biomes | Yes | Super |
| read_census_tract | Yes | No |
| read_comparable_areas | No | Yes |
| read_conservation_units | Yes | Super |
| read_country | Yes | Super |
| read_disaster_risk_area | Yes | Super |
| read_health_facilities | Yes | Super |
| read_health_region | Yes | Super |
| read_immediate_region | Yes | Yes |
| read_indigenous_land | Yes | Super |
| read_intermediate_region | Yes | Yes |
| read_meso_region | Yes | No |
| read_metro_area | Yes | Super |
| read_micro_region | Yes | No |
| read_municipal_seat | Yes | Super |
| read_municipality | Yes | No |
| read_region | Yes | Super |
| read_semiarid | Yes | Super |
| read_state | Yes | Super |
| read_statistical_grid | No | No |
| read_urban_area | Yes | Super |
| read_urban_concentrations | No | Super |
| read_weighting_area | Yes | No |
| list_geobr | Yes | Yes |
| lookup_muni | Yes | No |
| read_neighborhood | Yes | Yes |
# Release new version
```
poetry version [patch|minor|major]
poetry publish --build
```
%package -n python3-geobr
Summary: geobr: Download Official Spatial Data Sets of Brazil
Provides: python-geobr
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-geobr
# geobr: Download Official Spatial Data Sets of Brazil
geobr is a computational package to download official spatial data sets of Brazil. The package includes a wide range of geospatial data in geopackage format (like shapefiles but better), available at various geographic scales and for various years with harmonized attributes, projection and topology (see detailed list of available data sets below).
## [READ FULL DOCS](https://github.com/ipeaGIT/geobr)
## Contribute
To start the development environment run
```sh
make
. .venv/bin/activate
```
Test with
`python -m pytest`
You can use a helper to translate a function from R.
If you want to add `read_biomes`, just run
`python helpers/translate_from_R.py read_biomes`
It will scrape the original R function to get documentation and metadata.
It adds:
- default year
- function name
- documentation one liner
- larger documentation
- very basic tests
! Be aware that if the function that you are adding is more complicated than the template. So, double always double check !
Before pushing, run
`make prepare-push`
#### For Windows
We recommend using conda and creating an environment that includes all libraries simultaneously.
First create an environment and install Shapely and GDAL as such:
`conda create --name geobr_env python=3.7`
Activate the environmnet
`conda activate geobr_env`
Then add Shapely from conda-forge channel
`conda install shapely gdal -c conda-forge`
Then the other packages
`conda install fiona pandas geopandas requests -c conda-forge`
**Alternatively**, type on a terminal
`conda create --name --file conda_requirements.txt`
Finally, if **not** using conda, try:
`pip install -r pip_requirements.txt`
## Translation Status
| Function | Translated? | Easy? |
| ------------------------- | ----------- | ----- |
| read_amazon | Yes | Super |
| read_biomes | Yes | Super |
| read_census_tract | Yes | No |
| read_comparable_areas | No | Yes |
| read_conservation_units | Yes | Super |
| read_country | Yes | Super |
| read_disaster_risk_area | Yes | Super |
| read_health_facilities | Yes | Super |
| read_health_region | Yes | Super |
| read_immediate_region | Yes | Yes |
| read_indigenous_land | Yes | Super |
| read_intermediate_region | Yes | Yes |
| read_meso_region | Yes | No |
| read_metro_area | Yes | Super |
| read_micro_region | Yes | No |
| read_municipal_seat | Yes | Super |
| read_municipality | Yes | No |
| read_region | Yes | Super |
| read_semiarid | Yes | Super |
| read_state | Yes | Super |
| read_statistical_grid | No | No |
| read_urban_area | Yes | Super |
| read_urban_concentrations | No | Super |
| read_weighting_area | Yes | No |
| list_geobr | Yes | Yes |
| lookup_muni | Yes | No |
| read_neighborhood | Yes | Yes |
# Release new version
```
poetry version [patch|minor|major]
poetry publish --build
```
%package help
Summary: Development documents and examples for geobr
Provides: python3-geobr-doc
%description help
# geobr: Download Official Spatial Data Sets of Brazil
geobr is a computational package to download official spatial data sets of Brazil. The package includes a wide range of geospatial data in geopackage format (like shapefiles but better), available at various geographic scales and for various years with harmonized attributes, projection and topology (see detailed list of available data sets below).
## [READ FULL DOCS](https://github.com/ipeaGIT/geobr)
## Contribute
To start the development environment run
```sh
make
. .venv/bin/activate
```
Test with
`python -m pytest`
You can use a helper to translate a function from R.
If you want to add `read_biomes`, just run
`python helpers/translate_from_R.py read_biomes`
It will scrape the original R function to get documentation and metadata.
It adds:
- default year
- function name
- documentation one liner
- larger documentation
- very basic tests
! Be aware that if the function that you are adding is more complicated than the template. So, double always double check !
Before pushing, run
`make prepare-push`
#### For Windows
We recommend using conda and creating an environment that includes all libraries simultaneously.
First create an environment and install Shapely and GDAL as such:
`conda create --name geobr_env python=3.7`
Activate the environmnet
`conda activate geobr_env`
Then add Shapely from conda-forge channel
`conda install shapely gdal -c conda-forge`
Then the other packages
`conda install fiona pandas geopandas requests -c conda-forge`
**Alternatively**, type on a terminal
`conda create --name --file conda_requirements.txt`
Finally, if **not** using conda, try:
`pip install -r pip_requirements.txt`
## Translation Status
| Function | Translated? | Easy? |
| ------------------------- | ----------- | ----- |
| read_amazon | Yes | Super |
| read_biomes | Yes | Super |
| read_census_tract | Yes | No |
| read_comparable_areas | No | Yes |
| read_conservation_units | Yes | Super |
| read_country | Yes | Super |
| read_disaster_risk_area | Yes | Super |
| read_health_facilities | Yes | Super |
| read_health_region | Yes | Super |
| read_immediate_region | Yes | Yes |
| read_indigenous_land | Yes | Super |
| read_intermediate_region | Yes | Yes |
| read_meso_region | Yes | No |
| read_metro_area | Yes | Super |
| read_micro_region | Yes | No |
| read_municipal_seat | Yes | Super |
| read_municipality | Yes | No |
| read_region | Yes | Super |
| read_semiarid | Yes | Super |
| read_state | Yes | Super |
| read_statistical_grid | No | No |
| read_urban_area | Yes | Super |
| read_urban_concentrations | No | Super |
| read_weighting_area | Yes | No |
| list_geobr | Yes | Yes |
| lookup_muni | Yes | No |
| read_neighborhood | Yes | Yes |
# Release new version
```
poetry version [patch|minor|major]
poetry publish --build
```
%prep
%autosetup -n geobr-0.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-geobr -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.2.0-1
- Package Spec generated