%global _empty_manifest_terminate_build 0
Name: python-corpuscula
Version: 1.0.56
Release: 1
Summary: Toolkit that simplifies corpus processing
License: BSD
URL: https://github.com/fostroll/corpuscula
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/05/0a/5135585f53c4692201f286432b66b9b06c90569d877934eebfe97c8b7145/corpuscula-1.0.56.tar.gz
BuildArch: noarch
%description
RuMor: Russian Morphology project
Corpuscula: a python NLP library for corpus processing
[![PyPI Version](https://img.shields.io/pypi/v/corpuscula?color=blue)](https://pypi.org/project/corpuscula/)
[![Python Version](https://img.shields.io/pypi/pyversions/corpuscula?color=blue)](https://www.python.org/)
[![License: BSD-3](https://img.shields.io/badge/License-BSD-brightgreen.svg)](https://opensource.org/licenses/BSD-3-Clause)
A part of ***RuMor*** project. It contains tools to simplify corpus
processing. Highlights are:
* full [*CoNLL-U*](https://universaldependencies.org/format.html) support
(includes [*CoNLL-U Plus*](https://universaldependencies.org/ext-format.html))
* wrappers for known corpora of Russian language
* parser and wrapper for Russian part of *Wikipedia*
* *Corpus Dictionary* that can be used for further morphology processing
* simple database to keep named entities
## Installation
### pip
***Corpuscula*** supports *Python 3.5* or later. To install it via *pip*, run:
```sh
$ pip install corpuscula
```
If you currently have a previous version of ***Corpuscula*** installed, use:
```sh
$ pip install corpuscula -U
```
### From Source
Alternatively, you can also install ***Corpuscula*** from source of this *git
repository*:
```sh
$ git clone https://github.com/fostroll/corpuscula.git
$ cd corpuscula
$ pip install -e .
```
This gives you access to examples and data that are not included to the
*PyPI* package.
## Setup
After installation, you need to specify a directory where you prefer to store
downloaded corpora:
```python
>>> import corpuscula.corpus_utils as cu
>>> cu.set_root_dir() # We will keep corpora here
```
**NB:** it will create/update config file `.rumor` in your home directory.
If you won't set the root directory, ***Corpuscula*** will keep corpora
in the directory where it's installed.
## Usage
[*CoNLL-U* Support](https://github.com/fostroll/corpuscula/blob/master/doc/README_CONLLU.md)
[Management of Corpora](https://github.com/fostroll/corpuscula/blob/master/doc/README_CORPORA.md)
[Wrapper for *Wikipedia*](https://github.com/fostroll/corpuscula/blob/master/doc/README_WIKIPEDIA.md)
[*Corpus Dictionary*](https://github.com/fostroll/corpuscula/blob/master/doc/README_CDICT.md)
[Utilities](https://github.com/fostroll/corpuscula/blob/master/doc/README_UTILS.md)
[*Items* database](https://github.com/fostroll/corpuscula/blob/master/doc/README_ITEMS.md)
## Examples
You can find examples in the directory `examples` of our ***Corpuscula*** github
repository.
## License
***Corpuscula*** is released under the BSD License. See the
[LICENSE](https://github.com/fostroll/corpuscula/blob/master/LICENSE) file for
more details.
%package -n python3-corpuscula
Summary: Toolkit that simplifies corpus processing
Provides: python-corpuscula
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-corpuscula
RuMor: Russian Morphology project
Corpuscula: a python NLP library for corpus processing
[![PyPI Version](https://img.shields.io/pypi/v/corpuscula?color=blue)](https://pypi.org/project/corpuscula/)
[![Python Version](https://img.shields.io/pypi/pyversions/corpuscula?color=blue)](https://www.python.org/)
[![License: BSD-3](https://img.shields.io/badge/License-BSD-brightgreen.svg)](https://opensource.org/licenses/BSD-3-Clause)
A part of ***RuMor*** project. It contains tools to simplify corpus
processing. Highlights are:
* full [*CoNLL-U*](https://universaldependencies.org/format.html) support
(includes [*CoNLL-U Plus*](https://universaldependencies.org/ext-format.html))
* wrappers for known corpora of Russian language
* parser and wrapper for Russian part of *Wikipedia*
* *Corpus Dictionary* that can be used for further morphology processing
* simple database to keep named entities
## Installation
### pip
***Corpuscula*** supports *Python 3.5* or later. To install it via *pip*, run:
```sh
$ pip install corpuscula
```
If you currently have a previous version of ***Corpuscula*** installed, use:
```sh
$ pip install corpuscula -U
```
### From Source
Alternatively, you can also install ***Corpuscula*** from source of this *git
repository*:
```sh
$ git clone https://github.com/fostroll/corpuscula.git
$ cd corpuscula
$ pip install -e .
```
This gives you access to examples and data that are not included to the
*PyPI* package.
## Setup
After installation, you need to specify a directory where you prefer to store
downloaded corpora:
```python
>>> import corpuscula.corpus_utils as cu
>>> cu.set_root_dir() # We will keep corpora here
```
**NB:** it will create/update config file `.rumor` in your home directory.
If you won't set the root directory, ***Corpuscula*** will keep corpora
in the directory where it's installed.
## Usage
[*CoNLL-U* Support](https://github.com/fostroll/corpuscula/blob/master/doc/README_CONLLU.md)
[Management of Corpora](https://github.com/fostroll/corpuscula/blob/master/doc/README_CORPORA.md)
[Wrapper for *Wikipedia*](https://github.com/fostroll/corpuscula/blob/master/doc/README_WIKIPEDIA.md)
[*Corpus Dictionary*](https://github.com/fostroll/corpuscula/blob/master/doc/README_CDICT.md)
[Utilities](https://github.com/fostroll/corpuscula/blob/master/doc/README_UTILS.md)
[*Items* database](https://github.com/fostroll/corpuscula/blob/master/doc/README_ITEMS.md)
## Examples
You can find examples in the directory `examples` of our ***Corpuscula*** github
repository.
## License
***Corpuscula*** is released under the BSD License. See the
[LICENSE](https://github.com/fostroll/corpuscula/blob/master/LICENSE) file for
more details.
%package help
Summary: Development documents and examples for corpuscula
Provides: python3-corpuscula-doc
%description help
RuMor: Russian Morphology project
Corpuscula: a python NLP library for corpus processing
[![PyPI Version](https://img.shields.io/pypi/v/corpuscula?color=blue)](https://pypi.org/project/corpuscula/)
[![Python Version](https://img.shields.io/pypi/pyversions/corpuscula?color=blue)](https://www.python.org/)
[![License: BSD-3](https://img.shields.io/badge/License-BSD-brightgreen.svg)](https://opensource.org/licenses/BSD-3-Clause)
A part of ***RuMor*** project. It contains tools to simplify corpus
processing. Highlights are:
* full [*CoNLL-U*](https://universaldependencies.org/format.html) support
(includes [*CoNLL-U Plus*](https://universaldependencies.org/ext-format.html))
* wrappers for known corpora of Russian language
* parser and wrapper for Russian part of *Wikipedia*
* *Corpus Dictionary* that can be used for further morphology processing
* simple database to keep named entities
## Installation
### pip
***Corpuscula*** supports *Python 3.5* or later. To install it via *pip*, run:
```sh
$ pip install corpuscula
```
If you currently have a previous version of ***Corpuscula*** installed, use:
```sh
$ pip install corpuscula -U
```
### From Source
Alternatively, you can also install ***Corpuscula*** from source of this *git
repository*:
```sh
$ git clone https://github.com/fostroll/corpuscula.git
$ cd corpuscula
$ pip install -e .
```
This gives you access to examples and data that are not included to the
*PyPI* package.
## Setup
After installation, you need to specify a directory where you prefer to store
downloaded corpora:
```python
>>> import corpuscula.corpus_utils as cu
>>> cu.set_root_dir() # We will keep corpora here
```
**NB:** it will create/update config file `.rumor` in your home directory.
If you won't set the root directory, ***Corpuscula*** will keep corpora
in the directory where it's installed.
## Usage
[*CoNLL-U* Support](https://github.com/fostroll/corpuscula/blob/master/doc/README_CONLLU.md)
[Management of Corpora](https://github.com/fostroll/corpuscula/blob/master/doc/README_CORPORA.md)
[Wrapper for *Wikipedia*](https://github.com/fostroll/corpuscula/blob/master/doc/README_WIKIPEDIA.md)
[*Corpus Dictionary*](https://github.com/fostroll/corpuscula/blob/master/doc/README_CDICT.md)
[Utilities](https://github.com/fostroll/corpuscula/blob/master/doc/README_UTILS.md)
[*Items* database](https://github.com/fostroll/corpuscula/blob/master/doc/README_ITEMS.md)
## Examples
You can find examples in the directory `examples` of our ***Corpuscula*** github
repository.
## License
***Corpuscula*** is released under the BSD License. See the
[LICENSE](https://github.com/fostroll/corpuscula/blob/master/LICENSE) file for
more details.
%prep
%autosetup -n corpuscula-1.0.56
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-corpuscula -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.0.56-1
- Package Spec generated