%global _empty_manifest_terminate_build 0
Name: python-verbcalc
Version: 1.5.2b0
Release: 1
Summary: VerbCalc is a Python library that allows to perform calculations based on human speech.
License: BSD-3-Clause Licence
URL: https://github.com/ErykPiasecki07/VerbCalc
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/73/23/7e1f9dbe373a5c185ecebf80ce55a13322449c328a6b81da69c6bb73703a/verbcalc-1.5.2b0.tar.gz
BuildArch: noarch
%description
# VerbCalc
Python library for making calculations from natural language.
[![logo](https://github.com/ErykPiasecki07/VerbCalc/blob/main/extras/logo_small.png)](https://github.com/ErykPiasecki07/VerbCalc)
[![CircleCI](https://circleci.com/gh/ErykPiasecki07/VerbCalc/tree/main.svg?style=svg)](https://circleci.com/gh/ErykPiasecki07/VerbCalc/tree/main)
[![Documentation Status](https://readthedocs.org/projects/verbcalc/badge/?version=latest)](https://verbcalc.readthedocs.io/en/latest/?badge=latest)
### Can I use Verbcalc in my project?
Yes! See: [LICENSE](LICENSE)
### Can I contribute?
Yes! See: [CONTRIBUTING.md](CONTRIBUTING.md)
### What versions are currently supported and where can I report security vurnelability?
See: [SECURITY.md](SECURITY.md)
## Installation
`pip install verbcalc`
## Documentation
Documentation is available under: https://verbcalc.readthedocs.io
## Attributions
Thanks to Kinga Stefaniak for the project logo.
%package -n python3-verbcalc
Summary: VerbCalc is a Python library that allows to perform calculations based on human speech.
Provides: python-verbcalc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-verbcalc
# VerbCalc
Python library for making calculations from natural language.
[![logo](https://github.com/ErykPiasecki07/VerbCalc/blob/main/extras/logo_small.png)](https://github.com/ErykPiasecki07/VerbCalc)
[![CircleCI](https://circleci.com/gh/ErykPiasecki07/VerbCalc/tree/main.svg?style=svg)](https://circleci.com/gh/ErykPiasecki07/VerbCalc/tree/main)
[![Documentation Status](https://readthedocs.org/projects/verbcalc/badge/?version=latest)](https://verbcalc.readthedocs.io/en/latest/?badge=latest)
### Can I use Verbcalc in my project?
Yes! See: [LICENSE](LICENSE)
### Can I contribute?
Yes! See: [CONTRIBUTING.md](CONTRIBUTING.md)
### What versions are currently supported and where can I report security vurnelability?
See: [SECURITY.md](SECURITY.md)
## Installation
`pip install verbcalc`
## Documentation
Documentation is available under: https://verbcalc.readthedocs.io
## Attributions
Thanks to Kinga Stefaniak for the project logo.
%package help
Summary: Development documents and examples for verbcalc
Provides: python3-verbcalc-doc
%description help
# VerbCalc
Python library for making calculations from natural language.
[![logo](https://github.com/ErykPiasecki07/VerbCalc/blob/main/extras/logo_small.png)](https://github.com/ErykPiasecki07/VerbCalc)
[![CircleCI](https://circleci.com/gh/ErykPiasecki07/VerbCalc/tree/main.svg?style=svg)](https://circleci.com/gh/ErykPiasecki07/VerbCalc/tree/main)
[![Documentation Status](https://readthedocs.org/projects/verbcalc/badge/?version=latest)](https://verbcalc.readthedocs.io/en/latest/?badge=latest)
### Can I use Verbcalc in my project?
Yes! See: [LICENSE](LICENSE)
### Can I contribute?
Yes! See: [CONTRIBUTING.md](CONTRIBUTING.md)
### What versions are currently supported and where can I report security vurnelability?
See: [SECURITY.md](SECURITY.md)
## Installation
`pip install verbcalc`
## Documentation
Documentation is available under: https://verbcalc.readthedocs.io
## Attributions
Thanks to Kinga Stefaniak for the project logo.
%prep
%autosetup -n verbcalc-1.5.2b0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-verbcalc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.5.2b0-1
- Package Spec generated