%global _empty_manifest_terminate_build 0
Name: python-webull
Version: 0.6.1
Release: 1
Summary: The unofficial python interface for the WeBull API
License: MIT
URL: https://github.com/tedchou12/webull.git
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/33/b9/ba3e264b856dfa3370fa922f8cb330b7438f8bf526a431d3a3c8fb88898b/webull-0.6.1.tar.gz
BuildArch: noarch
%description
# Webull
APIs for webull, you are free to use, but code not extensively checked and Webull may update the APIs or the endpoints at any time.
https://www.webull.com/
Feel free to sign-up for a webull account through here, you will be able to help me to get referral stocks. You can also get 2 stocks for free:
https://www.webull.com/activity?inviteCode=oqJvTY3rJNyR&source=invite_gw&inviteSource=wb_oversea
Sorry for procrastinating in answering the questions and updating the packages. But if you really like the package or really like to motivate me. Materialist appreciations would really motivate me to responding you faster 😂:
[](https://www.buymeacoffee.com/tedchou12)
# Install
```
pip install webull
or
python3 -m pip install webull
```
# Run tests
```
pip install pytest requests_mock
python -m pytest -v
```
# Usage
How to login with your email
Webull has made Multi-Factor Authentication (MFA) mandatory since 2020/05/28, if you are having issues, take a look at here:
https://github.com/tedchou12/webull/wiki/MFA-&-Security
Or Authenticate without Login completely 2021/02/14:
https://github.com/tedchou12/webull/wiki/Workaround-for-Login
```
from webull import webull # for paper trading, import 'paper_webull'
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
```
How to login with your mobile
```
from webull import webull # for paper trading, import 'paper_webull'
wb = webull()
wb.login('+1-1112223333', 'pa$$w0rd') # phone must be in format +[country_code]-[your number]
```
How to order stock
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
wb.place_order(stock='AAPL', price=90.0, qty=2)
```
How to check standing orders
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
orders = wb.get_current_orders()
```
How to cancel standing orders
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
wb.cancel_all_orders()
```
# FAQ
Thank you so much, I have received Emails and messages on reddit from many traders/developers that liked this project. Thanks to many that helped and contributed to this project too! There are quite a few repeated questions on the same topic, so I have utilized the Wiki section for them. If you have troubles regarding *Login/MFA Logins*, *Real Time Quote Data*, *What is Trade PIN/Trade Token*, or *How to buy me a coffee* please take a look at the Wiki pages first. https://github.com/tedchou12/webull/wiki
# Stream Quotes
https://github.com/tedchou12/webull/wiki/How-to-use-Streaming-Quotes%3F
# Disclaimer
This software is not extensively tested, please use at your own risk.
# Developers
If you are interested to join and help me improve this, feel free to message me.
%package -n python3-webull
Summary: The unofficial python interface for the WeBull API
Provides: python-webull
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-webull
# Webull
APIs for webull, you are free to use, but code not extensively checked and Webull may update the APIs or the endpoints at any time.
https://www.webull.com/
Feel free to sign-up for a webull account through here, you will be able to help me to get referral stocks. You can also get 2 stocks for free:
https://www.webull.com/activity?inviteCode=oqJvTY3rJNyR&source=invite_gw&inviteSource=wb_oversea
Sorry for procrastinating in answering the questions and updating the packages. But if you really like the package or really like to motivate me. Materialist appreciations would really motivate me to responding you faster 😂:
[](https://www.buymeacoffee.com/tedchou12)
# Install
```
pip install webull
or
python3 -m pip install webull
```
# Run tests
```
pip install pytest requests_mock
python -m pytest -v
```
# Usage
How to login with your email
Webull has made Multi-Factor Authentication (MFA) mandatory since 2020/05/28, if you are having issues, take a look at here:
https://github.com/tedchou12/webull/wiki/MFA-&-Security
Or Authenticate without Login completely 2021/02/14:
https://github.com/tedchou12/webull/wiki/Workaround-for-Login
```
from webull import webull # for paper trading, import 'paper_webull'
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
```
How to login with your mobile
```
from webull import webull # for paper trading, import 'paper_webull'
wb = webull()
wb.login('+1-1112223333', 'pa$$w0rd') # phone must be in format +[country_code]-[your number]
```
How to order stock
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
wb.place_order(stock='AAPL', price=90.0, qty=2)
```
How to check standing orders
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
orders = wb.get_current_orders()
```
How to cancel standing orders
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
wb.cancel_all_orders()
```
# FAQ
Thank you so much, I have received Emails and messages on reddit from many traders/developers that liked this project. Thanks to many that helped and contributed to this project too! There are quite a few repeated questions on the same topic, so I have utilized the Wiki section for them. If you have troubles regarding *Login/MFA Logins*, *Real Time Quote Data*, *What is Trade PIN/Trade Token*, or *How to buy me a coffee* please take a look at the Wiki pages first. https://github.com/tedchou12/webull/wiki
# Stream Quotes
https://github.com/tedchou12/webull/wiki/How-to-use-Streaming-Quotes%3F
# Disclaimer
This software is not extensively tested, please use at your own risk.
# Developers
If you are interested to join and help me improve this, feel free to message me.
%package help
Summary: Development documents and examples for webull
Provides: python3-webull-doc
%description help
# Webull
APIs for webull, you are free to use, but code not extensively checked and Webull may update the APIs or the endpoints at any time.
https://www.webull.com/
Feel free to sign-up for a webull account through here, you will be able to help me to get referral stocks. You can also get 2 stocks for free:
https://www.webull.com/activity?inviteCode=oqJvTY3rJNyR&source=invite_gw&inviteSource=wb_oversea
Sorry for procrastinating in answering the questions and updating the packages. But if you really like the package or really like to motivate me. Materialist appreciations would really motivate me to responding you faster 😂:
[](https://www.buymeacoffee.com/tedchou12)
# Install
```
pip install webull
or
python3 -m pip install webull
```
# Run tests
```
pip install pytest requests_mock
python -m pytest -v
```
# Usage
How to login with your email
Webull has made Multi-Factor Authentication (MFA) mandatory since 2020/05/28, if you are having issues, take a look at here:
https://github.com/tedchou12/webull/wiki/MFA-&-Security
Or Authenticate without Login completely 2021/02/14:
https://github.com/tedchou12/webull/wiki/Workaround-for-Login
```
from webull import webull # for paper trading, import 'paper_webull'
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
```
How to login with your mobile
```
from webull import webull # for paper trading, import 'paper_webull'
wb = webull()
wb.login('+1-1112223333', 'pa$$w0rd') # phone must be in format +[country_code]-[your number]
```
How to order stock
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
wb.place_order(stock='AAPL', price=90.0, qty=2)
```
How to check standing orders
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
orders = wb.get_current_orders()
```
How to cancel standing orders
```
from webull import webull
wb = webull()
wb.login('test@test.com', 'pa$$w0rd')
wb.get_trade_token('123456')
wb.cancel_all_orders()
```
# FAQ
Thank you so much, I have received Emails and messages on reddit from many traders/developers that liked this project. Thanks to many that helped and contributed to this project too! There are quite a few repeated questions on the same topic, so I have utilized the Wiki section for them. If you have troubles regarding *Login/MFA Logins*, *Real Time Quote Data*, *What is Trade PIN/Trade Token*, or *How to buy me a coffee* please take a look at the Wiki pages first. https://github.com/tedchou12/webull/wiki
# Stream Quotes
https://github.com/tedchou12/webull/wiki/How-to-use-Streaming-Quotes%3F
# Disclaimer
This software is not extensively tested, please use at your own risk.
# Developers
If you are interested to join and help me improve this, feel free to message me.
%prep
%autosetup -n webull-0.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-webull -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.6.1-1
- Package Spec generated