%global _empty_manifest_terminate_build 0
Name: python-fightchurn
Version: 1.0.8
Release: 1
Summary: Code from the book Fighting Churn With Data
License: MIT License
URL: https://github.com/carl24k/fight-churn
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b4/cc/43e4827a8fe5434f03a8861999ffe504f8cd008f56a9794b728c0911f6a4/fightchurn-1.0.8.tar.gz
BuildArch: noarch
Requires: python3-bleach
Requires: python3-build
Requires: python3-certifi
Requires: python3-chardet
Requires: python3-cloudpickle
Requires: python3-colorama
Requires: python3-cycler
Requires: python3-docutils
Requires: python3-greenlet
Requires: python3-idna
Requires: python3-importlib-metadata
Requires: python3-joblib
Requires: python3-keyring
Requires: python3-kiwisolver
Requires: python3-llvmlite
Requires: python3-matplotlib
Requires: python3-numba
Requires: python3-numpy
Requires: python3-packaging
Requires: python3-pandas
Requires: python3-patsy
Requires: python3-pep517
Requires: python3-Pillow
Requires: python3-pkginfo
Requires: python3-postgres
Requires: python3-psycopg2-binary
Requires: python3-psycopg2-pool
Requires: python3-Pygments
Requires: python3-pyparsing
Requires: python3-dateutil
Requires: python3-pytz
Requires: python3-pytest
Requires: python3-readme-renderer
Requires: python3-requests
Requires: python3-requests-toolbelt
Requires: python3-rfc3986
Requires: python3-scikit-learn
Requires: python3-scipy
Requires: python3-shap
Requires: python3-six
Requires: python3-slicer
Requires: python3-SQLAlchemy
Requires: python3-statsmodels
Requires: python3-threadpoolctl
Requires: python3-toml
Requires: python3-tqdm
Requires: python3-twine
Requires: python3-urllib3
Requires: python3-webencodings
Requires: python3-xgboost
Requires: python3-zipp
%description
# fight-churn
This is code for the book "***Fighting Churn With Data: Science and strategy for keeping your customers***"; the book serves as a detailed guide to the code. You can get more information at:
- https://www.manning.com/books/fighting-churn-with-data, the publisher (Manning Publications)'s page for the book
- http://www.fightchurnwithdata.com, the author's blog site
- https://www.twitch.tv/carl24k_datascience, the author's live stream
- [The author's You Tube Channel, Fighting Churn With Data Science](https://www.youtube.com/channel/UCGVh5vcL4AAxErNdqJrr_Sw/featured)
This page contains the most up to date setup instructions.
## Note from the Author
Before you can load data or run the code you have to do some setup on your system. If you never have done this before it may seem like a lot of work, and it kind of is, but this amount of setup is routine when you begin to work with a new technology. These setup instructions should work for most people using either shell Python, Jupyter Notebook, or an IDE, on either Mac or Windows. That said, I must apologize because I am neither an expert in PostgreSQL nor an expert in Python, but I am about to give a lot of advice on how to setup and use these technologies - if you find I am not doing things the best way, or just not how you would have done it, please be patient. If you want to make things better please help help out! :)
## **Setup Instructions**
*WARNING TO PYPI USERS: None of the internal links in this document work on the pypi.org website! [To use the internal links in this README view it on github](https://github.com/carl24k/fight-churn).*
### Pre-Requisite Setup
Python and PostgreSQL are required.
- [**Pre-Requisites - Start Here!**](./readme_files/prereq.md)
### Code Setup
After the pre-requesisites, you have a choice on how to run the Fighting Churn With Data Code:
- [Command Line Setup](./readme_files/cmdline.md) : The fastest and easiest way to get started, using a `pip` Python package installation. This is great if you want to run the code and see the output, but you do not want to change the code or run it line by line.
- [Jupyter Notebook Setup](readme_files/notebook.md) : This is another way to get started quickly, if you already have Jupyter Notebooks installed.
- [Developers IDE Setup](readme_files/ide.md) : This method takes more time, but allows you to run
the code line by line in a debugger, or change it. (If you are a professional developer
planning to really use the code for your company, this is for you.)
## Errata for the 1st Printing
This version of the README if for the the code released with the fightchurn pip package in September 2021. In this version there have been some modifications to the paths described in the first printing of *Fighting Churn With Data* to enable packaging the Python code. The following two differences summarize the changes:
- To run the code listings, the first printing of the book refers to the script `fight-churn/listings/py/run_churn_list.py` : the path in the *current* code is `fight-churn/fightchurn/run_churn_listing.py`
- To generate the data, the first printing of the book refers to scripts under `fight-churn/data-generation/` : the path in the current code is `fight-churn/fightchurn/datagen`
[Complete details of the errata are described here](readme_files/errata.md).
## Extras
There is also some extra code from the development phase of the book, which are partially documented on [this page.](readme_files/extras.md)
## Authors
* **Carl Gold** [carl24k](https://github.com/carl24k)
## License
This project is licensed under the MIT License - see the [LICENSE.md](LICENSE.md) file for details.
%package -n python3-fightchurn
Summary: Code from the book Fighting Churn With Data
Provides: python-fightchurn
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fightchurn
# fight-churn
This is code for the book "***Fighting Churn With Data: Science and strategy for keeping your customers***"; the book serves as a detailed guide to the code. You can get more information at:
- https://www.manning.com/books/fighting-churn-with-data, the publisher (Manning Publications)'s page for the book
- http://www.fightchurnwithdata.com, the author's blog site
- https://www.twitch.tv/carl24k_datascience, the author's live stream
- [The author's You Tube Channel, Fighting Churn With Data Science](https://www.youtube.com/channel/UCGVh5vcL4AAxErNdqJrr_Sw/featured)
This page contains the most up to date setup instructions.
## Note from the Author
Before you can load data or run the code you have to do some setup on your system. If you never have done this before it may seem like a lot of work, and it kind of is, but this amount of setup is routine when you begin to work with a new technology. These setup instructions should work for most people using either shell Python, Jupyter Notebook, or an IDE, on either Mac or Windows. That said, I must apologize because I am neither an expert in PostgreSQL nor an expert in Python, but I am about to give a lot of advice on how to setup and use these technologies - if you find I am not doing things the best way, or just not how you would have done it, please be patient. If you want to make things better please help help out! :)
## **Setup Instructions**
*WARNING TO PYPI USERS: None of the internal links in this document work on the pypi.org website! [To use the internal links in this README view it on github](https://github.com/carl24k/fight-churn).*
### Pre-Requisite Setup
Python and PostgreSQL are required.
- [**Pre-Requisites - Start Here!**](./readme_files/prereq.md)
### Code Setup
After the pre-requesisites, you have a choice on how to run the Fighting Churn With Data Code:
- [Command Line Setup](./readme_files/cmdline.md) : The fastest and easiest way to get started, using a `pip` Python package installation. This is great if you want to run the code and see the output, but you do not want to change the code or run it line by line.
- [Jupyter Notebook Setup](readme_files/notebook.md) : This is another way to get started quickly, if you already have Jupyter Notebooks installed.
- [Developers IDE Setup](readme_files/ide.md) : This method takes more time, but allows you to run
the code line by line in a debugger, or change it. (If you are a professional developer
planning to really use the code for your company, this is for you.)
## Errata for the 1st Printing
This version of the README if for the the code released with the fightchurn pip package in September 2021. In this version there have been some modifications to the paths described in the first printing of *Fighting Churn With Data* to enable packaging the Python code. The following two differences summarize the changes:
- To run the code listings, the first printing of the book refers to the script `fight-churn/listings/py/run_churn_list.py` : the path in the *current* code is `fight-churn/fightchurn/run_churn_listing.py`
- To generate the data, the first printing of the book refers to scripts under `fight-churn/data-generation/` : the path in the current code is `fight-churn/fightchurn/datagen`
[Complete details of the errata are described here](readme_files/errata.md).
## Extras
There is also some extra code from the development phase of the book, which are partially documented on [this page.](readme_files/extras.md)
## Authors
* **Carl Gold** [carl24k](https://github.com/carl24k)
## License
This project is licensed under the MIT License - see the [LICENSE.md](LICENSE.md) file for details.
%package help
Summary: Development documents and examples for fightchurn
Provides: python3-fightchurn-doc
%description help
# fight-churn
This is code for the book "***Fighting Churn With Data: Science and strategy for keeping your customers***"; the book serves as a detailed guide to the code. You can get more information at:
- https://www.manning.com/books/fighting-churn-with-data, the publisher (Manning Publications)'s page for the book
- http://www.fightchurnwithdata.com, the author's blog site
- https://www.twitch.tv/carl24k_datascience, the author's live stream
- [The author's You Tube Channel, Fighting Churn With Data Science](https://www.youtube.com/channel/UCGVh5vcL4AAxErNdqJrr_Sw/featured)
This page contains the most up to date setup instructions.
## Note from the Author
Before you can load data or run the code you have to do some setup on your system. If you never have done this before it may seem like a lot of work, and it kind of is, but this amount of setup is routine when you begin to work with a new technology. These setup instructions should work for most people using either shell Python, Jupyter Notebook, or an IDE, on either Mac or Windows. That said, I must apologize because I am neither an expert in PostgreSQL nor an expert in Python, but I am about to give a lot of advice on how to setup and use these technologies - if you find I am not doing things the best way, or just not how you would have done it, please be patient. If you want to make things better please help help out! :)
## **Setup Instructions**
*WARNING TO PYPI USERS: None of the internal links in this document work on the pypi.org website! [To use the internal links in this README view it on github](https://github.com/carl24k/fight-churn).*
### Pre-Requisite Setup
Python and PostgreSQL are required.
- [**Pre-Requisites - Start Here!**](./readme_files/prereq.md)
### Code Setup
After the pre-requesisites, you have a choice on how to run the Fighting Churn With Data Code:
- [Command Line Setup](./readme_files/cmdline.md) : The fastest and easiest way to get started, using a `pip` Python package installation. This is great if you want to run the code and see the output, but you do not want to change the code or run it line by line.
- [Jupyter Notebook Setup](readme_files/notebook.md) : This is another way to get started quickly, if you already have Jupyter Notebooks installed.
- [Developers IDE Setup](readme_files/ide.md) : This method takes more time, but allows you to run
the code line by line in a debugger, or change it. (If you are a professional developer
planning to really use the code for your company, this is for you.)
## Errata for the 1st Printing
This version of the README if for the the code released with the fightchurn pip package in September 2021. In this version there have been some modifications to the paths described in the first printing of *Fighting Churn With Data* to enable packaging the Python code. The following two differences summarize the changes:
- To run the code listings, the first printing of the book refers to the script `fight-churn/listings/py/run_churn_list.py` : the path in the *current* code is `fight-churn/fightchurn/run_churn_listing.py`
- To generate the data, the first printing of the book refers to scripts under `fight-churn/data-generation/` : the path in the current code is `fight-churn/fightchurn/datagen`
[Complete details of the errata are described here](readme_files/errata.md).
## Extras
There is also some extra code from the development phase of the book, which are partially documented on [this page.](readme_files/extras.md)
## Authors
* **Carl Gold** [carl24k](https://github.com/carl24k)
## License
This project is licensed under the MIT License - see the [LICENSE.md](LICENSE.md) file for details.
%prep
%autosetup -n fightchurn-1.0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fightchurn -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.0.8-1
- Package Spec generated