%global _empty_manifest_terminate_build 0
Name: python-xmlwitch
Version: 0.3
Release: 1
Summary: xmlwitch offers Pythonic XML generation through context generators
License: BSD
URL: http://github.com/galvez/xmlwitch/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0a/d4/02632fba90c3883d86d1f6c28db5fca5707498619d8e9efc9b98a377063c/xmlwitch-0.3.tar.gz
BuildArch: noarch
%description
xmlwitch offers Pythonic XML generation through context generators in a
minimalist implementation with less than 100 lines of code. BSD-licensed.
Usage
`````
::
import xmlwitch
xml = xmlwitch.Builder(version='1.0', encoding='utf-8')
with xml.feed(xmlns='http://www.w3.org/2005/Atom'):
xml.title('Example Feed')
xml.updated('2003-12-13T18:30:02Z')
with xml.author:
xml.name('John Doe')
xml.id('urn:uuid:60a76c80-d399-11d9-b93C-0003939e0af6')
with xml.entry:
xml.title('Atom-Powered Robots Run Amok')
xml.id('urn:uuid:1225c695-cfb8-4ebb-aaaa-80da344efa6a')
xml.updated('2003-12-13T18:30:02Z')
xml.summary('Some text.')
print(xml)
Setup
`````
::
$ pip install xmlwitch # or
$ easy_install xmlwitch # or
$ cd xmlwitch-0.3; python setup.py install
Links
`````
* `Development repository `_
* `Author's website `_
%package -n python3-xmlwitch
Summary: xmlwitch offers Pythonic XML generation through context generators
Provides: python-xmlwitch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-xmlwitch
xmlwitch offers Pythonic XML generation through context generators in a
minimalist implementation with less than 100 lines of code. BSD-licensed.
Usage
`````
::
import xmlwitch
xml = xmlwitch.Builder(version='1.0', encoding='utf-8')
with xml.feed(xmlns='http://www.w3.org/2005/Atom'):
xml.title('Example Feed')
xml.updated('2003-12-13T18:30:02Z')
with xml.author:
xml.name('John Doe')
xml.id('urn:uuid:60a76c80-d399-11d9-b93C-0003939e0af6')
with xml.entry:
xml.title('Atom-Powered Robots Run Amok')
xml.id('urn:uuid:1225c695-cfb8-4ebb-aaaa-80da344efa6a')
xml.updated('2003-12-13T18:30:02Z')
xml.summary('Some text.')
print(xml)
Setup
`````
::
$ pip install xmlwitch # or
$ easy_install xmlwitch # or
$ cd xmlwitch-0.3; python setup.py install
Links
`````
* `Development repository `_
* `Author's website `_
%package help
Summary: Development documents and examples for xmlwitch
Provides: python3-xmlwitch-doc
%description help
xmlwitch offers Pythonic XML generation through context generators in a
minimalist implementation with less than 100 lines of code. BSD-licensed.
Usage
`````
::
import xmlwitch
xml = xmlwitch.Builder(version='1.0', encoding='utf-8')
with xml.feed(xmlns='http://www.w3.org/2005/Atom'):
xml.title('Example Feed')
xml.updated('2003-12-13T18:30:02Z')
with xml.author:
xml.name('John Doe')
xml.id('urn:uuid:60a76c80-d399-11d9-b93C-0003939e0af6')
with xml.entry:
xml.title('Atom-Powered Robots Run Amok')
xml.id('urn:uuid:1225c695-cfb8-4ebb-aaaa-80da344efa6a')
xml.updated('2003-12-13T18:30:02Z')
xml.summary('Some text.')
print(xml)
Setup
`````
::
$ pip install xmlwitch # or
$ easy_install xmlwitch # or
$ cd xmlwitch-0.3; python setup.py install
Links
`````
* `Development repository `_
* `Author's website `_
%prep
%autosetup -n xmlwitch-0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-xmlwitch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.3-1
- Package Spec generated