%global _empty_manifest_terminate_build 0 Name: python-seliky Version: 2.16 Release: 1 Summary: a better ui autotest lib based on selenium, compatible with robot framework License: MIT License URL: https://gitee.com/teark/seliky.git Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c0/8f/011826c4a7537838ffcd5608b2e809654df29ed7a5c921864ca1365e57d8/seliky-2.16.tar.gz BuildArch: noarch Requires: python3-selenium Requires: python3-webdriver-manager %description

English Introduction

3 minutes to learn about seliky

seliky: born for UI automation. A selenium encapsulation library is simpler and easier to use than the native syntax. Its main features are as follows:


#### 1. It supports elastic positioning and can deal with finite and changeable elements #### 2. The current element will highlight and flash. When executing, you can see which element is clicked with the naked eye #### 3. Compatible with robot framework #### 4. Encapsulate a large number of common forms in UI automation, which can be directly used in the project directly #### 5. When the driver version does not match, the driver will be automatically downloaded #### 6. More stable positioning mechanism, waiting mechanism, etc.
See the built-in case demo.py to learn more...
Installation method: pip install seliky - i https://pypi.org/simple


中文介绍

3 分钟了解 seliky

seliky:为ui自动化而生。一个selenium封装库,比起原生语法更简单好用,主要特性如下:


#### 1. 支持弹性定位,可以应对有穷性可变化的元素 #### 2. 当前元素会高亮闪烁。在执行时能够肉眼看到点了哪个元素 #### 3. 可兼容robotframework框架 #### 4. 封装大量ui自动化中的通用形式,可在项目中直接运用无需再写 #### 5. 当driver版本不匹配时,会自动下载driver #### 6. 更加稳定的定位机制、等待机制等
查看内置案例 demo.py 了解更多...
安装方式:pip install seliky -i https://pypi.org/simple %package -n python3-seliky Summary: a better ui autotest lib based on selenium, compatible with robot framework Provides: python-seliky BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-seliky

English Introduction

3 minutes to learn about seliky

seliky: born for UI automation. A selenium encapsulation library is simpler and easier to use than the native syntax. Its main features are as follows:


#### 1. It supports elastic positioning and can deal with finite and changeable elements #### 2. The current element will highlight and flash. When executing, you can see which element is clicked with the naked eye #### 3. Compatible with robot framework #### 4. Encapsulate a large number of common forms in UI automation, which can be directly used in the project directly #### 5. When the driver version does not match, the driver will be automatically downloaded #### 6. More stable positioning mechanism, waiting mechanism, etc.
See the built-in case demo.py to learn more...
Installation method: pip install seliky - i https://pypi.org/simple


中文介绍

3 分钟了解 seliky

seliky:为ui自动化而生。一个selenium封装库,比起原生语法更简单好用,主要特性如下:


#### 1. 支持弹性定位,可以应对有穷性可变化的元素 #### 2. 当前元素会高亮闪烁。在执行时能够肉眼看到点了哪个元素 #### 3. 可兼容robotframework框架 #### 4. 封装大量ui自动化中的通用形式,可在项目中直接运用无需再写 #### 5. 当driver版本不匹配时,会自动下载driver #### 6. 更加稳定的定位机制、等待机制等
查看内置案例 demo.py 了解更多...
安装方式:pip install seliky -i https://pypi.org/simple %package help Summary: Development documents and examples for seliky Provides: python3-seliky-doc %description help

English Introduction

3 minutes to learn about seliky

seliky: born for UI automation. A selenium encapsulation library is simpler and easier to use than the native syntax. Its main features are as follows:


#### 1. It supports elastic positioning and can deal with finite and changeable elements #### 2. The current element will highlight and flash. When executing, you can see which element is clicked with the naked eye #### 3. Compatible with robot framework #### 4. Encapsulate a large number of common forms in UI automation, which can be directly used in the project directly #### 5. When the driver version does not match, the driver will be automatically downloaded #### 6. More stable positioning mechanism, waiting mechanism, etc.
See the built-in case demo.py to learn more...
Installation method: pip install seliky - i https://pypi.org/simple


中文介绍

3 分钟了解 seliky

seliky:为ui自动化而生。一个selenium封装库,比起原生语法更简单好用,主要特性如下:


#### 1. 支持弹性定位,可以应对有穷性可变化的元素 #### 2. 当前元素会高亮闪烁。在执行时能够肉眼看到点了哪个元素 #### 3. 可兼容robotframework框架 #### 4. 封装大量ui自动化中的通用形式,可在项目中直接运用无需再写 #### 5. 当driver版本不匹配时,会自动下载driver #### 6. 更加稳定的定位机制、等待机制等
查看内置案例 demo.py 了解更多...
安装方式:pip install seliky -i https://pypi.org/simple %prep %autosetup -n seliky-2.16 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-seliky -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue May 30 2023 Python_Bot - 2.16-1 - Package Spec generated